plusuncold
Posts: 9
Joined: Mon Jan 28, 2013 1:24 am

[Solved] apt-get "404 Not Found"

Wed Jun 10, 2015 7:25 pm

Hi, I've got 2 Pis in the house (an early B and a Pi2) and on both I'm getting problems when using apt-get to upgrade or install packages. Before upgrading I've used 'sudo apt-get update'.

The issue seems to be with packages from the raspbian.org repo.

Here's the output from 'sudo apt-get update' on one of the Pis:
pi@raspberrypi:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
epiphany-browser libfreetype6 libfreetype6-dev lxpanel lxpanel-data minecraft-pi
raspberrypi-ui-mods wolfram-engine
The following packages will be upgraded:
cups-bsd cups-client cups-common fuse get-iplayer libapache2-mod-php5 libcups2
libcupsimage2 libfuse2 php5 php5-cli php5-common
12 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 203 kB/7,475 kB of archives.
After this operation, 297 kB disk space will be freed.
Do you want to continue [Y/n]? y
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main fuse armhf 2.9.0-2+deb7u2
404 Not Found
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libfuse2 armhf 2.9.0-2+deb7u2
404 Not Found
Failed to fetch http://mirrordirector.raspbian.org/rasp ... _armhf.deb 404 Not Found
Failed to fetch http://mirrordirector.raspbian.org/rasp ... _armhf.deb 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
and the /etc/apt/sources.list:
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
--fix-missing doesn't seem to help either
Last edited by plusuncold on Wed Jun 10, 2015 9:15 pm, edited 1 time in total.

plugwash
Forum Moderator
Forum Moderator
Posts: 3651
Joined: Wed Dec 28, 2011 11:45 pm

Re: apt-get "404 Not Found"

Wed Jun 10, 2015 7:35 pm

Can you please try

wget http://mirrordirector.raspbian.org/raspbian/pool/main/f/fuse/fuse_2.9.0-2+deb7u2_armhf.deb

And post the complete output.

plusuncold
Posts: 9
Joined: Mon Jan 28, 2013 1:24 am

Re: apt-get "404 Not Found"

Wed Jun 10, 2015 7:52 pm

This is the command and the output:
pi@raspberrypi:~$ wget http://mirrordirector.raspbian.org/rasp ... _armhf.deb
--2015-06-10 19:49:59-- http://mirrordirector.raspbian.org/rasp ... _armhf.deb
Resolving mirrordirector.raspbian.org (mirrordirector.raspbian.org)... 5.153.225.207, 2001:41c9:1:3ce::11
Connecting to mirrordirector.raspbian.org (mirrordirector.raspbian.org)|5.153.225.207|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://mirror.mythic-beasts.com/raspbia ... _armhf.deb [following]
--2015-06-10 19:49:59-- http://mirror.mythic-beasts.com/raspbia ... _armhf.deb
Resolving mirror.mythic-beasts.com (mirror.mythic-beasts.com)... 93.93.131.18, 2a00:1098:0:86:1000::25
Connecting to mirror.mythic-beasts.com (mirror.mythic-beasts.com)|93.93.131.18|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-06-10 19:49:59 ERROR 404: Not Found.

plugwash
Forum Moderator
Forum Moderator
Posts: 3651
Joined: Wed Dec 28, 2011 11:45 pm

Re: apt-get "404 Not Found"

Wed Jun 10, 2015 8:32 pm

Thanks, i've disabled redirections to the mirror in question and contacted it's admins.

plusuncold
Posts: 9
Joined: Mon Jan 28, 2013 1:24 am

Re: apt-get "404 Not Found"

Wed Jun 10, 2015 9:14 pm

It's working now! Thanks for the help!

Benny_H88
Posts: 1
Joined: Wed Jun 17, 2015 1:29 am

Re: [Solved] apt-get "404 Not Found"

Wed Jun 17, 2015 1:37 am

While trying to install ifuse

Sudo aptitude install ifuse

I get err http://mirrordirector.raspbian.org/raspbian/ wheezy/main fuse-utils all 2.9.0-2+deb7ul
404 Not Found

E: Failed to fetch http://mirrordirector.raspbian.org/rasp ... ul_all.deb: 404 Not Found

plugwash
Forum Moderator
Forum Moderator
Posts: 3651
Joined: Wed Dec 28, 2011 11:45 pm

Re: [Solved] apt-get "404 Not Found"

Wed Jun 17, 2015 12:23 pm

Benny_H88 wrote:While trying to install ifuse

Sudo aptitude install ifuse

I get err http://mirrordirector.raspbian.org/raspbian/ wheezy/main fuse-utils all 2.9.0-2+deb7ul
404 Not Found

E: Failed to fetch http://mirrordirector.raspbian.org/rasp ... ul_all.deb: 404 Not Found
You need to run apt-get update to get the latest package lists.

Return to “Raspberry Pi OS”