Page 1 of 1

Chromium Iceweasel won't play mp3

Posted: Wed May 27, 2015 8:45 pm
by kevins7189
I'm having sound issues in Chromium and Iceweasel. I get sound in flash, but when I try to play an mp3 in chromium there is no sound. Mp3 works in epiphany.
I thought chromium was smart enough to play mp3 but I guess not? Googling led me to a chromium ffmpeg that does not exist in raspian.

Any ideas?

Re: Chromium Iceweasel won't play mp3

Posted: Thu May 28, 2015 12:47 am
by elatllat
The raspberrypi foundation chose to optimize that other browser instead of chromium maybe due to the memory limitations of pre B2 boards. So a lot of chromium features are disabled on the armv6 build and it's a really old version.

Re: Chromium Iceweasel won't play mp3

Posted: Thu May 28, 2015 4:51 am
by fruitoftheloom
kevins7189 wrote:I'm having sound issues in Chromium and Iceweasel. I get sound in flash, but when I try to play an mp3 in chromium there is no sound. Mp3 works in epiphany.
I thought chromium was smart enough to play mp3 but I guess not? Googling led me to a chromium ffmpeg that does not exist in raspian.

Any ideas?
IF you have installed Raspbian forget Flash as it is not natively supported.

IF you have installed Raspbian then maybe use kweb for media viewtopic.php?f=66&t=40860

Re: Chromium Iceweasel won't play mp3

Posted: Thu May 28, 2015 4:02 pm
by kevins7189
kweb doesn't play sound either. kweb gtk3 doesn't seem to even work with javascript.
Basically the web page is php/javascript playing an mp3.
Epiphahy works, but crashes alot.
I don't understand why chromium and iceweasel won't play sound, but will through pepperflash.

Re: Chromium Iceweasel won't play mp3

Posted: Thu May 28, 2015 4:13 pm
by gkreidl
kevins7189 wrote:kweb doesn't play sound either. kweb gtk3 doesn't seem to even work with javascript.
Basically the web page is php/javascript playing an mp3.
Epiphahy works, but crashes alot.
I don't understand why chromium and iceweasel won't play sound, but will through pepperflash.
Of course kweb does play sound and even mp3 within the browser, if you disable omxplayer. And of course it will work with Javascript, if you enable it.

Re: Chromium Iceweasel won't play mp3

Posted: Sun May 31, 2015 1:53 pm
by kevins7189
any idea why Linaro doesn't have any of these problems? Out-of-the-box Chromium on Linaro works perfectly and as expected.

Re: Chromium Iceweasel won't play mp3

Posted: Sun May 31, 2015 2:03 pm
by gkreidl
kevins7189 wrote:any idea why Linaro doesn't have any of these problems? Out-of-the-box Chromium on Linaro works perfectly and as expected.
Linaro has newer program versions and Raspbian will get them in a few weeks when the transition to Jessie will be finished.

But mp3 was never part of any HTML specification and support is not required by any browser. In the past, plugins were responsible to support file formats which are not part of the HTML specification.

Webkit is compiled with support for gstreamer (0.1 or 1.0) and so browsers based on it support lots of media formats out of the box.