gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Tue Jul 28, 2015 3:28 pm

mjrival wrote:I have kodi 15.0-rc3 how can I update?, removing kodi and kodi-bin and installing again from the url of first post?
Just download download the latest package and run the install script.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

G160
Posts: 25
Joined: Sun Dec 23, 2012 1:32 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 9:12 am

hi, I'm trying to upgrade to kodi 15, however I'm getting errors when i run the install script, and 'startkodi' gives errors when i run it.

heres the errors i get in the console....
http://pastebin.com/EX1spb83

have i done something wrong?
thanks for your work on this, very much appreciated.

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 9:44 am

Damned typos!
There were some in the install script, but it should work nevertheless. I'm just uploading a new archive. If you don't want to download it again, just replace the content of install with:

Code: Select all

#!/bin/sh
if [ ! -f /usr/bin/gdebi ]
then
apt-get -y install gdebi-core
fi
if [ -f /usr/bin/kodi ]
then
dpkg -r kodi kodi.bin
fi
gdebi -n kodi_15.1-150901_armhf.deb
dpkg -i libplatform1_1.0.9-1_armhf.deb
cp kodi.desktop /usr/share/applications
cp startkodi /usr/local/bin
That doesn't explain the error message you got. Run
sudo apt-get update
and try again.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

G160
Posts: 25
Joined: Sun Dec 23, 2012 1:32 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 10:31 am

still no luck I'm afraid....i changed the install script as u suggested but only the first couple of errors disappeared, i still get these errors...

Code: Select all

Unpacking kodi (from kodi_15.1-150901_armhf.deb) ...
dpkg: error processing kodi_15.1-150901_armhf.deb (--install):
 trying to overwrite '/usr/lib/kodi/addon-helpers.cmake', which is also in package kodi-bin 2:14.2-1wheezy
dpkg-deb (subprocess): decompressing archive member: internal gzip write error: Broken pipe
dpkg-deb (subprocess): cannot copy archive member from 'kodi_15.1-150901_armhf.deb' to decompressor pipe: failed to write (Broken pipe)
dpkg-deb: error: subprocess <decompress> returned error exit status 2
Errors were encountered while processing:
 kodi_15.1-150901_armhf.deb

I'm completely up to date with apt-get update.

Anything else i can try or any more info u might need?

Im only upgrading as I'm using a sql database for my library, and i read somewhere that all clients need to run the same kodi version if a shared library is being used.

karma007
Posts: 17
Joined: Sat Feb 07, 2015 11:55 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 11:41 am

Hello,

i'm using kodi from http://michael.gorven.za.net/raspberrypi/xbmc (14.2)
now, i see that kodi (15.0) is available from raspbian repo, but when i do apt-get update, there are no update.

How can i do to update from raspbian repo instead of michaels ?

thanks

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 1:03 pm

G160 wrote:still no luck I'm afraid....i changed the install script as u suggested but only the first couple of errors disappeared, i still get these errors...

Code: Select all

Unpacking kodi (from kodi_15.1-150901_armhf.deb) ...
dpkg: error processing kodi_15.1-150901_armhf.deb (--install):
 trying to overwrite '/usr/lib/kodi/addon-helpers.cmake', which is also in package kodi-bin 2:14.2-1wheezy
dpkg-deb (subprocess): decompressing archive member: internal gzip write error: Broken pipe
dpkg-deb (subprocess): cannot copy archive member from 'kodi_15.1-150901_armhf.deb' to decompressor pipe: failed to write (Broken pipe)
dpkg-deb: error: subprocess <decompress> returned error exit status 2
Errors were encountered while processing:
 kodi_15.1-150901_armhf.deb

I'm completely up to date with apt-get update.

Anything else i can try or any more info u might need?

Im only upgrading as I'm using a sql database for my library, and i read somewhere that all clients need to run the same kodi version if a shared library is being used.
I have no idea. It's installing nicely here.
You have to remove former installations from any repository because this is an all in one package (containing both kodi and kodi.bin). The install script takes care of that (at least now, after the bug fix).
I'm not sure, why a file belonging to kodi 14.2 is still on your system and blocking installation.
Last edited by gkreidl on Sat Aug 01, 2015 1:07 pm, edited 1 time in total.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 1:05 pm

karma007 wrote:Hello,

i'm using kodi from http://michael.gorven.za.net/raspberrypi/xbmc (14.2)
now, i see that kodi (15.0) is available from raspbian repo, but when i do apt-get update, there are no update.

How can i do to update from raspbian repo instead of michaels ?

thanks
I don't see any kodi-15 release in the Raspbian repository,
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

G160
Posts: 25
Joined: Sun Dec 23, 2012 1:32 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 1:50 pm

you were right... i had leftover files.
once id cleaned them up, i reinstalled and everything went smoothly.
Many thanks

karma007
Posts: 17
Joined: Sat Feb 07, 2015 11:55 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 2:04 pm

gkreidl wrote:
I don't see any kodi-15 release in the Raspbian repository,
Oops, il read this "Raspbian - Up-to-date versions of Kodi are now on the default Raspbian repositories" here : http://kodi.wiki/view/HOW-TO:Install_Ko ... i#Raspbian

So that's not true ?

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 2:20 pm

karma007 wrote:
gkreidl wrote:
I don't see any kodi-15 release in the Raspbian repository,
Oops, il read this "Raspbian - Up-to-date versions of Kodi are now on the default Raspbian repositories" here : http://kodi.wiki/view/HOW-TO:Install_Ko ... i#Raspbian

So that's not true ?
At least not yet. The Raspbian version is still 14.2. Michael has a 15.0-RC1 in his unstable section, which is about a month old.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer


aik
Posts: 20
Joined: Mon Jul 27, 2015 9:59 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 4:21 pm

I tried this on ubuntu14.04 and got from "gdebi -n kodi_15.1-150901_armhf.deb":

Code: Select all

aik@aikrpi:~/kodi-15$ sudo ./install
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
This package is uninstallable
Dependency is not satisfiable: libtasn1-3

(Reading database ... 128760 files and directories currently installed.)
Preparing to unpack libplatform1_1.0.9-1_armhf.deb ...
Unpacking libplatform1 (1.0.9-1) over (1.0.9-1) ...
Setting up libplatform1 (1.0.9-1) ...
I did "sudo apt-get install libtasn1-*" which installed that "libtasn1-3" as well but did not help with kodi. And the ubuntu repo has only xbmc 12.3 so installing it first, then removing, then installing kodi15 is not the option either. Is this it, no way to get this working on ubuntu? Normally raspbian stuff just installs...

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 6:12 pm

It may depend on the version of installed packages/libraries.
I suppose you have to compile your own version or switch to Raspbian.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Mxx20
Posts: 15
Joined: Sun Jun 21, 2015 2:01 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 8:10 pm

Two things, one pi I've been using at work for music... I've been using a corded keyboard it won't type in kodi....

Second...it's more of an add-on thing but I'm limited to using sound cloud( I think is the name) do to my work blocking anything to do with Pandora, scripts anything... Any one have any suggestions on that? Or maybe a way around it?

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 9:13 pm

[quote="Mxx20"]Two things, one pi I've been using at work for music... I've been using a corded keyboard it won't type in kodi....
/quote]

Did you add user pi to all the groups (especially input)?

Also add to /etc/init.d/rc.local this line:
chmod 0777 /dev/tty0
(if your keyboard works like a phone keyboard)
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Mxx20
Posts: 15
Joined: Sun Jun 21, 2015 2:01 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sat Aug 01, 2015 9:21 pm

No I didn't lol...I'll have to do it Monday

aik
Posts: 20
Joined: Mon Jul 27, 2015 9:59 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sun Aug 02, 2015 1:16 am

gkreidl wrote:It may depend on the version of installed packages/libraries.
I suppose you have to compile your own version or switch to Raspbian.
Heh. This linux, this is tricky. I cloned their git and followed instructions for LTS and got:

aik@aikrpi:/mnt/hugeolddisk/rpi/xbmc$ sudo apt-get build-dep kodi
...
E: Build-Depends dependency for kodi cannot be satisfied because candidate version of package libcec2 can't satisfy version requirements

I tried installing libcec2, libcec3, nothing makes "build-dep kodi" happy :-/

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Sun Aug 02, 2015 6:31 am

Please keep to the topic of this thread. Open a new one about your problems /questions.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

aik
Posts: 20
Joined: Mon Jul 27, 2015 9:59 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Tue Aug 04, 2015 5:02 pm

So I installed raspbian and the packages from the starting post, everything installed nicely, thanks!
However there is a nit - if a video file has 4:3 aspect ration, there are parts of a desktop visible on the left and right sides when it plays. Is that fixable?

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Tue Aug 04, 2015 5:10 pm

aik wrote:So I installed raspbian and the packages from the starting post, everything installed nicely, thanks!
However there is a nit - if a video file has 4:3 aspect ration, there are parts of a desktop visible on the left and right sides when it plays. Is that fixable?
I'm sure there are settings on kodi for that, but do you want to distort the image? Spreading a 4:3 video across a 16:8 screen looks weird, IMHO.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

LennVilardi
Posts: 4
Joined: Tue Aug 04, 2015 5:13 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Tue Aug 04, 2015 5:43 pm

Is it possible to compile a version of kodi with avahi to support airplay ?
Thanks :)

aik
Posts: 20
Joined: Mon Jul 27, 2015 9:59 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Wed Aug 05, 2015 12:54 am

gkreidl wrote:I'm sure there are settings on kodi for that, but do you want to distort the image? Spreading a 4:3 video across a 16:8 screen looks weird, IMHO.
It is weird indeed, I want to keep 4:3 and just fill the free spaces on the left and right with black to hide these parts of the xfce desktop.

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Wed Aug 05, 2015 5:21 am

aik wrote: It is weird indeed, I want to keep 4:3 and just fill the free spaces on the left and right with black to hide these parts of the xfce desktop.
xfce desktop? Kodi? What are we talking about.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

aik
Posts: 20
Joined: Mon Jul 27, 2015 9:59 pm

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Wed Aug 05, 2015 6:36 am

gkreidl wrote:xfce desktop? Kodi? What are we talking about.
I boot Pi, it starts with XFCE. Then I start Kodi, which is full screen. TV is 1920*1080 (which is 16:9). In Kodi, I navigate to a folder with a movie and start it. Its resolution is 320*240 (whish is 4:3 aspect ratio).

The movie starts in full screen but since its aspect is less than TV's one, it only occupies the area 1440*1080 in the center of TV. So there should be nothing on the left (240x1080+0+0) and on the right (240x1080+1680+0) of the TV screen.

However I can see respective XFCE desktop parts through these (240x1080+0+0) and (240x1080+1680+0).

This is (I think) because Kodi hides itself and runs omxplayer in fullscreen but since omxplayer outputs to overlay and preserves the aspect ratio, it does not expand the overlay to the entire screen (otherwise the video would be stretched from 4:3 to 16:9 which is ugly) so here is this weird effect.

Need a picture?

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Kodi 15.1-rc1 Debian package for Raspbian on RPi 2

Wed Aug 05, 2015 7:00 am

I just tested it with a 4:3 video (both from my OpenBox desktop and from LXDE) and there was always a black border at both sides; no desktop visible.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Return to “Raspberry Pi OS”