pcote_pi
Posts: 38
Joined: Mon Nov 03, 2014 12:29 am
Location: Montréal

How to Activate Graphical Loging on LXDE

Thu Apr 16, 2015 9:35 pm

Allo,

I would like my PI2 to automatically boot to the graphical user interface (done via raspi-config) and I would like to see the graphical login (username and password) before the icons appear and the taskbar.

I have checked the autostart file and the config directory but I cannot find any commands to activate the graphical login.

PIDORA and ubuntu do provide graphical login and I would like to do the same.

Please do not tell me that I have to run raspi-config and activate the boot on terminal to login. This is not what I want and need.

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: How to Activate Graphical Loging on LXDE

Fri Apr 17, 2015 12:06 am

When you enable boot to desktop in raspi-config, it changes the configuration file for lightdm to autologin the pi user.

To stop this behaviour edit the file /etc/lightdm/lightdm.conf as root.
E.g.

Code: Select all

sudo nano /etc/lightdm/lightdm.conf
Look for the line

Code: Select all

autologin-user=pi
and comment it out

Code: Select all

#autologin-user=pi
Note: do this after using raspi-config to enable boot to desktop. Also note that on my Raspberry Pi when I enabled the lightdm-greeter (the process that invites you to login), the theme appeared broken, in that some images were missing. You may need to change the theme or work out which images are missing.

pcote_pi
Posts: 38
Joined: Mon Nov 03, 2014 12:29 am
Location: Montréal

Re: How to Activate Graphical Loging on LXDE

Sun Apr 19, 2015 11:33 pm

Works as specified. Many thanks.

Can you point to me the documentation that would explain the boot process and sequence of Raspbian?

I have tried with no success using the web. So I had to resort to the forum to find out how to intercept the autologin at boot.

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: How to Activate Graphical Loging on LXDE

Mon Apr 20, 2015 10:48 am

pcote_pi wrote:... Can you point to me the documentation that would explain the boot process and sequence of Raspbian? ...
No, unfortunately I can't sorry.

Chapter 3:The system initialization of the Debian Reference Manual may be a good place to start. The Raspian boot sequence is a little different as there is no BIOS and it doesn't use GRUB.

fruitoftheloom
Posts: 20485
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: How to Activate Graphical Loging on LXDE

Mon Apr 20, 2015 10:56 am

This is the initial boot up sequence of the Raspberry Pi, which is the equivelent of the BIOS in a standard PC

http://wiki.beyondlogic.org/index.php?t ... ot_Process
Retired disgracefully.....

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: How to Activate Graphical Loging on LXDE

Wed Apr 22, 2015 1:39 pm

AndyD wrote:Also note that on my Raspberry Pi when I enabled the lightdm-greeter (the process that invites you to login), the theme appeared broken, in that some images were missing. You may need to change the theme or work out which images are missing.
You can fix the broken icon using the following command.

Code: Select all

sudo ln -s /usr/share/icons/HighContrast/scalable/devices/computer.svg /usr/share/lightdm-gtk-greeter/hicolor/scalable/apps/
[/s]
Actually, that only worked if you have the gnome-accessibility-themes package installed. I think a better solution is to have the Raspberry Pi logo displayed. You can use the following:-

Code: Select all

sudo ln -s /usr/share/raspberrypi-artwork/raspberry-pi-logo.svg /usr/share/lightdm-gtk-greeter/hicolor/scalable/apps/computer.svg

pcote_pi
Posts: 38
Joined: Mon Nov 03, 2014 12:29 am
Location: Montréal

Re: How to Activate Graphical Loging on LXDE

Fri May 15, 2015 10:47 pm

I found a side effect of activating the graphical login.

The mouse pointer does stop to show the "hourglass pointer". When I double click on a desktop icon, the mouse pointer does not show the circle showing activity in progress.

When I disable the graphical login and reboot, the hourglass returns showing the double click was caught and that there is processing of the action.

Tried this 3 times and it is repeatible.

Return to “Raspbian”