cryocat
Posts: 1
Joined: Mon Apr 06, 2015 9:13 pm

Upgraded installation from Wheezy to Jessie; unable to SSH i

Mon Apr 06, 2015 9:16 pm

I have hit a wall with regard to this issue and I have no inkling whatsoever as to what might have happened. Any help regarding this matter will be greatly appreciated.

I connect to my Raspberry Pi 2 over the network, SSH-ing into it. Today, I tried upgrading the from the wheezy version to Jessie by changing the /etc/apt/sources.list file and using apt-get dist-upgrade. Installation finished normally, with no exceptions. I restarted the Pi and now I can't seem to SSH into it anymore. Trying to ping it returns a request timeout message. I don't have a display to connect my raspberry pi to, so I don't have anymore information to give regarding this issue, only that I can't even ping it anymore! I apologize for the clueless nature of the post, but I really can't think of where to even begin troubleshooting.

Any ideas?

Tom_A
Posts: 272
Joined: Fri Dec 06, 2013 8:34 am

Re: Upgraded installation from Wheezy to Jessie; unable to S

Mon Apr 06, 2015 10:31 pm

Whatever the problem is, you are probably going to need to connect to a monitor to diagnose and fix it.

The possibilities I can think of are:

1. For some reason ssh was uninstalled during the update so that you can only log in locally.
2. The Jessie install enabled the firewall so that even though ssh is still installed, it is not possible to reach the Pi without first adjusting the firewall settings.
3. The user password reset or changed due to the install??

You can plug the install sd card into a reader and then into a computer capable of reading the root partition. (You might need to make another Raspbian install to do this.) Then you can recover any of your files that are still on the card. Jessie is still pre-release software. It's best to clone the stable install to a new card and then update that to prevent situations like this. Even if everything worked much better, if there was just one deal breaker in the upgrade, it's not easy to reverse the upgrade.

Rodman101
Posts: 16
Joined: Tue Jun 11, 2013 10:55 pm

Re: Upgraded installation from Wheezy to Jessie; unable to S

Tue Apr 28, 2015 6:23 pm

This has happened to me since I upgraded as well. The problem for me is that now I have to physically log onto the RPi before I'm able to log in via SSH. There must be a way to fix this, but for now that's what I've had to do.

User avatar
minos
Posts: 71
Joined: Sun Mar 17, 2013 1:31 am

Re: Upgraded installation from Wheezy to Jessie; unable to S

Tue Apr 28, 2015 7:45 pm

May be because "root" has been disabled in SSH users... I'm reading it about amd64 jessie release.
Humm, a way to explore if you have upgraded 7.8 > 8.0

Sry it's french page, but I'm sure the command needed is the same:
https://www.debian.org/releases/jessie/ ... ml#openssh

Code: Select all

echo 'openssh-server openssh-server/permit-root-login boolean true' | debconf-set-selections
EDIT:
I've tried on my Debian 8 amd64 fresh install... and solution given before is not working...
So I found this other solution, and that's work fine, ssh login for "root" is now ok
https://debiantalk.wordpress.com/2015/0 ... n-via-ssh/

MattOwnby
Posts: 58
Joined: Thu Aug 16, 2012 7:22 pm

Re: Upgraded installation from Wheezy to Jessie; unable to S

Wed Feb 03, 2016 9:06 am

cryocat wrote:I have hit a wall with regard to this issue and I have no inkling whatsoever as to what might have happened. Any help regarding this matter will be greatly appreciated.

I connect to my Raspberry Pi 2 over the network, SSH-ing into it. Today, I tried upgrading the from the wheezy version to Jessie by changing the /etc/apt/sources.list file and using apt-get dist-upgrade. Installation finished normally, with no exceptions. I restarted the Pi and now I can't seem to SSH into it anymore. Trying to ping it returns a request timeout message. I don't have a display to connect my raspberry pi to, so I don't have anymore information to give regarding this issue, only that I can't even ping it anymore! I apologize for the clueless nature of the post, but I really can't think of where to even begin troubleshooting.

Any ideas?
did you ever figure this out? I am kinda surprised that not more people are having this problem. I just gave Jessie a shot and while it can initiate connections to other machines on my LAN, the other machines on my LAN can't seem to connect to or ping the pi at all. It's behaving like there is an aggressive filewall installed but iptables-save shows nothing so I am kinda stumped.

gonna go back to wheezy for now. *crosses fingers*

User avatar
RaTTuS
Posts: 10539
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Upgraded installation from Wheezy to Jessie; unable to S

Wed Feb 03, 2016 9:26 am

has the IP changed ?
Are attempting to log in via root or a normal user
what do the logs show ? [obviously you need a display or serial connection to show it]
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Return to “Raspbian”