Page 1 of 1

Overclocking the RPi2

Posted: Fri Feb 20, 2015 6:01 am
by Diskonekted
Hi all,

Just wanted to ask if anyone else has noticed some conflict with the overclocking on the RPi2? I overclocked mine to 1Ghz upon the first-time boot and have been having some troubles ever since.

I dropped this back to the 900Mhz setting, which the raspi-config considers 'Medium'; but continued to have stability issues. There's nothing that I can see i the log files that points to a specific fault; but I've been swapping out SD cards with other builds, like RetroPie and some of the Debian minimal builds and these seem to work fine for extended hours (i.e. 4+ days).

At current, I can only get about 4 hours out of the Pi2 and then it become unresponsive (even to immediate console, i.e. monitor output). The reason for my query about conflict is that there seems to be a disconnect between the detail about the model here and what the raspi-config considers the default CPU frequency to be.

At most it looks like the raspi-connfig is unaware that it's running on a Pi2 and that the overclock pre-sets are not applicable to the new hardware. I'm looking to have this changed back to what would be "native" for the Pi2 hardware and can easily adjust the /boot/config.txt parameters, but I'm unsure of what the core_freq, sdram_freq and over_voltage parameters need to be set at/to

Does anyone know what these need to be set at? Or has anyone else had stability issues on their RPi2? I should note that I'm using the 2015-01-31 build and already have the package updates (firmware, wolfram, etc.) that are part of the 2015-02-16 build.

Re: Overclocking the RPi2

Posted: Fri Feb 20, 2015 11:40 am
by jamesh
Have you tried a fresh card and Raspbian install? Does that work OK?

Re: Overclocking the RPi2

Posted: Fri Feb 20, 2015 11:59 am
by Diskonekted
Hi James,

Yes, I've tried a different card and I've tried reinstalling the same 2015-01-31 build image which was listed here before it was updated. The card I used the first time around was a 16Gb SanDisk Class10 (link) and then I installed the same image onto an 8Gb Class4 (link).

Both had the same problems, but I've also got spares of these two same cards, so I've just downloaded the latest raspbian build on the downloads page (build 2015-02-16) and will try this tomorrow. When you refer to the raspbian install are you referring to the image installation method mentioned here?

Re: Overclocking the RPi2

Posted: Fri Feb 20, 2015 12:17 pm
by Diskonekted
Just a note; I haven't tried the new build as yet, but I am using the 2015-01-31 build with all the updates (that are listed in the release notes) of the new build.

I've been doing this via apt-get, but I wasn't sure if this included the raspi-config tool and remembered that this includes its' own options under '8. Advanced Options -> A0 Update'. So trying this, it seemed to perform the same task, but when returning to the tool menu and looking at the Overclock options again, there was an additional option, one for the Pi2!

So I'll try this option and see how things go over the course of the next few days. I will be interested to see if I choose 'None' if this will reset the clock frequencies back to that of the Pi1; if so it'd be great to do something here to make the 'None' option more specific to the Pi model that it's being chosen on.

Re: Overclocking the RPi2

Posted: Fri Feb 20, 2015 12:29 pm
by RaTTuS
if you just comment out all the overclock things in the config file then it will default back to umm default ;)

Re: Overclocking the RPi2

Posted: Fri Feb 20, 2015 12:49 pm
by Diskonekted
RaTTuS wrote:if you just comment out all the overclock things in the config file then it will default back to umm default ;)
Ahhh, sometimes the most straight-forward method is the easiest! Here's me trying to revert changes with the tool that was made to make said changes in the first place. :lol:

A worthwhile lesson for others trying to un-do these settings made in raspi-config; if you're using a Pi2, don't try removing overclock settings by choosing the 'None' option. This will only under-clock your Pi2, not restore it back to default.

Re: Overclocking the RPi2

Posted: Fri Feb 20, 2015 1:01 pm
by Fidelius
Diskonekted wrote:Just wanted to ask if anyone else has noticed some conflict with the overclocking on the RPi2? I overclocked mine to 1Ghz upon the first-time boot and have been having some troubles ever since.
I too overlocked the Pi2 to "Pi2 Turbo" mode (i.e. your mentioned 1 GHz).

Recently, when "Mame4all for Pi" has been used in two-player mode (i.e. more load?) for > half an hour, the Pi2 completely froze.

So I commented-out the overclocking settings in the boot/config.txt (yes :-) and now will have to see if this resetting to the Pi2's standard clocking values makes the freeze go away. I don't know if it's a "Mame4All for Pi" bug with the Pi2 (on the Pi1 it never freezes) or a Pi2 overclock thing.

What would be a more general way to stress-test an overclocked Pi2 to see if it runs stable?


Also at times I can't login to the X11-XFCE desktop in the welcome-screen, but unfortunately this happens with and without overclocking, so may be another problem.

Re: Overclocking the RPi2

Posted: Tue Feb 24, 2015 9:14 pm
by Diskonekted
So I'm now thinking that the lock-ups/freezing was due to temperature. Previously I was running the Pi2 as a BOINC compute node; but I've been running it without work units the last few days and it's still responsive.

I don't think the issue is related to BOINC itself, as I'd expect some errors in the log files, but am unsure if the Raspian OS will scale the system work down if it reaches a certain temperature threshold.... I'm thinking that I'll use the Pi2 for different projects, namely an arcade machine, so I don't expect it will run too hot.

Fidelius, I haven't tried 'Mame4All' (I'll give it a go later today), but I've been using a separate SD for RetroPIE, have you tried this? It's really good and has a nice easy UI.