User avatar
Fidelius
Posts: 460
Joined: Wed Jan 01, 2014 8:40 pm
Location: Germany

Pi2 LightDM welcome-screen won't login at times

Thu Feb 19, 2015 1:52 pm

I run Raspbian plus an apt-get-installed XFCE on a Pi1 without the slightest problem.

Now for the Pi2 I copied the Pi1's SD-card (after apt-get-update) to the Pi2's µSD-card and basically everything runs fine.

However, at times when a user sees the LightDM welcome screen and wants to login to the XFCE desktop, it won't work. What happens is that...
a) the centre area of the login welcome screen, where the users' names have been listed to click, stays white and the mouse changes between text cursor ("I") and normal mouse cursor, but you can't do anything with the mouse then, and no XFCE desktop appears.
... or ...
b) you can't even move the mouse or press a key.

In case of a) the user then can login to a text console (Ctrl+Alt+F1...) and do a "startx", then the desktop appears, but this is not nice for normal users. So usually a user with sudo rights logs-in to the text console and does a "reboot".
In case of b) you've to ssh from another computer to the Pi2 and reboot it from there.

The "won't login" problem can happen when the Pi2 has been cold- or warm-booted, or when one user logged-out and the same or another user wants to login.


Unfortunately I don't know much about Linux X11 and desktop internals, so could somebody who does please tell me how to encircle this problem? I have saved the /var/log/Xorg.0[..3].log files in case they would be helpful.

Only if this encirclement doesn't solve the problem, I would try a fresh Raspbian installation on the Pi2 and hope that it works then...

Return to “Raspbian”