Pikkuiikka
Posts: 6
Joined: Fri Sep 20, 2019 1:52 pm
Location: Finland

Raspbian: all image thumbnails not showing up

Sat Sep 21, 2019 8:56 am

Hello,

sorry if this has been discussed, did not find anything.

Latest Raspbian with Pi 4B: When opening an image folder in the default file manager, only some of the thumbnails show up. Maybe 1/3 of all in a folder. No matter if the location is in the Pi itself or in the local network. Very annoying, because I have my image store in a NAS device. Lot of images... Thumbnails showed nicely with Linux Mint/Windows 10 combo. Now that I've replaced those with a Pi 4, I need a similar function.

I have look at the preferences and removed the option to 'show thumbnails only in local folders'. No help.

Is this a bug in Raspbian, or would I need to install some other file manager?

-iikka

ccpetersen
Posts: 9
Joined: Fri Dec 04, 2015 4:03 pm
Location: US

Re: Raspbian: all image thumbnails not showing up

Sat Oct 12, 2019 3:08 pm

Same question.

wally333
Posts: 90
Joined: Mon Jun 06, 2016 7:09 pm

Re: Raspbian: all image thumbnails not showing up

Tue Jan 28, 2020 6:35 pm

Me too. I don't get any *.jpg thumbnails.

I only need them on the local SD card or plugged in drive.

tpcalhoun
Posts: 5
Joined: Fri Jan 04, 2013 12:37 am

Re: Raspbian: all image thumbnails not showing up

Sat Feb 22, 2020 4:09 pm

You can make the thumbnails generate properly for larger image files by adjusting the preferences for File Manager.

While in File Manager application (within Raspbian OS)...
  • Navigate to the folder containing the image files you are interested in
  • From the File Manager menu bar, click on the Edit menu
  • Select Preferences from the Edit menu options
  • Once the Preferences dialog screen is displayed, select the Display preferences from the left navigation bar.
  • In the middle of the Display preferences screen you will see a setting for "Do not generate thumbnails for files exceeding this size:"
  • Simply bump up the KB size number to something larger than your typical image file size. The default is 2048 KB
  • Once you have changed the setting, you can Close the Preferences dialog screen
  • To make the new setting effective, you will need to Close and then Re-Launch the File Manager application.
Give it a try.

User avatar
Disaster Incarnate
Posts: 44
Joined: Wed Nov 11, 2020 4:42 am
Location: Planet Earth (Usually)

Re: Raspbian: all image thumbnails not showing up

Sun Nov 15, 2020 12:48 pm

necro'ing this for my pi400, this does not work, thumbnails never show up.

User avatar
varices
Posts: 6
Joined: Sun Apr 04, 2021 6:20 pm

Re: Raspbian: all image thumbnails not showing up

Sun May 09, 2021 9:04 am

tpcalhoun wrote:
Sat Feb 22, 2020 4:09 pm
You can make the thumbnails generate properly for larger image files by adjusting the preferences for File Manager.

While in File Manager application (within Raspbian OS)...
  • Navigate to the folder containing the image files you are interested in
  • From the File Manager menu bar, click on the Edit menu
  • Select Preferences from the Edit menu options
  • Once the Preferences dialog screen is displayed, select the Display preferences from the left navigation bar.
  • In the middle of the Display preferences screen you will see a setting for "Do not generate thumbnails for files exceeding this size:"
  • Simply bump up the KB size number to something larger than your typical image file size. The default is 2048 KB
  • Once you have changed the setting, you can Close the Preferences dialog screen
  • To make the new setting effective, you will need to Close and then Re-Launch the File Manager application.
Give it a try.
Cheers. I ran all over those preferences windows, even minimizing the image file size of all things I went through. It took ma awhile to find this but I got the file size pinned to at 3x 2048, so it's at 6144 and it works like a charm. Is their any after effect to this you've ever run into?

Now I just have to figure out how to restore Windows software from the volume management preferences or would you know if that is no big deal?

Thanks,
varices

Return to “Raspberry Pi OS”