tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Choppy audio

Tue Aug 14, 2018 11:00 pm

I have two identically setup Raspbians loaded from NOOBS 2.8.2. One on my Visio in my Living room, plays audio smooth, one in the bedroom on a TCL Roku tv plays audio choppy. On both I went to preferences and select controls/select PCM for playback. Not sure what else to try. Note: Living room is pi2 on a wired network bedroom is pi3 on wireless.

Joe

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: Choppy audio

Wed Aug 15, 2018 5:23 am

Are you using RPi HDMI audio, RPi TRRS audio, or usb sound card audio?

Choppy audio on a WiFi connected RPi3B may mean heavy WiFi traffic, or WiFi signal degradation due to distance/blockage.
Have you tried temporarily using wired network connection on the RPi3B to check if the "choppiness" is removed?
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

crofter
Posts: 55
Joined: Thu Feb 22, 2018 11:28 pm

Re: Choppy audio

Wed Aug 15, 2018 8:27 am

hi

please try swaping sd cards as i also do not get choppy audio pi 2 and 3b

good luck

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Fri Aug 17, 2018 5:44 pm

Well, apparently it is the wifi connection. Bummer. The room it is in has no ethernet connection. Also, this is a dual boot with OSMC. OSMC plays fine over wifi.??? My signal strength is ok as the TV and other devices work fine. I know what it is not also: not HDMI cable, not Bluetooth being enabled, not this particular pi3b. (tried another in same places). It's not what TV it is attached to either. This pi goes to the desktop so it can use web browser, music and games. The OSMC boot is for it to play movies on my network. It gets choppy audio whether the music is on a fileserver mounted to mnt or local on the SD card. So what is the wifi doing in the background? Also did try swapping SD cards. (they are Sandisk Ultra's).

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Fri Aug 17, 2018 11:50 pm

After an afternoon of Attic crawling, have ethernet in room for pi3.. Diabled wifi...Audio still choppy :?: :?: :?: So, took the SD card and put it in a pi2b and tried it. Still choppy??? Moved it to the other tv and not choppy??? Put the SD back in the pi3 and tried on the same tv and its ok?? The TV could cause this???.

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: Choppy audio

Sat Aug 18, 2018 10:48 am

Hmmm.... me still dont get it either. RPi is directly connected to TCL TV via HDMI cable, am I correct?

when you mention "choppy audio", the audio
a. is skipping (song skipping lyrics or tune)?
b. has cracks and pops sound and some hum in the background?

if it is the latter, then the RPi3B may be affected by some stray interference from the TV (via the PSU perhaps, or other route).

even if you tried distancing the RPi from the TV (using long HDMI cable) the "choppiness" continues?
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Sat Aug 18, 2018 4:21 pm

Audio is cutting out and in. Didn't think of power supply interference. Tried several HDMI cables. Will try moving power supply. Both are plugged into a UPS.

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: Choppy audio

Sat Aug 18, 2018 11:13 pm

Hope you dont mind, lets do some other test.

A. With the RPi3B still connected to the TCL TV (either by long or short HDMI cables), and both connected to UPS, RPi3B connected via LAN cable
1. set the audio to output from the TRRS jack.
2. plug a headphone to the TRRS jack
3. play an audio /video file (a file that played properly on the RPi2B)
4. check for choppiness in audio from the headphone

B. Same setup as A, but remove connection to TCL TV, access the RPI3B via VNC from another pc (or from RPI2B). This we try to eliminate the TV as the source of "choppiness"

C. Same as A, but power source not from UPS but from another outlet. This we try to eliminate the power source interference

D. Same as B, but power source not from UPS but from another outlet. This we try to eliminate both the TV and the power source interference.
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Sun Aug 19, 2018 12:53 am

Tried to force it out of the audio jack with Raspi-config, but it insisted on always coming out the HDMI. I assume the TRRS jack is the 3.5 mm audio jack on the pi? I guess there is something in the handshake with the HDMI that causes it to always output thru HDMI?

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: Choppy audio

Sun Aug 19, 2018 1:28 am

Yes the TRRS jack is the 3.5mm jack on the RPi

on the raspbian desktop top right you will notice a speaker icon (usually next to a cpu usage monitor mini graph)

right click it and make sure the check is on "Analog"

then do the test again.
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Sun Aug 19, 2018 3:28 pm

I tried that but it still insisted on coming out the HDMI.

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: Choppy audio

Mon Aug 20, 2018 9:54 am

can you check the config.txt file?

Code: Select all

~ $ sudo nano /boot/config.txt
and see if this is un-commented on your config.txt

Code: Select all

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2
also some say adding this

Code: Select all

disable_audio_dither=on
right after this

Code: Select all

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
improves sound quality (well... reduces noise that is)
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Mon Aug 20, 2018 3:10 pm

will try when I have some time to mess with it.

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Mon Aug 20, 2018 7:06 pm

Much improved. Thank you. Let's mark this 'Solved'

LTolledo
Posts: 736
Joined: Sat Mar 17, 2018 7:29 am

Re: Choppy audio

Tue Aug 21, 2018 9:01 am

Just curious, which one did the trick?
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

tannenba
Posts: 43
Joined: Tue Dec 24, 2013 5:22 pm
Location: Central Arizona, USA
Contact: Website

Re: Choppy audio

Tue Aug 21, 2018 2:36 pm

Mostly the last suggestion.

Return to “Raspbian”