VNC disabled after apt-get dist-upgrade


7 posts
by mattmiller » Sun Mar 12, 2017 5:54 pm
I downloaded and installed a new 2013-03-02 image on a PiZeroW using PiBakery and used PiBakery option to enable VNC on 1st boot

All OK - VNC worked fine as always

I then did sudo apt-get update and then sudo apt-get dist-upgrade and then sudo reboot after it had finished

I then couldn't VNC in

I had to enable ssh via ssh.txt and use raspi-config via putty to re-enable VNC server

Anyone else seeing this issue?
Posts: 1130
Joined: Thu Feb 05, 2015 11:25 pm
by DougieLawson » Sun Mar 12, 2017 7:04 pm
The thing that broke VNC for me was the 4.9.13 kernel. But the RealVNC folks fixed that with an update to their package (perhaps it's that update that inadvertenly disabled it).
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.
User avatar
Posts: 27569
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by sconemad » Tue Mar 14, 2017 9:10 am
Thanks for reporting this. Yes it looks like this is an issue with the init scripts for the service.

If you have installed the 2013-03-02 Raspbian image, enabled VNC then updated the realvnc-vnc-server package, this results in the VNC service being disabled. The good news is that re-enabling from the Pi configuration app or raspi-config is all that is required to fix this, and this should only need to be done once. We're looking into a fix.
User avatar
Posts: 155
Joined: Thu Apr 28, 2016 1:47 pm
Location: Cambridge, UK
by mattmiller » Tue Mar 14, 2017 11:04 am
We're looking into a fix.

Ta :)
Posts: 1130
Joined: Thu Feb 05, 2015 11:25 pm
by BamRam » Mon Mar 20, 2017 5:33 pm
My problem is that I do not even have the option to select enabling VNC in the configuration box. It is not even there. I have the Raspberry Pi 3 B from Adafruit.
Tried doing a shell install but still does not show up.
I was able to enable the Pi Camera though and SSH option is there.
Posts: 2
Joined: Mon Mar 20, 2017 5:25 pm
by bensimmo » Mon Mar 20, 2017 8:08 pm
BamRam wrote:My problem is that I do not even have the option to select enabling VNC in the configuration box. It is not even there. I have the Raspberry Pi 3 B from Adafruit.
Tried doing a shell install but still does not show up.
I was able to enable the Pi Camera though and SSH option is there.

Have you updated Raspian ?
How old is your original Raspian image?

Try
https://www.raspberrypi.org/documentati ... pdating.md

Then
https://www.raspberrypi.org/documentati ... ccess/vnc/
Posts: 1065
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire
by BamRam » Mon Mar 20, 2017 11:42 pm
Yes, I solved the problem by downloading the latest version of Raspbian. I had bought the Pi last August but only got around to trying it out now. VNC option is now available in the Interfaces. :D
Posts: 2
Joined: Mon Mar 20, 2017 5:25 pm