Page 2 of 2

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 5:03 pm
by danjperron
Avec une deuxième personne qui te demande d'ajouter une résistance en parallèle avec tes diodes y a t'il un changement lorsque tu ajoutes la résistance ?

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 5:31 pm
by jareczek
J'avais oublié l'histoire du pwm . Il aurait fallu le supprimer pour faciliter les investigations !

Toujours dans le cas "vérifier si le circuit fait ce qu'il devrait faire" :
Dans ton post 14:32 tu dis :
R allumée
Vd B = 0.315
Vd R = 2.60
Vd G = 0.167 (bruit multimètre)
-> c'est pour Rallumée ET V et B éteintes ? Si oui c'est incohérent et je donne ma langue au chat
De plus cela ne correspond pas aux valeurs que tu as donné post 10:58 où tu donnes un Vd pour R allumée de 1,35V.
Si tes mesures sont exactes le fonctionnement d'une diode influence celui des autres
Et là, à part recabler le circuit "en volant" (sans PCB) pour vérifier je ne vois pas !
Au fait, ton alim 12V peut fournir le courant demandé ? sûr ?
Bref, ce problème n'est pas résolu

Pour la partie "led allumée alors qu'elle ne devrait pas" :
Danjperron me fait découvrir qu'une led peut s'allumer d'une manière VISIBLE avec 1µA et je veux bien le croire .

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 6:05 pm
by RD2
Ce que j'ai appelé Vd dans le premier post était la tension entre une masse et la sortie du transistor (donc patte 2, nommée d). Lors de ma dernière mesure, Vd est la tension entre 1 et 3 du transistor (entre la grille et une masse). En gros, c'est Vs GPIO dans ma première mesure (les différences de tension vient du réglage de mon 12V qui a du sensiblement changer).

Je ne sais pas si j'ai été clair, mais mon circuit "fait ce qu'il doit faire" dans un sens, sauf que deux couleurs restent légèrement allumée. Sinon, la partie commande, le Pwm, tout marche comme je veux!

Je teste au plus vite l'histoire de la résistance en parallèle.

Edit : Mon alimentation délivre ce qu'il faut ;)

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 6:33 pm
by RD2
Résistance de 2.7 kOhms entre la passe et la patte 1 et une masse, juste un changement de luminosité qui augmente mais très légèrement (c'est bien ça qu'on me demande? :) )

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 7:12 pm
by danjperron
Non pas entre la masse mais de la cathode à l'anode de la led pour chaque canal .
Donc tu as trois résistances à installer.

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 8:17 pm
by RD2
Ah je n'y était pas du tout depuis le début, je pensais que nous parlions des diodes des transistors... Désolé :oops:

Donc j'ai testé sur le bleu, et ça fonctionne, elle n'éclaire plus au repos!

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 8:57 pm
by danjperron
Et voila! courant de fuite,(résiduel) depuis le début!

La résistance empêche la LED t'atteindre le potentiel de conduction de la jonction interne donc pas de courant.

Le courant de fuite est donc passer par la résistance.

Sans résistance le potentiel de conduction est atteint et la led illumine, peut mais elle le fait!

Daniel

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 9:31 pm
by RD2
Et par curiosité, pourquoi sur deux des trois couleurs?

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Sun Feb 15, 2015 9:59 pm
by danjperron
Et par curiosité, pourquoi sur deux des trois couleurs?

Et bien il y a deux raisons.

1 - Un des mosfets a moins de courant de fuite.
2- Le potentiel de junction d'une des couleurs est plus élevé et donc conduit peut.

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Mon Feb 16, 2015 7:36 am
by RD2
Très bien, merci beaucoup pour toutes ces informations intéressantes, je sais ou revenir si j'ai le moindre problème :)

Re: Courant résiduel transistor : Led légèrement allumée

Posted: Mon Feb 16, 2015 10:14 am
by jareczek
Je retiens les informations de Danjperron, c'est intéressant à savoir.
Une idée pour mettre "off" dans ce genre de circuit serait d'appliquer la tension +12V à travers un relais à contacts mécaniques, un interrupteur ou de couper l'alimentation.

Par contre faut pas confondre Vds (tension drain/source), Vgs (tension gate/source) quand tu donnes des résultats de mesure.
D'autre part, avec des moyens de mesure "ordinaires", ne pas mesurer Vgs ou Vg/0v car le résultat sera faux.
Pour qu'une mesure soit juste, il faut que la résistance d'entrée du multimètre soit très grande devant la résistance du circuit sur lequel on connecte le multimètre. Or lorsque mosfet est bloqué les 2 résistances ont des valeurs trop proches l'une de l'autre.