RD2
Posts: 24
Joined: Mon Nov 10, 2014 8:04 pm

Courant résiduel transistor : Led légèrement allumée

Wed Feb 11, 2015 8:00 pm

Bonjour,

Je suis en train de réaliser un montage à base d'une led RGB commandée par trois transistors. J'ai remarqué un phénomène intéressant, je suppose qu'il y a un courant résiduel en sortie des transistors qui fait que deux des trois couleurs restent allumées même lorsque le transistor n'est pas commandé! Avez vous déjà remarqué ce phénomène?

Etant donné qu'il faut que cette led soit complètement coupée, j'ai pensé à ajouter un transistor commandé qui ferait une sorte de ON/OFF sur la masse commune de la led RGB. Pensez-vous que c'est une bonne idée? Quel transistor choisir étant donné que la led consomme environ 0.3A par canal, soit environ 1A maximum?

Merci d'avance pour votre aide

jareczek
Posts: 170
Joined: Tue Jul 23, 2013 2:45 pm
Location: Auvergne

Re: Courant résiduel transistor : Led légèrement allumée

Wed Feb 11, 2015 8:14 pm

Un transistor bloqué peut laisser passer quelques nA, et encore . . .
Donc les tiens ne sont pas bloqués

Montre le schéma du montage
Sauf erreur ou omission . . .

nikotinux
Posts: 671
Joined: Sat Feb 02, 2013 2:11 am

Re: Courant résiduel transistor : Led légèrement allumée

Wed Feb 11, 2015 8:15 pm

c'est l'essuie glace de l'alternateur qui n'est pas assez serré ...

peut être qu'avec un schéma, une image, un truc .... qui décrive comment tu commandes tes leds, on pourrait trouver pourquoi tes transistors, qui doivent a priori fonctionner en bloqué / saturé, font pas bien le job.

edit : grilled

RD2
Posts: 24
Joined: Mon Nov 10, 2014 8:04 pm

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 8:00 am

Merci pour vos réponse, alors le shéma du montage est le suivant :

Image

Les leds sont commandées en PWM par l'intermédiaire du raspberry. La led rgb est connectée entre les 6 ports RN/RP, GN/GP, BN/BP.
Attachments
Schema_projet_light.png
Schema_projet_light.png (27.85 KiB) Viewed 2046 times

danjperron
Posts: 3331
Joined: Thu Dec 27, 2012 4:05 am
Location: Québec, Canada

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 12:09 pm

En théorie cela devrait fonctionner!

Ajoute des résistances de charge, peut être des 1K en pull-up.

Ground la gate et regarde si le courant de coulage diminue.

Daniel

totoharibo
Posts: 4152
Joined: Thu Jan 24, 2013 8:43 am

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 3:21 pm

pas de problème de masse (OV) ?

jareczek
Posts: 170
Joined: Tue Jul 23, 2013 2:45 pm
Location: Auvergne

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 3:58 pm

- qu'est-ce qu'il y a sur PL12 ?
- comment est branchée ta diode (K et A) par rapport à N et P ? Je suppose que la diode rvb est connectée là !
- tu es sûr que les A et K ne sont pas reliées dans le boîtier ? donne donc le datasheet !
- comment est alimenté le circuit ?
- qu'est-ce que c'est PL1a et PL1b ?

D'après ce que je vois les led n'ont aucune raison de s'allumer !
Ou alors je deviens neuneu !
Sauf erreur ou omission . . .

jelopo
Posts: 1476
Joined: Wed Oct 17, 2012 7:53 pm

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 6:39 pm

Bonjour,

Il faut noter que certaines led 3 couleurs, ont des différences d'intensité lumineuse pour une même tension appliquée à chacune d'elles. En fait, dans ces "boitiers" led 3 couleurs, il y a trois leds de caractéristiques différentes (par exemple) :
- Rouge : 2 V - 500 MCD
- Vert : 3V - 3000 MCD
- Bleue : 3V - 2000 MCD
Du coup cela pourrait expliquer que visuellement lorsque les transistors doivent être à l'état non conducteurs 2 leds éclairent et une n'éclaire pas.
Aussi, est-tu sûr qu' il n'y a pas du tout de tension de commande sur R1, R2 et R3 lorsque les transistors doivent être non conducteur ? En plus de répondre aux questions de jareczek je te conseillerais bien de mesurer la tension sur la patte 1 de R1 et/ou de dessouder la patte 1 de R1 juste pour voir.

A+

nikotinux
Posts: 671
Joined: Sat Feb 02, 2013 2:11 am

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 7:44 pm

Gag vécu , j'ai inversé drain et source au câblage et j'avais un courant qui traversait la diode de protection ... ça marchait beaucoup moins bien aussi ...

RD2
Posts: 24
Joined: Mon Nov 10, 2014 8:04 pm

Re: Courant résiduel transistor : Led légèrement allumée

Thu Feb 12, 2015 9:12 pm

Merci beaucoup pour toutes ces pistes, c'est très intéressant! Je vais donc essayer de répondre à toutes les interrogations, dans l'ordre:
danjperron wrote:En théorie cela devrait fonctionner!

Ajoute des résistances de charge, peut être des 1K en pull-up.

Ground la gate et regarde si le courant de coulage diminue.

Daniel
Au contraire, le bleu s'éclaire légèrement plus

jareczek wrote:- qu'est-ce qu'il y a sur PL12 ?
- comment est branchée ta diode (K et A) par rapport à N et P ? Je suppose que la diode rvb est connectée là !
- tu es sûr que les A et K ne sont pas reliées dans le boîtier ? donne donc le datasheet !
- comment est alimenté le circuit ?
- qu'est-ce que c'est PL1a et PL1b ?

D'après ce que je vois les led n'ont aucune raison de s'allumer !
Ou alors je deviens neuneu !
- Du 12VDC
- Oui elle est connectée ici, l'anode est connectée sur le P (donc le +12 V) et la cathode sur le N. L'anode était commune sur la led mais je l'ai séparée pour connecter chaque pâte RGB indépendamment.
- Je n'ai pas vraiment de datasheet, je l'ai achetée ici si mes souvenirs sont bon : http://www.dx.com/p/10w-500-lumen-multi ... N0Wj_mG8wA
- Tout en 12 V, le 5V est réalisé par un convertisseur DC/DC
- C'est le connecteur relié au raspberry
jelopo wrote:Bonjour,

Il faut noter que certaines led 3 couleurs, ont des différences d'intensité lumineuse pour une même tension appliquée à chacune d'elles. En fait, dans ces "boitiers" led 3 couleurs, il y a trois leds de caractéristiques différentes (par exemple) :
- Rouge : 2 V - 500 MCD
- Vert : 3V - 3000 MCD
- Bleue : 3V - 2000 MCD
Du coup cela pourrait expliquer que visuellement lorsque les transistors doivent être à l'état non conducteurs 2 leds éclairent et une n'éclaire pas.
Aussi, est-tu sûr qu' il n'y a pas du tout de tension de commande sur R1, R2 et R3 lorsque les transistors doivent être non conducteur ? En plus de répondre aux questions de jareczek je te conseillerais bien de mesurer la tension sur la patte 1 de R1 et/ou de dessouder la patte 1 de R1 juste pour voir.

A+
Ce sont les couleurs bleu et rouge qui s'allument à ma grande surprise, j'ai supposé que cela venait d'ici aussi, mais cela m'aurrai allumé le bleu et le vert, ou que le rouge!

Au niveau des leds
0.80V sur le vert qui ne s'allume pas
4.70V sur le rouge qui s'allume
7.15 Vsur le bleu qui s'allume

pate 1 de R3 1.27V (Bleu)
pate 1 de R2 0.0V (Vert)
pate 1 de R1 0.367V (Rouge)

Ca se précise je pense! Il y a bien une tension résiduelle en quelque part! J'ai fais ça sur une platine test, à vue d'oeil, je ne voit rien qui touche...
nikotinux wrote:Gag vécu , j'ai inversé drain et source au câblage et j'avais un courant qui traversait la diode de protection ... ça marchait beaucoup moins bien aussi ...
J'en doute car j'aurai la même chose avec le vert, non?


jareczek
Posts: 170
Joined: Tue Jul 23, 2013 2:45 pm
Location: Auvergne

Re: Courant résiduel transistor : Led légèrement allumée

Fri Feb 13, 2015 4:34 am

Tes mesures de tensions R1/2/3 ne sont pas ce qu'elles devraient . . .

Dans ton lien on trouve I = 350 mA (je suppose que c'est pour chacune)
led R 7,5 V - led V&Ble 10,5V

On devrait donc avoir pour rouge R7 12 ohm, pour vert R8 et bleu R9 4 ohm, à une vache près.
Si c'est 350 mA pour les trois, multiplier les résistances par 3
Mais c'est pas ça qui les laisse allumées . . .

Faut donc mesurer, les diodes commandées une par une, les autres étant au repos, et par rapport au 0V
- Vs chaque GPIO
- Vd chaque mos
- Vk et Va chaque diode
- le courant diode si tu as 2 multimètres
Donc en tout 3 fois 12 mesures.
Avec ça le défaut est trouvé

C'est pas simple de dépanner par courrier !
Sauf erreur ou omission . . .

RD2
Posts: 24
Joined: Mon Nov 10, 2014 8:04 pm

Re: Courant résiduel transistor : Led légèrement allumée

Sat Feb 14, 2015 9:58 am

Merci encore pour cette aide à distance surement pas évidente.

Alors, en ce qui concerne les résistances, petite erreur sur le schéma joint, j'ai mis des 3.9 Ohms et 12 Ohms, donc ce qui colle avec tes calculs. De plus, j'ai fais une sorte de calibrage en courant avec une sorte de limitation logicielle. En fait, pour toutes les couleurs, mon PWM est limité pour ne pas avoir un courant supérieur à 0.2A (donc avec une grosse marge de sécurité car le radiateur sur lequel était monté ma led était limité, je vais peut être l'augmenter avec un autre rad!)

Pour les mesures, les voici (led allumée)

Vs GPIO
R : 2.89
G : 2.50
B : 2.76

Vd
R : 1.352
G : 1.93
B : 1.109

Vk
R : 5.52
G : 3.31
B : 2.54

Va
R : 11.92
G : 11.91
B : 11.91

Va-Vk
R : 6.38
G : 8.31
B : 9.36

Je n'ai pas fais le courant de diode... Est-ce suffisant?

Merci encore

danjperron
Posts: 3331
Joined: Thu Dec 27, 2012 4:05 am
Location: Québec, Canada

Re: Courant résiduel transistor : Led légèrement allumée

Sat Feb 14, 2015 3:09 pm

danjperron wrote:
Ajoute des résistances de charge, peut être des 1K en pull-up.

RD2 wrote:
Au contraire, le bleu s'éclaire légèrement plus

As-tu branché la résistance en parallèle avec la led ?

Normalement une résistance de charge qui est branché en parallèle avec la LED devrait dériver le courant de coulage et de ce fait réduire la tension sur la led. Par conséquent annuler toute conduction puisque la tension sur la led sera très loin du potentiel nécessaire pour passer par dessus la zone de déplétion électronique.

Même un courant de coulage, aussi faible qu'il soit , va passer par la led puisque rien va empêcher la led d'atteindre la tension pour une conduction. Donc une faible luminosité peut être visible. (très faible). La résistance de charge va éviter cela.

Peux-tu faire un post avec une photo de ton montage.

Daniel

jareczek
Posts: 170
Joined: Tue Jul 23, 2013 2:45 pm
Location: Auvergne

Re: Courant résiduel transistor : Led légèrement allumée

Sat Feb 14, 2015 6:25 pm

Le mosfet laisse passer 1 µA à l'état bloqué -> pas de lumière

Merci pour les valeurs mais il faut surtout celles concernant les diodes éteintes !
Donc tu allumes par ex V tu éteint R et B, puis tu fait les mesures pour R et B

Je présuppose une fuite quelque part dans ton montage

Dernière chose pour vérifier tes led : en dehors de ton montage alimente directement une led en 12V à travers une résistance de 3 Mohm (3 000 000) et regarde si elle s'allume

A bientôt
Sauf erreur ou omission . . .

danjperron
Posts: 3331
Joined: Thu Dec 27, 2012 4:05 am
Location: Québec, Canada

Re: Courant résiduel transistor : Led légèrement allumée

Sat Feb 14, 2015 7:09 pm

Le mosfet laisse passer 1 µA à l'état bloqué -> pas de lumière
La je ne suis pas d'accord !

il y a une fuite et rien pour empêcher le courant de passer par la diode. Il y a donc émission de photon.

Cela ne devrait pas ce voir mais une caméra avec une très longue exposition devrait la détecter.

Voici un petit montage avec une LED RGB qui a un courant ~ 1 uA et une lueur verte est visible même avec la caméra de mon portable et très visible avec mes yeux et en plus il 14hrs ici devant une fenêtre.

Image

RD2 nous a pas dit quelle est l'intensité.

C'est pour cela qu'une résistance de charge est nécessaire. Pour un coulage de 1uA une résistance de < 1Méga ohm fera l'affaire.

jareczek
Posts: 170
Joined: Tue Jul 23, 2013 2:45 pm
Location: Auvergne

Re: Courant résiduel transistor : Led légèrement allumée

Sat Feb 14, 2015 8:20 pm

Le data sheet de RD2 donne un courant pour une ou les 3 led de 350 mA

Je suppose que tu traduis automatiquement.
Les termes coulage, charge et fuite à quoi correspondent-ils en anglais ?
Sauf erreur ou omission . . .

danjperron
Posts: 3331
Joined: Thu Dec 27, 2012 4:05 am
Location: Québec, Canada

Re: Courant résiduel transistor : Led légèrement allumée

Sat Feb 14, 2015 8:26 pm

Non je suis du Québec alors le français est ma langue première malgré que mon milieu de travail est l'anglais.

J'ai un emploi en Ontario.

En anglais le courant de coulage ou le courant de fuite est "leakage current".

La résistance de charge sera "load resistance".

Le courant maximum d'une LED n'indique pas comment elle réagit à faible intensité.
Et j'ai besoin de voir une photo du montage et surtout de voir la luminosité de la led.

Daniel

jareczek
Posts: 170
Joined: Tue Jul 23, 2013 2:45 pm
Location: Auvergne

Re: Courant résiduel transistor : Led légèrement allumée

Sun Feb 15, 2015 9:03 am

Chez "nous" on dit courant de fuite ou courant résiduel.
Courant de "coulage" n'a pas de sens ! D'où mon interrogation.

Le problème de DR2 est intéressant car il faut déterminer si le circuit est en panne ou s'il est mal conçu.
En ayant le circuit sous les yeux ce serait plus facile.

Il faut extrapoler le courant diode lorsque le mosfet est bloqué en faisant des mesures de tension
Si les tensions sont correctes et les diodes allumées (à quel niveau d'intensité ?) nous sommes dans un cas "circuit mal conçu"

Pour l'instant je me considère dans le cas "circuit en panne" et il faut vérifier si le comportement du circuit est le comportement théorique.
Si le fonctionnement du circuit est normal (il fait ce qu'il doit faire) on passe à la suite.

Les tensions GPIO chargées par 11 k me semblent anormales (2,5V à 2,9V) mais je n'ai pas d'expérience GPIO avec le Pi
Sauf erreur ou omission . . .

RD2
Posts: 24
Joined: Mon Nov 10, 2014 8:04 pm

Re: Courant résiduel transistor : Led légèrement allumée

Sun Feb 15, 2015 1:32 pm

danjperron wrote:
danjperron wrote:
Ajoute des résistances de charge, peut être des 1K en pull-up.

RD2 wrote:
Au contraire, le bleu s'éclaire légèrement plus

As-tu branché la résistance en parallèle avec la led ?

Normalement une résistance de charge qui est branché en parallèle avec la LED devrait dériver le courant de coulage et de ce fait réduire la tension sur la led. Par conséquent annuler toute conduction puisque la tension sur la led sera très loin du potentiel nécessaire pour passer par dessus la zone de déplétion électronique.

Même un courant de coulage, aussi faible qu'il soit , va passer par la led puisque rien va empêcher la led d'atteindre la tension pour une conduction. Donc une faible luminosité peut être visible. (très faible). La résistance de charge va éviter cela.

Peux-tu faire un post avec une photo de ton montage.

Daniel

Alors je n'ai pas fais le test des résistances de pull up, juste la mise à la masse des gates. J'avoue ne pas avoir très bien compris ou entre quoi et quoi les mettre!

Voici les photos du montage :

Image

Image

Image
jareczek wrote:Le mosfet laisse passer 1 µA à l'état bloqué -> pas de lumière

Merci pour les valeurs mais il faut surtout celles concernant les diodes éteintes !
Donc tu allumes par ex V tu éteint R et B, puis tu fait les mesures pour R et B

Je présuppose une fuite quelque part dans ton montage

Dernière chose pour vérifier tes led : en dehors de ton montage alimente directement une led en 12V à travers une résistance de 3 Mohm (3 000 000) et regarde si elle s'allume

A bientôt
R allumée
Vd B = 0.315
Vd R = 2.60
Vd G = 0.167 (bruit multimètre)

G allumée
Vd B = 0.318
Vd R = 0.202
Vd G = 2.25

B allumée
Vd B = 2.32
Vd R = 0.200
Vd G = 0.167 (Bruit)

Pour la led, là ça me fait dessouder mon montage, mais si c'est vraiment necessaire, dis le moi je le ferrai!

En ce qui concerne le courant des leds, c'est 350 mA pour chaque couleurs, c'est une led 10W! Mais comme j'ai dis précedemment, j'ai limité mon montage à 200 mA par cannal, donc 600 mA au total!

Merci.

danjperron
Posts: 3331
Joined: Thu Dec 27, 2012 4:05 am
Location: Québec, Canada

Re: Courant résiduel transistor : Led légèrement allumée

Sun Feb 15, 2015 1:59 pm

Merci pour les photos!

J'ai des questions.

Quel est la différence de luminosité entre allumée ou éteinte. Ce que nous ne savons pas c'est le niveau d'intensité.
La troisième photo indique la LED en pleine puissance ou toute les lumières éteintes avec tout à OFF ? J'ai besoin d'une base de référence.

Est-ce très évident ou très subtile ? Seulement lorsque l'ont regarde la LED ?

Tu appliques un multimètre pour lire la tension. Est-ce que la luminosité de la LED change avec le contact des probes ?
(En mode OFF).

Pour moi il est évident qu'il y a un fuite de courant et que ton schéma ne fait rien pour l'enlever. Donc essai une résistance de 1K entre chaque anode et cathode de la led.

Daniel

RD2
Posts: 24
Joined: Mon Nov 10, 2014 8:04 pm

Re: Courant résiduel transistor : Led légèrement allumée

Sun Feb 15, 2015 3:41 pm

Alors, la différence entre led on et led Off est très importante, je parlais d'un courant de fuite car la lumière émise est très faible. Cependant, étant donné que c'est pour faire une lampe de chevet, la moindre lumière n'est pas très acceptable. Et là, dans une pièce noire, on voit un léger éclairement!

La troisième photo est une photo avec tout off, donc la led est censée être complètement éteinte. On voit bien que la rangée du milieu est complètement éteinte, c'est le vert!

Pour comparaison, la lumière orange au fond sur la droite correspond aux leds du raspberry, c'est légèrement moins lumineux qu'une des leds du raspberry!

Pour l'histoire du multimètre, j'avais, à un moment, observé un changement de luminosité du bleu, mais je n'arrive pas à le remettre en évidence!

fdufnews
Posts: 289
Joined: Fri Oct 07, 2011 5:37 pm

Re: Courant résiduel transistor : Led légèrement allumée

Sun Feb 15, 2015 4:09 pm

Ta carte déconnectée du raspberry les LEDs s'allument toujours?


fdufnews
Posts: 289
Joined: Fri Oct 07, 2011 5:37 pm

Re: Courant résiduel transistor : Led légèrement allumée

Sun Feb 15, 2015 4:19 pm

Pour mettre en évidence que le problème est lié ou non au courant de fuite (pourtant faible) du transistor, il suffirait de mettre en parallèle d'une des diodes qui reste allumée une résistance de quelques kilohm

Return to “Français”