linuxfox69
Posts: 9
Joined: Sun May 26, 2013 11:49 am

Bloqué au login

Sun May 26, 2013 12:04 pm

Bonjour a tous , j'ai fais l'acquisition d'un raspberry depuis peu et commencer a configurer chaque choses petit a petit ( ssh , ftp , vnc, clavier azerty , heure, update , upgrade ... ) mais voila a chaque fois revient la même étape sur laquelle je bloque ->

On me demande mon login et mon mot de passe qui est encore par défaut :

Je tape donc pi en login et raspberry en mot de passe puis je valide mais voila après un écran noir me laissant penser que je vais pouvoir accéder au bureau et bien on me ramène a la page pour me loguer. ( le ssh marche malgré sa pourtant j'ai accès a la console )

Mon système est normalement installer avec Win32DiskImager et l'iso wheezy-raspbian et cela fais 2 fois que je réinstalle tout donc voila si quelqu'un a une idée je ne trouve que des forums en anglais qui ne répondent pas a ma question. Merci d'avance !

Nutella
Posts: 2
Joined: Sun May 26, 2013 10:01 am

Re: Bloqué au login

Sun May 26, 2013 12:47 pm

qwerty azerty
user : pi
mdp : pqspberry

fdufnews
Posts: 288
Joined: Fri Oct 07, 2011 5:37 pm

Re: Bloqué au login

Sun May 26, 2013 1:22 pm

Peut être n'as-tu pas bien configuré ton Raspi à la première mise sous tension.
Il doit démarrer en clavier anglais. Comme le préconise Nutella pour saisir ton mot de passe tapes rqspberry au lieu de raspberry.

Autrement puisse que tu arrives à ouvrir une session en ssh, à partir de la console ssh lance:
sudo raspi-config
et là utilise configure_keyboard pour indiquer que tu utilises un clavier français
si tu ne l'as pas fait il faut aussi faire un change_local pour installer la langue française.

linuxfox69
Posts: 9
Joined: Sun May 26, 2013 11:49 am

Re: Bloqué au login

Sun May 26, 2013 1:26 pm

J'ai mis le clavier en azerty donc le mot de passe était bien raspberry , j'ai quand même essayé rqspberry mais rien n'y fais le mot de passe est reconnu mais on me renvoi a la page de login.

Après avoir changer le mot de passe le résultat est le même ...

JumpZero
Posts: 852
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Bloqué au login

Sun May 26, 2013 4:33 pm

Bjr,
Est-ce que je comprend bien?
pi/raspberry ok en ssh. Mais pas ok en direct sur clavier ecran du Pi.
C'est ca? Si c'est ca ton clavier deconnes. Essaies de taper plein de lettres dans le login au lieu de simplement 'pi'. Juste pour voir si tout ce que tu tapes s'affiche (puisque quand on passe au mot de passe on voit plus rien) tu pourras aussi voir si ton 'q' est un 'a'. Il y a beaucoup de probleme avec les claviers usb qui tirent trop de courrant et ca fait souvent des caracteres qui se repetent: tu tapes une touche elle apparait 10 fois...

linuxfox69
Posts: 9
Joined: Sun May 26, 2013 11:49 am

Re: Bloqué au login

Sun May 26, 2013 5:10 pm

Oui c'est bien sauf que j'ai bien fais les réglages le clavier marche il est en azerty et le mot de passe est bon mais au moment de normalement ouvrir la session on me redemande le mot de passe

JumpZero
Posts: 852
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Bloqué au login

Sun May 26, 2013 5:46 pm

mais au moment de normalement ouvrir la session
Tu parles bien la première session après le boot qui s'affiche sur l’écran connecté au Pi (HDMI ou composite) et tu utilises le clavier connecté au Pi en usb. Il y a l'adresse IP affichée et juste au dessous le mot login: suivi du curseur? Soyons précis, l'erreur est toujours dans le détail...
As tu essayé de taper plein de lettres dans le login au lieu de simplement 'pi'. Juste pour voir si tout ce que tu tapes s'affiche?

linuxfox69
Posts: 9
Joined: Sun May 26, 2013 11:49 am

Re: Bloqué au login

Sun May 26, 2013 6:37 pm

Oui lors du second boot, l'accès a l'interface graphique après avoir installer toute les maj et autres.
Je met les login par défaut pi et raspberry en essayant les variantes au cas ou le clavier ne serait pas en azerty.
La session " se referme sans même s’ouvrir " sans raison et me redemande mes identifiants , oui j'ai bien tester le clavier est pourtant en azerty et les touches fonctionnent. Je peux accéder au système via ssh et changer le mot de passe mais la encore rien n'y fait , est ce qu'il y aurait une autre commande ?

JumpZero
Posts: 852
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Bloqué au login

Sun May 26, 2013 10:54 pm

Hum!
J'ai l'impression que l'on ne parle pas de la même chose.
C'est quoi le second boot? Es-ce que tu veux dire que tu as booté avec une Raspbian toute fraiche ensuite tu as configuré dans raspi-config et tu reboot une deuxième fois?
Et quelle interface graphique? Décris stp.
--
Jmp0

linuxfox69
Posts: 9
Joined: Sun May 26, 2013 11:49 am

Re: Bloqué au login

Mon May 27, 2013 1:31 am

Pour faire clair je grave l'iso sur la carte sd , je mets la carte sur le raspberry , arrivé dans le bios je fais les réglages comme mettre le clavier en azerty et activé le ssh . Je lance mon système et commence a m'en servir puis après l'avoir arrêté et redémarré 3h après j'arrive sur une page qui me demande mes identifiants mais malheureusement l'accès au bureau met fermé ( l'interface graphique) et on me redemande mes identifiants encore et encore ( sans me dire qu'il sont incorrect , j'ai essayé un mauvais mot de passe et sa m'affiche mot de passe incorrect ... ).

JumpZero
Posts: 852
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Bloqué au login

Mon May 27, 2013 11:24 am

Ce que tu appelles le bios d'ou tu fais les réglages n'est pas un bios c'est "raspi-config". C'est un programme fait pour le Pi qui se lance la première fois et que tu peux relancer autant de fois que tu veux avec la commande "sudo raspi-config".
D’après ce que tu dis, si tu arrives directement au bureau de l'interface graphique quand tu boot, c'est que tu as activé cette option depuis raspi-config.
Donc ce que je te proposes, c'est d'y aller étapes par étapes:
Tu accèdes au Pi en ssh, tu lances raspi-config, tu désactives le lancement automatique de l'interface graphique au boot. Et tu reboot. Là tu vas arriver sur un écran texte qui te demanderas ton login.
Tu te log depuis la. Ça devrait marcher. Ensuite pour lancer l'interface graphique tu tapes "startx". Et il n'y a plus de mot de passe.
Réussies déjà ça, tu verras pour lancer le bureau au boot ensuite.
Si tu n'arrives pas a te loger, vérifies ton mot de passe en le tapant a la place du login (a la place de "pi"), comme ça tu vois s'afficher ce que tu tapes, tu vois si quand tu tapes un 'a' c'est bien un 'a'. Juste pour vérifier.
--
Jmp0

kalou60
Posts: 7
Joined: Mon Mar 18, 2013 10:50 am

Re: Bloqué au login

Mon May 27, 2013 11:52 am

Bonjour
En ssh créé l'utilisateur root ainsi qu'un mot de passe, sur le raspberry logue toi en root avec mdp.

linuxfox69
Posts: 9
Joined: Sun May 26, 2013 11:49 am

Re: Bloqué au login

Mon May 27, 2013 12:14 pm

Et bien merci a toi on dirais qu'il a quelque chose contre ce réglage j'ai donc fais comme tu ma dis enlever le démarrage au bureau. Par contre question on me dis que tous les réglages non pas été dans raspi-config, l'heure , le clavier , la langue , est ce qu'il y a autre chose ?

tulipe11
Posts: 3
Joined: Thu Apr 07, 2016 3:13 pm

Re: Bloqué au login

Fri Apr 08, 2016 3:19 pm

Bonjour
J'ai le méme probleme avec la derniére version de raspbian.
premiére installation tout est ok, j'arrive à l'interface graphique lance des applis etc.

Puis j'ai fait un sudo upgrade et depuis je tombe toujours sur l'interface de session qui refuse mon entrée vers "gnome".

méme si je met le bon mot de passe et login, j'ai écran noir et je retourne sur la page de saisie.
curieusement j'ai accés au ssh voir méme à l'interface avec un VNC distant, quoi est ce ?

nikotinux
Posts: 670
Joined: Sat Feb 02, 2013 2:11 am

Re: Bloqué au login

Fri Apr 08, 2016 4:12 pm

linuxfox69 wrote:est ce qu'il y a autre chose ?
étendre la partition !!

slhoir
Posts: 7
Joined: Sat Jun 18, 2016 7:25 pm

Re: Bloqué au login

Thu Nov 03, 2016 7:54 am

Bonjour,

Avez-vous trouvé une solution à ce problème. Je suis dans le même cas.

Connexion ssh OK, mais sur l'interface graphique (directement depuis l'ordi ou via VNC), refus du mot de passe.

A lire le sujet, je n'en voit pas !

Merci

totoharibo
Posts: 3882
Joined: Thu Jan 24, 2013 8:43 am

Re: Bloqué au login

Thu Nov 03, 2016 10:05 am

slhoir wrote:Bonjour,

Avez-vous trouvé une solution à ce problème. Je suis dans le même cas.

Connexion ssh OK, mais sur l'interface graphique (directement depuis l'ordi ou via VNC), refus du mot de passe.

A lire le sujet, je n'en voit pas !

Merci
connection avec l'utilisateur pi sur l'interface graphique ?

Va faire un tour du côté des logs (en root : sudo su avant) dans /var/log. Un tail permet pour voir la fin des fichiers de logs après une tentative avortée.

slhoir
Posts: 7
Joined: Sat Jun 18, 2016 7:25 pm

Re: Bloqué au login

Thu Nov 03, 2016 12:41 pm

OK, merci.
J'ai trouvé dans le syslog :
Nov 3 13:24:34 raspberrypi lightdm[598]: ** (process:1818): WARNING **: Error reading existing Xauthority: Failed to open file '/home/pi/.Xauthority': Permission denied
Le propriétaire du fichier était root:root.
J'ai remis pi:pi et c'est rentré dans l'ordre.
Je me demande tout de même ce qui a pu provoquer ce changement !!!
MERCI

bibe
Posts: 1
Joined: Fri Nov 18, 2016 12:02 am

Re: Bloqué au login

Fri Nov 18, 2016 12:13 am

slhoir wrote:OK, merci.
J'ai trouvé dans le syslog :
Nov 3 13:24:34 raspberrypi lightdm[598]: ** (process:1818): WARNING **: Error reading existing Xauthority: Failed to open file '/home/pi/.Xauthority': Permission denied
Le propriétaire du fichier était root:root.
J'ai remis pi:pi et c'est rentré dans l'ordre.
Je me demande tout de même ce qui a pu provoquer ce changement !!!
MERCI
pour être bien clair, si vous êtes bloqué au login/password après la dernière mise a jour de la raspberry (la version pixel), faites :
- 1 - une connexion en ssh avec pi/"le-mot-de-passe-que-vous-connaissez"
- 2 - sudo chown pi:pi /home/pi/.Xauthority (chown=changement du propriétaire et du groupe)
- 3 - depuis l'interface graphique de la raspberry -> Eteindre (ou à la sauvage débranche/rebranche)
- 4 - redémarrer votre Raspberry et tout il est beau !

Toma1
Posts: 4
Joined: Thu Feb 02, 2017 10:28 am

Re: Bloqué au login

Thu Feb 23, 2017 10:07 am

Bonjour, je ré-ouvre se sujet car j'ai une petite question par rapport à ce changement de droit un peu bizarre.

J'aimerais beaucoup savoir qu'est-ce qui peu produire le changement de droit, j'ai l'impression que c'est liée à certaines modification au niveau du lancement automatique d'applications l’ouverture de la session, mais ce n'est qu'une supposition.

Donc si vous avez la réponse ou si vous avez la foie de rechercher la source du problème je serais ravi d'avoir vos avis à ce sujet, merci !

mem123
Posts: 18
Joined: Mon Mar 06, 2017 3:43 pm

Re: Bloqué au login

Tue May 09, 2017 8:17 am

Bonjour,
J'ai eu le même probleme que vous.

Pour comprendre la source du probléme je l'ai accédé à parir de ssh et j'ai affiché le syslog.
J'ai réalisé que la Raspberry n'a plus d'espace mémoire.
Donc j'ai supprimé quelque dossiers inutiles via ssh et après je pouvait me connecter sans probleme.

tomatoes
Posts: 1
Joined: Fri May 11, 2018 8:12 pm

Re: Bloqué au login

Fri May 11, 2018 8:19 pm

Bonjour

J'ai le même problème. Si j'ai bien compris, on ne peut pas résoudre le problème sans SSH ? Je peux me connecter avec VNC a ma rpi et je me demandais si c'était faisable par ce biais là ?

Merci d'avance pour vos réponses.

PS : Je suis tout nouveau et n'y connais pas grand chose ^^

HATHEMI
Posts: 8
Joined: Tue Aug 16, 2016 9:08 pm

Re: Bloqué au login

Mon May 21, 2018 1:18 pm

j'ai le même problème et je ne peux pas comprendre comment puis-je le fixer
SSH - -bash: impossible de créer un fichier temporaire pour le document ici: lorsque j'utilise TAB
Je suis bloqué sur l'interface graphique de connexion à chaque fois que je tape mon mot de passe
quand je me connecte à ssh, et tape rd -h je trouve cette ligne '/ dev / root 100%'. je pense que si je peux libérer de l'espace mon problème sera résolu
Toute aide, s'il vous plaît. : |

Berthy
Posts: 1
Joined: Tue May 29, 2018 10:30 pm

Re: Bloqué au login

Tue May 29, 2018 10:34 pm

Bonjour je sais que ça fais longtemps mais j'ai eu le même problème et je l'ai résolu, j'avais mis mes clé usb en raid et mon point de montage "/home/pi" j'ai retiré les clef usb et voilà.

Return to “Français”

Who is online

Users browsing this forum: No registered users and 11 guests