Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

xbmc pb youtube

Sun Feb 17, 2013 3:20 pm

Bonjour,

Sur mon Rasberry j'ai installé xbmc, en suivant cette méthode:
http://michael.gorven.za.net/raspberrypi/xbmc

voir aussi ici " http://www.raspberrypi.org/phpBB3/viewt ... 65&t=32935 " ou j'en parle.

Puis, j'ai installé sur xbmc le plugin youtube...
Le problème, c'est que au début il fonctionnait, bien que certaines vidéos affichées un écran noir, peut-être dut à un problème de codec (en fait je serai curieux savoir ou était réellement le problème)... mais actuellement je ne peut plus lire aucune vidéo!

Chaque fois que je veux lire une vidéo, on dirait quelle charge puis j'ai le massage "adresse vidéo non trouvé" !

Quelqu'un peut-il m'aider à dépanner ?

@+

JM

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Sun Feb 17, 2013 10:32 pm

Bonsoir,

Je viens d'activer le mode debug pour générer le log dans:

Code: Select all

~/.xbmc/temp/xbmc.log
Voila le contenu de mon fichier xbmc.log au moment ou intervient le problème:

Code: Select all

23:20:44 T:2925126672   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.image_decode handle 
0xae62f000 dllopen : 1
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.image_decode input port 320 output port 321
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.resize handle 0xb3c2eff8 dllopen : 1
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.resize input port 60 output port 61
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.image_decode) - port(320), nBufferCountMin(2), nBufferCountActual(3), nBufferSize(81920), nBufferAlignmen(16)
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::AllocOutputBuffers component(OMX.broadcom.resize) - port(61), nBufferCountMin(1), nBufferCountActual(1), nBufferSize(706560) nBufferAlignmen(16)
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.resize handle 0xb3c2eff8 dllopen : 1
23:20:44 T:2925126672   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.image_decode handle 0xae62f000 dllopen : 1
23:20:44 T:2925126672   DEBUG: Creating DDS version of: special://masterprofile/Thumbnails/2/2bdf956e.jpg
23:20:49 T:3036344320   DEBUG: ------ Window Deinit (Pointer.xml) ------
23:21:01 T:2925126672   DEBUG: Compress - using DXT1 (min error is: 15.12:0.00)
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.image_decode handle 0x01d17d58 dllopen : 1
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.image_decode input port 320 output port 321
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.resize handle 0x023171e0 dllopen : 1
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.resize input port 60 output port 61
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.image_decode) - port(320), nBufferCountMin(2), nBufferCountActual(3), nBufferSize(81920), nBufferAlignmen(16)
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::AllocOutputBuffers component(OMX.broadcom.resize) - port(61), nBufferCountMin(1), nBufferCountActual(1), nBufferSize(706560) nBufferAlignmen(16)
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.resize handle 0x023171e0 dllopen : 1
23:21:01 T:2943751184   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.image_decode handle 0x01d17d58 dllopen : 1
23:21:01 T:2943751184   DEBUG: Creating DDS version of: special://masterprofile/Thumbnails/8/81fa8d01.jpg
23:21:04 T:3036344320   DEBUG: ------ Window Init (Pointer.xml) ------
23:21:06 T:3036344320   DEBUG: ProcessMouse: trying mouse action leftclick
23:21:06 T:3036344320   DEBUG: OnPlayMedia plugin://plugin.video.youtube/?path=/root/video&actio
n=play_video&videoid=rsUW0iV12js
23:21:06 T:3036344320   DEBUG: CAnnouncementManager - Announcement: OnClear from xbmc
23:21:06 T:3036344320   DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnClear
23:21:06 T:3036344320   DEBUG: CAnnouncementManager - Announcement: OnAdd from xbmc
23:21:06 T:3036344320   DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnAdd
23:21:06 T:3036344320   DEBUG: StartScript - calling plugin YouTube('plugin://plugin.video.youtube/','5','?path=/root/video&action=play_video&videoid=rsUW0iV12js')
23:21:06 T:3036344320    INFO: initializing python engine.
23:21:06 T:3036344320   DEBUG: new python thread created. id=7
23:21:06 T:3036344320   DEBUG: WaitOnScriptResult - waiting on the YouTube (id=7) plugin...
23:21:06 T:2861450256  NOTICE: Thread XBPyThread start, auto delete: false
23:21:06 T:2861450256   DEBUG: Python thread: start processing
23:21:07 T:2861450256  NOTICE: -->Python Interpreter Initialized<--
23:21:07 T:2861450256   DEBUG: Process - The source file to load is /home/pi/.xbmc/addons/plugin.video.youtube/default.py
23:21:07 T:2861450256   DEBUG: Process - Setting the Python path to /home/pi/.xbmc/addons/plugin.video.youtube:/usr/share/xbmc/addons/script.module.simplejson/lib:/usr/share/xbmc/addons/weather.wunderground/resources/lib/wunderground:/usr/share/xbmc/addons/script.module.pil/lib:/home/pi/.xbmc/addons/script.common.plugin.cache/lib:/home/pi/.xbmc/addons/script.module.simple.downloader/lib:/home/pi/.xbmc/addons/script.module.parsedom/lib:/usr/share/xbmc/addons/script.module.pysqlite/lib:/usr/lib/python2.7:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/local/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages/PIL:/usr/lib/pymodules/python2.7:
23:21:07 T:2861450256   DEBUG: Process - Entering source directory /home/pi/.xbmc/addons/plugin.video.youtube
23:21:07 T:2861450256   DEBUG: Instantiating addon using automatically obtained id of "plugin.video.youtube" dependent on version 2.1.0 of the xbmc.python api
23:21:08 T:3036344320   DEBUG: DialogProgress::StartModal called
23:21:08 T:3036344320   DEBUG: ------ Window Init (DialogProgress.xml) ------
23:21:08 T:3036344320    INFO: Loading skin file: DialogProgress.xml, load type: KEEP_IN_MEMORY
23:21:09 T:2861450256  NOTICE: YouTube-4.4.1
23:21:11 T:2861450256  NOTICE: CommonFunctions-2.5.1
23:21:11 T:2861450256   DEBUG: LocalizeStrings: no strings.po file exist at /home/pi/.xbmc/addons/plugin.video.youtube/resources/language/French, fallback to strings.xml
23:21:11 T:2861450256   DEBUG: LocalizeStrings: no strings.po file exist at /home/pi/.xbmc/addons/plugin.video.youtube/resources/language/English, fallback to strings.xml
23:21:12 T:3036344320    INFO: CheckIdle - Closing session to http://i.ytimg.com (easy=0x1f02a40, multi=0xae60d8a8)
23:21:12 T:3036344320    INFO: CheckIdle - Closing session to http://i.ytimg.com (easy=0x22eff48, multi=0x1f1ce10)
23:21:12 T:3036344320    INFO: CheckIdle - Closing session to http://i.ytimg.com (easy=0x229d0c8, multi=0xa9f020a0)
23:21:12 T:3036344320    INFO: CheckIdle - Closing session to http://i.ytimg.com (easy=0xae63ee10, multi=0xb3cd4f60)
23:21:13 T:3036344320   DEBUG: ------ Window Deinit (Pointer.xml) ------
23:21:19 T:2861450256  NOTICE: links: 'dict'
23:21:19 T:2861450256    INFO: Scriptresult: Success
23:21:19 T:3036344320   DEBUG: ------ Window Init (DialogKaiToast.xml) ------
23:21:19 T:2861450256    INFO: Python script stopped
23:21:19 T:2861450256   DEBUG: Thread XBPyThread 2861450256 terminating
23:21:19 T:3036344320   DEBUG:  WaitOnScriptResult - plugin exited prematurely - terminating
23:21:19 T:3036344320   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=rsUW0iV12js]
23:21:19 T:3036344320   DEBUG: Playlist Player: no more playable items... aborting playback
23:21:20 T:2861450256  NOTICE: Thread Background Loader start, auto delete: false
23:21:20 T:3036344320   DEBUG: waiting for python thread 7 (/home/pi/.xbmc/addons/plugin.video.youtube/default.py) to stop
23:21:20 T:3036344320   DEBUG: python thread 7 (/home/pi/.xbmc/addons/plugin.video.youtube/default.py) destructed
23:21:20 T:2861450256   DEBUG: Thread Background Loader 2861450256 terminating
23:21:20 T:3036344320   DEBUG: ------ Window Deinit (DialogProgress.xml) ------
23:21:22 T:2943751184   DEBUG: Compress - using DXT1 (min error is: 17.87:0.00)
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.image_decode handle 0xb3c01ee0 dllopen : 1
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.image_decode input port 320 output port 321
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.resize handle 0xae64b148 dllopen : 1
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.resize input port 60 output port 61
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.image_decode) - port(320), nBufferCountMin(2), nBufferCountActual(3), nBufferSize(81920), nBufferAlignmen(16)
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::AllocOutputBuffers component(OMX.broadcom.resize) - port(61), nBufferCountMin(1), nBufferCountActual(1), nBufferSize(706560) nBufferAlignmen(16)
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.resize handle 0xae64b148 dllopen : 1
23:21:22 T:2925126672   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.image_decode handle 0xb3c01ee0 dllopen : 1
23:21:22 T:2925126672   DEBUG: Creating DDS version of: special://masterprofile/Thumbnails/1/12c5ecb4.jpg
23:21:24 T:3036344320   DEBUG: ------ Window Deinit (DialogKaiToast.xml) ------
J'ai espoir que quelqu'un me viendra en aide!

@+

JM

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: xbmc pb youtube

Mon Feb 18, 2013 9:11 am

Et moi j'ai espoir que tu trouves une solution, car j'ai installé le plugin Youtube ce week end, et j'ai noté exactement le même problème !

J

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: xbmc pb youtube

Mon Feb 18, 2013 10:10 am

J'ai trouvé ce lien sur la partie anglosaxonne du forum : http://forum.xbmc.org/showthread.php?ti ... pid1191793

A priori c'est une solution à ce problème, donc à tester.

(Cela dit, le problème date de septembre dernier, et je trouve curieux que la version du plugin sur le dépot officiel soit toujours foireuse ! )

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Mon Feb 18, 2013 6:29 pm

Bien vu Zoolan...

Sauf que sais pas si tu as essayé de tester cette solution, mais les liens fournis sont cassé (erreur 404)!

Donc pour le moment toujours pas solution en vu!

JM

custk9
Posts: 8
Joined: Tue Feb 12, 2013 10:54 pm

Re: xbmc pb youtube

Mon Feb 18, 2013 6:51 pm

Il faut remplacer le YouTubePlayer.py avec celui téléchargé du https://www.dropbox.com/l/GBKQUmxrRnoOBGFB

Testé et ça marche.

Source: http://forum.xbmc.org/showthread.php?ti ... pid1338677

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: xbmc pb youtube

Tue Feb 19, 2013 8:58 am

Salut,

Quand j'ai écris le post, je n'avais pas testé les liens non...

Donc merci à custk9 de nous en fournir un valide :)

Je vais remplacer le fichier via SSH dès maintenant, et je testerai ce soir en rentrant.

J

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Tue Feb 19, 2013 9:25 pm

Bonsoir,

Donc, je viens de tester la solution donné par custk9 et... cela re-fonctionne comme avant... cad que j'arrive a lire correctement certaines vidéos, et sur d'autres j'ai correctement la bande son mais pas d'image!

Cela à quand-même résolut le problème, mais cela ne me donne pas entière satisfaction!

JM

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: xbmc pb youtube

Wed Feb 20, 2013 9:13 am

Pour l'absence d'image, peut être est ce un problème de codec ?

Aussi, j'ai noté que sur la version web de Youtube, certaines vidéos sont illisibles dans certaines résolutions, as tu essayé de modifier la résolution pour celles qui ne s'affichent pas ?

J

custk9
Posts: 8
Joined: Tue Feb 12, 2013 10:54 pm

Re: xbmc pb youtube

Wed Feb 20, 2013 6:11 pm

Est-ce-que tu peut verifier que les videos marche sur un ordinateur? Comme zoolander a dit, peut être une problème avec un codec? Mpeg-2 codec clé acheté?

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Wed Feb 20, 2013 7:10 pm

C'est ça Zooland... c'est bien un problème de résolution...
Je suis aller dans la configuration du plugin, et j'ai sélectionné choir résolution manuellement!

C'est bien con que xbmc ne s'adapte pas automatiquement aux résolutions disponibles!

Le plugin youtube a encore visiblement de la mage de progression (évolution)!

@+

JM

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: xbmc pb youtube

Thu Feb 21, 2013 8:18 am

Le problème ne vient pas d'une mauvaise gestion de la résolution par XBMC, mais d'un mauvais encodage de ces résolutions sur Youtube je pense. Si XBMC choisit cette résolution, c'est qu'elle est censée être disponible...

Moi je l'ai testé hier soir, et ça marche nickel... Sauf que je suis chez Free... Donc ça marche nickel si tu attends 45 minutes pour charger une vidéo HD de 5 minutes...

Quelqu'un connait un provider honnête avec une bonne interface TV et pas de bridage ? :-p

J

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Thu Feb 21, 2013 5:23 pm

Non, xbmc ne choisi pas la résolution... soi tu lui fixe la résolution dans la configuration... soi tu lui dis que tu choisiras la résolution au moment de la lecture... mais dans tout les cas c'est l'utilisateur qui choisit!

JM

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: xbmc pb youtube

Fri Feb 22, 2013 10:00 am

Ah, je pensais qu'on lui fixait une résolution max, et qu'il choisissait la plus haute disponible.

Cela me parait étonnant quand même, car si tu indiques dans la configuration 1080, tu dois pas avoir accès à beaucoup de vidéos !

J

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Fri Feb 22, 2013 5:42 pm

Si tu fixe du 1080, je crois qu'il fera que du 1080... par-contre je crois qu'il y-a eu une mise à jour... tu choisis "vidéo base résolution" dans la configuration... cela donne de bon résulta à l'affichage, et ça passe apparemment sur toutes les vidéos!

JM

Ptijean
Posts: 12
Joined: Sat Feb 09, 2013 2:07 pm

Re: xbmc pb youtube

Sat Feb 23, 2013 2:30 pm

Et le top avec plugin youtube, dans exploration tu vas dans top 100 musiques, sur la chemise sélectionné avec le bouton title tu fais apparaître le menu, et tu sélectionnes dedans "lire aléatoire", puis play... tu auras toutes les vidéos du top 100 musiques qui défileront non-stop sur ta tv... ça peut être sympa pour une ambiance autour d'un apéro dînatoire par exemple!!!

JM

Return to “Français”