User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Débit catastrophique

Wed Jan 23, 2013 7:39 am

Bonjour à tous,

Je possède un Raspberry model B 512Mo qui tourne sur raspbian. Le bonheur ;)

Je voulais le tester pour rendre un simple disque externe (alimenté par sa propre alim), en NAS via le raspberry via samba.

Quand je tente une copie de fichier depuis un pc sur le réseau, vers le raspberry (passant par samba), sur le disque externe, en débit je suis à 400Ko/sec sur des gros fichiers...
L'externe directement sur le pc me donne du 30Mo/sec.

Est-ce que c'est vraiment un problème de chipset usb sur le raspberry qui est si lent ? Le cpu arm pendant la copie est variable à 60%.

Quelqu'un a déjà tenté la même chose ? Vous obtenez quoi ?

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Wed Jan 23, 2013 6:16 pm

J'ai testé en ext4, c'est mieux, environ 4-5Mo/sec..

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Fri Jan 25, 2013 9:25 am

Je me sens tellement seul... En NTFS j'avais un débit de 200 ko/s, ce qui est ridicule. Je pensais que passer en EXT4 règlerait mes problèmes, je suis passé à 600 ko/s... C'est 3 fois mieux, mais c'est quand même pourrave !

Sur le NAS de la Freebox, avec le même PC, je suis à plus de 2 Mo/s...

J

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Fri Jan 25, 2013 9:38 am

N'empêche que je ne trouve pas de solution :s
Dommage ça aurait été sympa de recycler les vieux disques externes en NAS via raspberry :s

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Fri Jan 25, 2013 10:22 am

Je pense que 30 Mo/s serait illusoire, du simple fait que le chipset réseau est un 100 Mbps (environ 12 Mo/s). A mon sens, 5 Mo/s c'est un résultat plutôt probant pour un NAS basé sur un Pi :)

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Fri Jan 25, 2013 10:27 am

En effet, mais je ne demande pas 30Mo, mais se rapprocher des 10Mo ça serait pas mal :) Là 400Ko c'est ridicule.

Je vais tenter d'utiliser les derniers modules ntfs-3g compilés direct sur le rasp. On sait jamais :)

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Fri Jan 25, 2013 10:35 am

Ah ok, je n'avais pas compris que tu voulais absolument rester sur du NTFS...

A mon avis, c'est peine perdue, le driver NTFS est limité, ne serait ce que par sa consommation de CPU.

Au delà de ça, je doute sincèrement de la possibilité d'atteindre le débit max du port Ethernet (toujours pour des problèmes de ressources).

Donc, je serais toi, je formaterais mon disque en EXT4.

J

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Fri Jan 25, 2013 12:19 pm

Je sais, mais le fait de le laisser en ntfs me permet de le brancher ailleurs si besoin.. :)

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Fri Jan 25, 2013 2:15 pm

Si ailleurs est un ou plusieurs autres machines connues, tu peux installer un driver EXT4 sur les machines en question, ça sera sans doute plus performant.

Sinon, effectivement, c'est un problème insoluble (à moins de trouver un format de fichier qui soit supporté de façon performante par tous les OS, et si possible en natif).

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Fri Jan 25, 2013 5:01 pm

Ext4 sous windows ?

J'ai tenté la dernière version ntfs-3g compilée, ça change rien.

En tout cas, en ext4, c'est samba qui bouffe 70% du CPU. Y'a peut-être une alternative à samba plus légère (pour des clients windows) ?

User avatar
ecaheti
Posts: 140
Joined: Tue Aug 14, 2012 3:06 pm
Location: Normandie, France
Contact: Website

Re: Débit catastrophique

Fri Jan 25, 2013 7:07 pm

Je vous maudis avec vos histoire ! mon accès au Pi est tombé à 250ko/s !

Bon, rien de dramatique, j'ai fait un ifdown / ifup de eth0 et tout est rentré dans l'ordre.

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Fri Jan 25, 2013 7:21 pm

Quoi ? Tu es en quel filesystem ?

User avatar
ecaheti
Posts: 140
Joined: Tue Aug 14, 2012 3:06 pm
Location: Normandie, France
Contact: Website

Re: Débit catastrophique

Fri Jan 25, 2013 10:21 pm

J'en discutais dans un autre topic, mon disque est en NTFS.

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Sat Jan 26, 2013 1:40 pm

Et tu as quel débit ? Tu as fait comment ? :p

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Sat Jan 26, 2013 2:06 pm

Je pense avoir trouvé. Ajoutez l'option noatime au montage ntfs.

Avec ça je tourne à 5Mo/sec en ntfs :)

User avatar
ecaheti
Posts: 140
Joined: Tue Aug 14, 2012 3:06 pm
Location: Normandie, France
Contact: Website

Re: Débit catastrophique

Sun Jan 27, 2013 8:23 am

Pour les options de montage j'ai fait un peu le bourrin.
J'ai lancé LXDE, branché le disque qui a été automatiquement reconnu, et j'ai copié / collé la config de montage dans fstab

Code: Select all

/dev/sda1	/media/300go	auto  rw,nosuid,nodev,allow_other,default_permissions	0	0
Mais maintenant que je copie colle mon fstab, je le trouve bien propre... Enfin soit, ça me donne l'occasion de partager ma config, peut etre que ça peut servir.

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Mon Jan 28, 2013 7:56 am

tu as quoi comme débit sur ton ntfs ?

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Mon Jan 28, 2013 8:42 am

ouafnico wrote:Je pense avoir trouvé. Ajoutez l'option noatime au montage ntfs.

Avec ça je tourne à 5Mo/sec en ntfs :)
Merci pour cette info :)

User avatar
rhodan51
Posts: 110
Joined: Fri Aug 17, 2012 10:33 am

Re: Débit catastrophique

Tue Feb 12, 2013 9:49 am

Bonjour,

J'ai le même problème de débit avec mon disque dur externe formaté en btrfs. Le débit ne dépasse pas les 100 Ko/s.

J'aimerais beaucoup pouvoir utiliser mon disque dur externe afin d'augmenter la capacité de stockage de mon RPI. Je souhaites, à des fin de test, garder le format btrfs pour mon disque externe.

J'ai lu dans le magazine "GNU Linux Magazine n°156" que le débit des 2 ports usb et du port Ethernet était partagé par le même contrôleur (qui est d'ailleurs absent sur la version A qui vient de sortir). Étant donné que mon RPI est en réseau via le wifi, je peux comprendre que le débit ne soit pas très rapide pour l'accès à mon disque externe mais à 100ko/s, il est inenvisageable d'utiliser mon disque en tant que support de stockage. Je ne sais pas si cela serait mieux en Ethernet car je suis obligé de passer par le CPL pour le relier à ma box et comme le débit Ethernet est partagé avec l'usb...

Ce que je souhaiterais, c'est avoir un débit plus important (en sachant très bien que je ne peux pas espérer de miracle) comme j'ai avec ma carte SD.

Quelle solution peut il y avoir ?

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Tue Feb 12, 2013 10:22 am

L'usb est ta seule solution. Par contre essaye un autre format de fichier pour voir si c'est mieux (même si tu veux rester en brtfs).

Sinon, tout comme moi, essaye de modifier des options de montages (ça a changé du tout au tout sur ntfs).

User avatar
rhodan51
Posts: 110
Joined: Fri Aug 17, 2012 10:33 am

Re: Débit catastrophique

Tue Feb 12, 2013 12:52 pm

J'ai testé en ntfs et en ext4, c'est à peine mieux, je dépasse pas les 500ko/s, même avec l'option noatime.

Je pense que je suis bridé au niveau du débit usb car j'ai un dongle wifi pour communiquer en réseau avec mon RPI.

J'ai comparé avec le débit de ma carte SD et je ne dépasse pas les 500ko/s non plus bien que ce soit une classe 10.

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Wed Feb 13, 2013 2:34 pm

Je ne sais pas si c'est lié au wifi, car mon RPi est bien connecté en Ethernet, mais j'ai des débits du même acabit.

A noter : mon PC lui est connecté en wifi 54 Mbps à la Freebox, et le RPi est connecté en Ethernet 100Mbps à la même Freebox.

En termes de performances, j'obtiens :
PC <-> NAS Freebox : 2 Mo/s
PC <-> NAS RPi EXT4 : 600 ko/s

Conclusion : soit le port Ethernet du RPi est pourri, soit le débit du disque est pourri. Je pencherais plus pour le port Ethernet, mais pour en avoir le cœur net, il faudrait que je mesure le débit du disque vers la RAM, ce que je ne sais pas faire...

J

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Wed Feb 13, 2013 2:49 pm

Tu peux tenter de faire un montage de /dev/shm sur /mnt par exemple, car le shm est un montage en ram.

Ensuite, tu fais une copie de ton disque externe vers /mnt et tu vois le temps que ça prend.

Pour ma part, j'avais la même chose que vous jusqu'à ce que je modifie le noatime.

Zoolander06
Posts: 203
Joined: Fri Oct 26, 2012 3:25 pm

Re: Débit catastrophique

Wed Feb 13, 2013 2:54 pm

Comment faire pour modifier le noatime ?

Pour ma part, je n'ai fait que connecter mon disque dur, le montage s'est fait tout seul, je ne sais pas si j'ai une ligne dans le fstab du coup...

User avatar
ouafnico
Posts: 67
Joined: Wed Jan 23, 2013 7:35 am

Re: Débit catastrophique

Wed Feb 13, 2013 3:11 pm

Si ça s'est fait tout seul c'est que c'est l'automonteur qui l'a fait donc ça n'est pas dans le fstab.
Regarde avec la commande mount les options qui ont été données.
Le mieux sera de le demonter en commande et de le remonter manuellement pour tester des options

Return to “Français”