bob-leponge
Posts: 4
Joined: Thu Dec 27, 2012 10:41 am

Xbmc - image au ralenti, son ok

Thu Dec 27, 2012 10:51 am

Bonjour à tous,

Nouveau possesseur d'un raspberry pi, je encontre un soucis avec XBMC.

Lors de la lecteur de certaines vidéo, le son est diffusé parfaitement, mais l'image elle est au ralenti ( ou se fige).
J'ai testé Raspbmc et OpenElec, le problème est identique.

Quelqu'un à t-il une idée ou une solution pour résoudre ce problème ?

Merci d'avance ;-)

trouch
Posts: 310
Joined: Fri Aug 03, 2012 7:24 pm
Location: France
Contact: Website

Re: Xbmc - image au ralenti, son ok

Thu Dec 27, 2012 12:25 pm

bob-leponge wrote:Lors de la lecteur de certaines vidéo, le son est diffusé parfaitement, mais l'image elle est au ralenti ( ou se fige).
Tu peux préciser quelles vidéos ?
codec ? (divx, xvid, mpeg, vc-1, h.264...)
conteneur ? (extension de fichier)
source ? (internet, nas, usb...)
bitrate/résolution ?

WebIOPi - Raspberry Pi REST Framework to control your Pi from the web
http://store.raspberrypi.com/projects/webiopi
http://code.google.com/p/webiopi/
http://trouch.com

bob-leponge
Posts: 4
Joined: Thu Dec 27, 2012 10:41 am

Re: Xbmc - image au ralenti, son ok

Thu Dec 27, 2012 9:35 pm

Merci pour l'intéret porté,

Voici les informations concernant la vidéo :

Format : AVI
Format/Info : Audio Video Interleave
FileSize/String : 699 MiB
Duration/String : 1h 17mn
OverallBitRate/String : 1 256 Kbps

Video
ID/String : 0
Format : MPEG-4 Visual
Format_Profile : Advanced Simple@L5
Format_Settings_BVOP/String : 1
Format_Settings_QPel/String : No
Format_Settings_GMC/String : No warppoints
Format_Settings_Matrix/String : Default (MPEG)
MuxingMode : Packed bitstream
CodecID : XVID
CodecID/Hint : XviD
Duration/String : 1h 17mn
BitRate/String : 1 118 Kbps
Width/String : 656 pixels
Height/String : 368 pixels
DisplayAspectRatio/String : 16:9
FrameRate/String : 25.000 fps
ColorSpace : YUV
ChromaSubsampling : 4:2:0
BitDepth/String : 8 bits
ScanType/String : Progressive
Compression_Mode/String : Lossy
Bits-(Pixel*Frame) : 0.185
StreamSize/String : 622 MiB (89%)
Encoded_Library/String : XviD 1.2.0.dev47 (UTC 2006-11-01)

Audio
ID/String : 1
Format : MPEG Audio
Format_Version : Version 1
Format_Profile : Layer 3
Format_Settings_Mode : Joint stereo
Format_Settings_ModeExtension : MS Stereo
CodecID : 55
CodecID/Hint : MP3
Duration/String : 1h 17mn
BitRate_Mode/String : Constant
BitRate/String : 128 Kbps
Channel(s)/String : 2 channels
SamplingRate/String : 48.0 KHz
Compression_Mode/String : Lossy
StreamSize/String : 71.2 MiB (10%)
Alignment/String : Aligned on interleaves
Interleave_Duration/String : 40 ms (1.00 video frame)
Interleave_Preload/String : 504 ms
Encoded_Library/String : LAME3.97
Encoded_Library_Settings : -m j -V 4 -q 2 -lowpass 17 -b 128

pseudomystere
Posts: 9
Joined: Mon Dec 17, 2012 10:00 pm

Re: Xbmc - image au ralenti, son ok

Thu Dec 27, 2012 10:47 pm

EXACTEMENT le même problème! j'attends les reponses avec impatience :)

trouch
Posts: 310
Joined: Fri Aug 03, 2012 7:24 pm
Location: France
Contact: Website

Re: Xbmc - image au ralenti, son ok

Thu Dec 27, 2012 10:54 pm

Le problème doit venir du codec XVID utilisé qui demande un décodage logiciel...
Tu peux essayer en augmentant la fréquence du CPU
ou alors il faut ré-encoder ces vidéos en H.264 pour avoir le décodage matériel via le GPU.

WebIOPi - Raspberry Pi REST Framework to control your Pi from the web
http://store.raspberrypi.com/projects/webiopi
http://code.google.com/p/webiopi/
http://trouch.com

bob-leponge
Posts: 4
Joined: Thu Dec 27, 2012 10:41 am

Re: Xbmc - image au ralenti, son ok

Wed Jan 09, 2013 9:32 am

Désolé pour la réponse plus que tardive,

J'ai essayé d'augmenter la fréquence comme conseillé, mais toujours le même soucis.
Si tu as des réglages à me conseiller je suis preneur.

Merci pour les réponses.

patdelapampa
Posts: 1
Joined: Wed Jan 09, 2013 10:40 am

Re: Xbmc - image au ralenti, son ok

Wed Jan 09, 2013 10:46 am

Bonjour,
J'ai eu exactement le même problème avec raspbmc.
Je suis passé sous Xbian qui semble ne pas avoir le soucis.

bob-leponge
Posts: 4
Joined: Thu Dec 27, 2012 10:41 am

Re: Xbmc - image au ralenti, son ok

Thu Jan 17, 2013 9:15 am

patdelapampa wrote:Bonjour,
J'ai eu exactement le même problème avec raspbmc.
Je suis passé sous Xbian qui semble ne pas avoir le soucis.
Merci à toi pour ce conseil.
Effectivement, je n'ai pas ce soucis avec xbian !
(Bon j'ai quand même 1 ou 2 films qui ne passent pas, mais rien de bien méchant)

Merci à tous pour votre aide ;-)

pseudomystere
Posts: 9
Joined: Mon Dec 17, 2012 10:00 pm

Re: Xbmc - image au ralenti, son ok

Thu Jan 17, 2013 8:22 pm

patdelapampa wrote:Bonjour,
J'ai eu exactement le même problème avec raspbmc.
Je suis passé sous Xbian qui semble ne pas avoir le soucis.
Je suis aussi sous xbian et le problème est quand même là pour plusieurs fichiers... Je pense que je vais devoir réencoder ma mediatheque

Return to “Français”