christo45
Posts: 7
Joined: Sun Nov 17, 2019 4:51 pm

Pas de conexion WifI sous Buster

Fri Nov 22, 2019 10:51 pm

Bonjour,

J'ai installé la dernière distrib BUSTER Lite sur un Raspberry 3 B+.
Impossible de se connecter au wifi.

La configuration du réseau semble avoir été modifiée depuis la version Stretch.

Je n'ai plus rien dans le fichier /etc/network/interfaces !

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
Si je le rempli avec ma configuration réseau, j'ai une erreur du service dhcpcd qui me plante le réseau !
failed to start on all interfaces

Code: Select all

auto lo

iface wlan0 inet static
  address 192.168.1.104
  netmask 255.255.255.0

allow hotplug wlan0
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
Ma configuration wifi, /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FR

network={
ssid="mySSID"
password="myPassword"
key_mgmt=WPA-PSK
}
Quelqu'un pourrait m'expliquer les relations qu'il y a entre wpa_supplicant, dhcpcd, le fichier 'interfaces' ?

J'ai essayé de branché une clé wifi, je scan bien le réseau mais je n'arrive pas à m'y connecter.

Code: Select all

 wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext,r8712u
 Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ip a

Code: Select all

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enxb827eb581c68: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:58:1c:68 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.40/24 brd 192.168.1.255 scope global dynamic noprefixroute enxb827eb581c68
       valid_lft 85540sec preferred_lft 74740sec
    inet6 fe80::b05a:a137:cda2:30d0/64 scope link 
       valid_lft forever preferred_lft forever
3: wlx0014d1abfe3b: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:14:d1:ab:fe:3b brd ff:ff:ff:ff:ff:ff
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:0d:49:3d brd ff:ff:ff:ff:ff:ff

epoch1970
Posts: 3867
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Pas de conexion WifI sous Buster

Sat Nov 23, 2019 11:35 am

Tout est conforme.

Code: Select all

# Please note that this file is written to be used with dhcpcd
Autrement dit, ce fichier est vide et il doit le rester pour que dhcpcd fonctionne.

La documentation officielle décrit comment connecter un Pi au wifi.

En l'état :
- Le fichier wpa_supplicant.conf à l'air correct
- Virer tout ce qui a été ajouté au fichier interfaces
- Redémarrer.

Par défaut dhcpcd verra une interface wifi non configurée et essaiera de lancer wpa_supplicant et d'obtenir une addresse IP via DHCP.
Aucune configuration n'est nécessaire à part le fichier wpa_supplicant.conf

Si ça ne marche pas, direction "sudo raspi-config" pour déclarer le pays dans lequel la machine opère et ainsi désactiver rfkill. Raspbian est bon élève, pas de wifi par défaut et pas de wifi si le pays n'est pas renseigné.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

christo45
Posts: 7
Joined: Sun Nov 17, 2019 4:51 pm

Re: Pas de conexion WifI sous Buster

Sat Nov 23, 2019 2:14 pm

Merci pour vos explications.

Je n'ai pas trouvé ou désactiver 'rfkill' dans raspi-config !
Dans le fichier wpa_supplicant, le pays est bien configuré country=FR
Si ça ne marche pas, direction "sudo raspi-config" pour déclarer le pays dans lequel la machine opère et ainsi désactiver rfkill. Raspbian est bon élève, pas de wifi par défaut et pas de wifi si le pays n'est pas renseigné.
Je n'ai donc plus rien dans le fichier /etc/network/interfaces

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
Je laisse ma configuration dans wpa_supplicat.conf qui n'a pas changée

wpa_supplicant est bien lancé :
ps aux | grep wpa

Code: Select all

root       329  0.0  0.4  10708  4028 ?        Ss   14:49   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
root       388  0.0  0.2  10972  1908 ?        Ss   14:49   0:00 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
systemctl status dhcpcd

Code: Select all

* dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dhcpcd.service.d
           `-wait.conf
   Active: active (running) since Sat 2019-11-23 14:48:59 CET; 2min 30s ago
 Main PID: 467 (dhcpcd)
    Tasks: 2 (limit: 2200)
   Memory: 5.0M
   CGroup: /system.slice/dhcpcd.service
           |-388 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
           `-467 /sbin/dhcpcd -q -w

nov. 23 14:48:52 raspberrypi dhcpcd[298]: eth0: adding address fe80::6d3:171c:5dac:c9f1
nov. 23 14:48:53 raspberrypi dhcpcd[298]: eth0: soliciting an IPv6 router
nov. 23 14:48:53 raspberrypi dhcpcd[298]: eth0: rebinding lease of 192.168.1.40
nov. 23 14:48:53 raspberrypi dhcpcd[298]: eth0: probing address 192.168.1.40/24
nov. 23 14:48:58 raspberrypi dhcpcd[298]: eth0: leased 192.168.1.40 for 86400 seconds
nov. 23 14:48:58 raspberrypi dhcpcd[298]: eth0: adding route to 192.168.1.0/24
nov. 23 14:48:58 raspberrypi dhcpcd[298]: eth0: adding default route via 192.168.1.1
nov. 23 14:48:59 raspberrypi dhcpcd[298]: forked to background, child pid 467
nov. 23 14:48:59 raspberrypi systemd[1]: Started dhcpcd on all interfaces.
nov. 23 14:49:05 raspberrypi dhcpcd[467]: eth0: no IPv6 Routers available
mais lorsque je veux scanner le réseau :
iwlist wlan0 scan

Code: Select all

wlan0     Interface doesn't support scanning : Device or resource busy
Du coup, j'ai branché une clef wifi
dmesg | grep usb

Code: Select all

[    2.941774] usb 1-1.1.1: new high-speed USB device number 6 using dwc_otg
[    3.072551] usb 1-1.1.1: New USB device found, idVendor=0424, idProduct=7800, bcdDevice= 3.00
[    3.080200] usb 1-1.1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    4.320139] usb 1-1.2: r8712u: USB_SPEED_HIGH with 4 endpoints
[    4.320871] usb 1-1.2: r8712u: Boot from EFUSE: Autoload OK
[    4.884120] usb 1-1.2: r8712u: CustomerID = 0x0000
[    4.889957] usb 1-1.2: r8712u: MAC Address from efuse = 00:14:d1:ab:fe:3b
[    4.895749] usb 1-1.2: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[    4.902660] usbcore: registered new interface driver r8712u
[    7.160888] usbcore: registered new interface driver brcmfmac
j'ai chargé le module r8712u

Code: Select all

modprobe r8712u
et je l'ai rajouté au fichier /etc/modules

ip a

Code: Select all

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:58:1c:68 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.40/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 86114sec preferred_lft 75314sec
    inet6 fe80::6d3:171c:5dac:c9f1/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:14:d1:ab:fe:3b brd ff:ff:ff:ff:ff:ff
4: wlan1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:0d:49:3d brd ff:ff:ff:ff:ff:ff
le scan fonctionne avec l'interface wlan0 de ma clef (wlan1 toujours HS pour le wifi du raspberry):
iwlist wlan0 scan

Code: Select all

wlan0     Scan completed :
          Cell 01 - Address: 78:81:02:31:60:DC
                    ESSID:"monSSID"
                    Protocol:IEEE 802.11bgn
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:rsn_ie=30140100000fac040100000fac040100000fac020c00
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: F4C69766094C697665626F782034100800020006103C0001011049000600372A000120....
                    Signal level=58/100  
iwlist wlan1 scan

Code: Select all

wlan1     No scan results
au boot, j'ai wpa qui lance l'interface wlan1 au lieu de wlan0 de ma clef, comment le changer ?
ps aux | grep wpa

Code: Select all

root       323  0.0  0.4  10708  3972 ?        Ss   14:55   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
root       401  0.0  0.2  10972  2044 ?        Ss   14:55   0:00 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan1 -Dnl80211,wext
si je le fait manuellement
wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dwext

Code: Select all

Successfully initialized wpa_supplicant
rfkill: Cannot get wiphy information

Je tourne en rond !!!
Comment je peux m'en sortir avec ou sans clef wifi ?

epoch1970
Posts: 3867
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Pas de conexion WifI sous Buster

Sat Nov 23, 2019 3:49 pm

Reprenons.
  • Raspbian Buster tout neuf.
  • Configurer comme ceci le wifi de la carte intégrée.
  • Redémarrer sans ethernet connecté et Internet doit marcher via l'interface Wifi intégrée si la config a été correcte.
Ensuite,
  • Pour désactiver la carte wifi intégrée d'un Pi et utiliser une autre à la place, editer config.txt sur la 1ère partition de la SD (accessible sous /boot/config.txt lorsque le système est lancé) et rajouter

    Code: Select all

    dtoverlay=pi3-disable-wifi
    "wlan0" disparaitra du système après redémarrage, et un adaptateur USB deviendrait "wlan0".
  • Pour utiliser 2 cartes wifi en même temps:
    • Si les 2 doivent se connecter au même point d'accès, rien à faire de spécial (*).
    • Si les 2 doivent chacune se connecter à un point d'accès différent:
      1. Dupliquer le fichier de config en précisant le nom de l'interface dans le nom du fichier:

        Code: Select all

        cd /etc/wpa_supplicant.conf
        cp wpa_supplicant.conf wpa_supplicant-wlan0.conf
        cp wpa_supplicant.conf wpa_supplicant-wlan1.conf
      2. Editer les 2 fichiers wpa_supplicant-wlan0.conf, wpa_supplicant-wlan1.conf et spécialiser les paramètres comme de besoin
      3. Redémarrer
    • Si l'une des 2 doit servir de point d'accès, et non de client. Disons que wlan1 doit servir d'AP, alors éditer /etc/dhcpcd.conf et rajouter en fin de fichier

      Code: Select all

      interface wlan1
      nohook wpa_supplicant
      
      Ensuite, redémarrer. Dhcpcd n'essaiera pas de lancer wpa_supplicant sur cette interface, la laissant libre pour l'utilisation en point d'accès. Doc pour le point d'accès ici.
(*) A priori avec Raspbian il est rare d'avoir à recourir à modprobe. Wpa_supplicant utilise depuis longtemps le driver nl80211 par défaut pour le wifi. Tous les drivers wifi du système devraient être conçus pour fonctionner via nl80211 qui sert de couche d'abstraction.
Pas besoin de modprobe, ni de -Dwext,ceci,cela.
Si l'un ou l'autre paraissent nécessaires, vérifier la compatibilité du matériel avec linux 4.x
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

christo45
Posts: 7
Joined: Sun Nov 17, 2019 4:51 pm

Re: Pas de conexion WifI sous Buster

Sat Nov 23, 2019 7:36 pm

Voilà qui est clair !
=> je pars bien d'une Raspbian Buster Lite fraichement installée
=> j'ai bien lancé raspi-config pour configurer le wifi
=> après reboot, toujours rien !

J'ai des erreurs dans les logs sur le module brcmfmac :
dmesg -l err

[ 6.932069] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 7.187835] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 7.204383] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04



Quant à la clef wifi, une TrendNet TEW-649UB, je pense qu'elle n'est pas compatible.
En désactivant le wifi de la carte (via config.txt), il me reste bien une seule interface mais qui ne veut pas se connecter

systemctl status wpa_supplicant

Code: Select all

● wpa_supplicant.service - WPA supplicant
   Loaded: loaded (/lib/systemd/system/wpa_supplicant.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-11-18 18:31:53 CET; 5 days ago
 Main PID: 333 (wpa_supplicant)
    Tasks: 1 (limit: 2305)
   Memory: 4.0M
   CGroup: /system.slice/wpa_supplicant.service
           └─333 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant

nov. 18 18:31:51 raspberrypi systemd[1]: Starting WPA supplicant...
nov. 18 18:31:53 raspberrypi wpa_supplicant[333]: Successfully initialized wpa_supplicant
nov. 18 18:31:53 raspberrypi systemd[1]: Started WPA supplicant.
nov. 18 18:31:59 raspberrypi wpa_supplicant[333]: nl80211: Driver does not support authentication/association or connect commands
nov. 18 18:31:59 raspberrypi wpa_supplicant[333]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
nov. 18 18:31:59 raspberrypi wpa_supplicant[333]: rfkill: Cannot get wiphy information
Je pense qu'il faut régler l'erreur brcmfmac. Je continu à chercher ...
Merci pour tous vos conseils qui sont les bienvenus !

totoharibo
Posts: 4246
Joined: Thu Jan 24, 2013 8:43 am

Re: Pas de conexion WifI sous Buster

Sun Nov 24, 2019 9:45 am

ça se passe dans /etc.dhcpdc.conf (à la fin)
SSID <ssid>
inform <pi>
static router <ton routeur (box)>
static domain_name_serveur <ip du DNS>

/etc/interface n'est plus utilisé depuis belle burette.
j'utilise raspi-config (celui en console marche mieux) pour choisir le Wifi et l''IP du RPi)
Aucun problème.

pour ton BCM4345 :
apt-cache search bcm4345
-> firmware-brcm80211
plein de trucs dessus (voir par apt-cache show)

pas essayé (pas de clé bien sur)

pour info :
J'utilise d'office buster "normal". On ne trouve plus de cartes de moins de 8G donc je ne vois pas l'utilité de lite.
Je configure tout en graphique (dont le WIFI) et ensuite quand tout est bon je passe en "console auto-login" par raspi-config. Je suis en "presque lite", éventuellement j'enlève des packages qui ne me servent pas.

epoch1970
Posts: 3867
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Pas de conexion WifI sous Buster

Sun Nov 24, 2019 1:08 pm

christo45 wrote:
Sat Nov 23, 2019 7:36 pm
J'ai des erreurs dans les logs sur le module brcmfmac :
dmesg -l err

[ 6.932069] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 7.187835] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 7.204383] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
Pas de 3B+ ni même de Raspbian sous la main mais a priori ces messages ne sont pas des erreurs. Ils sont loggués au niveau erreur mais c'est de l'info en réalité.

Un point de référence simple : si le Pi n'est pas cassé, que l'alimentation électrique est officielle et pas cassée non plus, l'OS Raspbian buster fraîchement téléchargé et installé sur une SD pas cassée, alors le wifi intégré fonctionne.
S'il ne marche pas, l'install sur la SD est foireuse, ou le fichier wpa_supplicant.conf est foireux ou le point d'accès est trop loin, ou bloque la connexion, ou peut-être utilise des réglages exotiques.

Une fois que le wifi intégré fonctionne, viendra éventuellement le temps de se pencher sur l'adaptateur wifi externe.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

christo45
Posts: 7
Joined: Sun Nov 17, 2019 4:51 pm

Re: Pas de conexion WifI sous Buster

Sun Nov 24, 2019 2:01 pm

La clef wifi, c'était uniquement pour tester. je ne souhait pas créer un AP, juste accéder à internet via le Wi-Fi.
Si l'erreur brcm n'en est pas une, je dois effectivement avoir un truc foireux !

J'ai essayé avec plusieurs SD, toujours même erreur. Je tenterai la semaine prochaine sur un autre Raspberry...

epoch1970
Posts: 3867
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Pas de conexion WifI sous Buster

Sun Nov 24, 2019 4:22 pm

Je reformule : ca n'est pas une erreur. C'est un message d'information.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

christo45
Posts: 7
Joined: Sun Nov 17, 2019 4:51 pm

Re: Pas de conexion WifI sous Buster

Sun Nov 24, 2019 9:01 pm

J'ai bien relu tes remarques 'epoch1970' :
S'il ne marche pas, l'install sur la SD est foireuse, ou le fichier wpa_supplicant.conf est foireux ou le point d'accès est trop loin, ou bloque la connexion, ou peut-être utilise des réglages exotiques.

J'ai branché un 'Wifi Extendeur CPL orange" à coté du Raspi, et là, je scan bien le réseau et je peux m'y connecter.

Le problème viendrait donc de la Livebox que je n'arrive pas à scanner ! même en mettant le raspi à coté.
Du coup, je crois que je vais utiliser l'Extender ...
mais j'aimerai bien comprendre pourquoi je ne vois pas le wifi de la box, avec le téléphone, je scanne correctement.

Encore merci 'epoch1970' pour ton aide.

epoch1970
Posts: 3867
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Pas de conexion WifI sous Buster

Sun Nov 24, 2019 9:19 pm

Bon on peut pas dire que ça s'éclaircit, mais voilà un progrès !

Le wifi, trop près c'est pas bon, et trop loin non plus...
Mais à 1 m. ça ne doit pas rater... Il y a peut être une option dans la LB qui fait que le Pi3B est rejeté.

Sur le forum LB, peut être ? Ou bien ici: quel modèle de LB, exactement ?
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

christo45
Posts: 7
Joined: Sun Nov 17, 2019 4:51 pm

Re: Pas de conexion WifI sous Buster

Mon Nov 25, 2019 7:45 am

C'est la Livebox4.

J'ai revérifié tous les paramètres, aucunes restrictions.
Le wifi est visible sur les téléphones, PC ... mais pas depuis le raspi ! Incroyable !

Je pense que çà va se finir en CPL tout çà !

iznobe
Posts: 287
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Pas de conexion WifI sous Buster

Wed Nov 27, 2019 4:42 pm

Salut ,

Quel est ton type de raspberry pi et le modele ?

je serais toi , je telechargerai la version de raspbian buster avec environnement graphique , mais sans les logiciels recommandés .
ensuite , comme dab , grave sur la carte activé le ssh , entré dans raspiconfig , commencer par etendre a toute la carte la partition ext4 , puis redemarrer .

renseigner toutes les infos de localisation et ne pas oublier la wifi country .

re-redemarrer , faire les MAJ .

verifier que tout est ok .

ensuite avec une souris et un clavier temporaire , renseignez la clé wifi et tout le touintouin a propos du wifi , la commande

Code: Select all

 iwconfig 
peut donner quelques renseignement de base sur le hardware wifi et son etat .


@+

Return to “Français”