Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

[RESOLU] Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 12:57 pm

Bonjour à tous,

Mon problème n'est pas un problème de démarrage de ma Pi4 mais un problème de redémarrage. Ma Pi4 est montée avec OS Raspbian et up to date. Sur la Pi les 2 ports USB2 sont utilisés (Clavier et souris). Un kit de refroidissement passif est installé sur le CPU, la ram et la carte graphique. La température du CPU (au moment ou le phénomène se présente) est au alentour de 71°C.

Le problème de Pi4 qui redémarre est pendant une navigation (1 seul onglet ouvert) sous Chromium :(

Si vous avez des idées ou piste de recherches...

Merci par avance
Last edited by Pascal74 on Wed Nov 27, 2019 1:25 pm, edited 1 time in total.
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

epoch1970
Posts: 3867
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 1:36 pm

Des pistes concernant la cause:
- Ca n'est PAS la temperature
- C'est probablement l'alimentation qui ne tient pas le coup
- Ca pourrait être un court-circuit causé par les radiateurs
- Ca pourrait ressembler à un manque de mémoire mais le symptôme serait plutôt dans ce cas que le navigateur disparait (est tué par le système), pas que la machine redémarre en totalité. Dans "dmesg", dans les logs, sur la console, on peut voir un message de "OOM reaper" (OOM=Out-Of-Memory) lorsque le système tue un process pour préserver la machine.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 1:44 pm

Merci pour cette réponse rapide epoch1970.
Dans "dmesg", dans les logs, sur la console, on peut voir un message de "OOM reaper" (OOM=Out-Of-Memory)
Je débute un peu avec Raspberry sur une distrib Raspbian dans quel répertoire sont stockés les log ? Là ya qd mm 4Go de RAM sur cette pi.

J'ai peine à croire que cela provienne d'un court circuit causé par les radiateurs : Ce ne sont que des 'blocs' d'alu ajourés fixés avec une pâte thermo.

Cdlmt
Pascal74
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

iznobe
Posts: 287
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 2:37 pm

Salut ,

et l ' alimentation ? quelle puissance , modele ?


sinon dans le terminal juste mettre

Code: Select all

dmesg | tail -50
et mettre les lignes entre balise code svp.

EDIT : je viens de voir dans votre signature , 3 A .
cela parait etonnant , car ca ressemble fortement a un probleme d' alimentation faiblarde , tester avec une autre plus puissante si vous pouvez .

votre module d ' abaissement de tension pourrait aussi jouer un role la dedans , si vous avez moyen de tester sans aussi , en ne laissant que le strict minimum .
en gros le pi , une alim differente un ecran et une souris .

Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 3:04 pm

Le Pi est alimenté par ce boitier Image

La sortie est définie sur 5,1V et pour l'ampérage le pi ne prend jamais plus de 2A, même lorsqu'il redémarre

Le descriptif du module indique ceci:
plage de tension d'entrée DC 5V-36V; tension de sortie DC 1.25V-32V réglable en continu; courant de sortie maximal 5A, utilisation recommandée inférieure à 4,5 A; puissance maximale 75W, utilisation recommandée dans les 50W.

Ca me semble largement être dans la plage d'utilisation du Pi4
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

iznobe
Posts: 287
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 4:03 pm

je suis d' accord , mais il pourrait avoir un defaut de fabrication . certains chargeur telephone ont une sortie de 2 A , ca ne coute rien de faire un test si vous en avez un sous la main .

au niveau de dmesg , rien ?
Last edited by iznobe on Mon Nov 18, 2019 4:06 pm, edited 2 times in total.

Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 4:05 pm

Je vais tester dès ce soir avec un multimètre.

Pour les logs dans dmesg . Quel est le répertoire de localisation sous OS Raspbian ?
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

iznobe
Posts: 287
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 4:08 pm

les fichiers journaux sont situés dans /var/log

faites un :

Code: Select all

 cd /var/log && ls
pour avoir la liste complete des fichiers presents .
puis un

Code: Select all

cat nom_du_fichier 
pour voir ce qu ' il contient .

le symptome est problematique a chaque fois que vous ouvrez votre navigateur ? sur quelle page ?

pour dmesg il s' agit juste d' une commande a passer dans le terminal :

Code: Select all

dmesg | tail -50
permet d' afficher les 50 dernieres ligne du fichier journal.

les commandes ( et leur resultats ) se mettent entre balise code , comme je viens de le faire , pour une meilleure lisibilité ;)
Last edited by iznobe on Wed Nov 27, 2019 12:57 pm, edited 1 time in total.

Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 4:11 pm

Merci pour votre aide (très rapide). Je regarde ça ce soir dès que je rentre du boulot. Je ferais un retour d'info à la suite de ce post.

Encore merci
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 9:02 pm

Après avoir démarré la Pi j'ai plugué une clé USB3. J'ai fait une copie de fichier de USB3 vers la Pi: pas de problème rencontré. J'ai ensuite lancé Chromium pour venir sur le forum et après un scroll souris : redémarrage de la Pi.
Juste après le redémarrage, je viens de passer la commande dmesg et voilà ce qu'elle contient

Code: Select all

~ $ dmesg | tail -50
[    4.761149] bcm2835-codec bcm2835-codec: Device registered as /dev/video12
[    4.761190] bcm2835-codec bcm2835-codec: Loaded V4L2 isp
[    4.777812] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    4.872440] vc4-drm soc:gpu: bound fe600000.firmwarekms (ops vc4_fkms_ops [vc4])
[    4.872459] checking generic (3e7fe000 3fc000) vs hw (0 ffffffffffffffff)
[    4.872469] fb: switching to vc4drmfb from simple
[    4.872705] Console: switching to colour dummy device 80x30
[    4.885625] [drm] Initialized vc4 0.0.0 20140616 for soc:gpu on minor 1
[    4.885640] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    4.885649] [drm] No driver support for vblank timestamp query.
[    4.885659] [drm] Setting vblank_disable_immediate to false because get_vblank_timestamp == NULL
[    4.894088] [drm] Initialized v3d 1.0.0 20180419 for fec00000.v3d on minor 0
[    4.921506] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    5.001976] brcmfmac: F1 signature read @0x18000000=0x15264345
[    5.017545] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    5.018171] usbcore: registered new interface driver brcmfmac
[    5.104490] Console: switching to colour frame buffer device 240x67
[    5.109409] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    5.157170] vc4-drm soc:gpu: fb0: DRM emulated frame buffer device
[    5.273192] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    5.294797] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
[    7.514877] uart-pl011 fe201000.serial: no DMA platform data
[    7.760647] random: crng init done
[    7.760666] random: 7 urandom warning(s) missed due to ratelimiting
[    7.791744] 8021q: 802.1Q VLAN Support v1.8
[    7.877999] Adding 102396k swap on /var/swap.  Priority:-2 extents:1 across:102396k SSFS
[    8.246767] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    8.246800] brcmfmac: power management disabled
[    8.643861] bcmgenet: Skipping UMAC reset
[    8.649514] bcmgenet fd580000.genet: configuring instance for external RGMII (no delay)
[    8.650241] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   12.650318] fuse init (API version 7.27)
[   13.780882] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   14.190961] Bluetooth: Core ver 2.22
[   14.191008] NET: Registered protocol family 31
[   14.191012] Bluetooth: HCI device and connection manager initialized
[   14.191023] Bluetooth: HCI socket layer initialized
[   14.191030] Bluetooth: L2CAP socket layer initialized
[   14.191051] Bluetooth: SCO socket layer initialized
[   14.203784] Bluetooth: HCI UART driver ver 2.3
[   14.203795] Bluetooth: HCI UART protocol H4 registered
[   14.203868] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   14.204003] Bluetooth: HCI UART protocol Broadcom registered
[   14.470948] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.470954] Bluetooth: BNEP filters: protocol multicast
[   14.470965] Bluetooth: BNEP socket layer initialized
[   14.531799] Bluetooth: RFCOMM TTY layer initialized
[   14.531815] Bluetooth: RFCOMM socket layer initialized
[   14.531831] Bluetooth: RFCOMM ver 1.11
[   18.702209] usb 2-2: USB disconnect, device number 2
J'ai enlevé ma clé USB3 redémarré et pour le moment pas de redémarrage. J'ai toutefois constaté la puissance monter à 5.45 Il n'est donc pas impossible que le module step down dc/dc soit en cause. Je vais en commander un plus basic (sans écran et réglage potentiomètre d'ajustement) en DC/DC 12/24V > 5V 10A utilisé en automobile. Et je verrais bien à ce moment là.
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

iznobe
Posts: 287
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Raspberry Pi4 problème de redémarrage

Mon Nov 18, 2019 9:38 pm

Bonsoir ,

a priori rien de tres alarmant , mais je ne suis pas un expert.

Cependant , je nee vois pas vraiment le rapport avec chromium .
ca arrive toujours sur la meme page ou n ' importe laquelle ?
le symptome est toujours present avec un autre navigateur , par exemple firefox ?

Code: Select all

sudo apt install firefox
pour installer puis faites un essai .

vous avez des trucs en USB branché dessus votre pi ?
que donne

Code: Select all

lsusb -v
?

quel ecran avez vous ? l ' ecran est connecté en HDMI?

Pascal74
Posts: 7
Joined: Mon Nov 18, 2019 12:31 pm

Re: Raspberry Pi4 problème de redémarrage

Tue Nov 26, 2019 1:44 pm

Re bonjour.

Me revoilà pour faire un point de situation. Après avoir remplacer le module DC/DC step down qui permet de réguler la sortie en 5V le problème n'est plus rencontré. Il semblerait que ce dernier était défectueux. La société à été contactée et en renvoi un autre.

Concernant Chromium, il est constaté (également lu sur d'autres forum) que celui ci est assez gourmand et génère parfois quelques instabilités. Peut etre un problème de jeunesse liée à la version Buster :?:

En tout cas merci pour l'aide apportée ;)

(ps comment passer ce poste à [reglé] ou [résolu], je ne vois rien pour le faire :? )
(Raspberry Pi4 4Go ram + Kit refroidissement passif), OS Raspbian, Alim 5,1V et 3A modul step down DC/DC 12V > 5,1V (avec afficheur pour contrôler)

iznobe
Posts: 287
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Raspberry Pi4 problème de redémarrage

Wed Nov 27, 2019 1:00 pm

Salut , il suffit d' editer votre premier message et d ' ajouter devant le titre [ RESOLU ] .

content que le probleme soit reglé ;)

de mon coté , j ' ai aussi constaté la gourmandise de cromium lorsque je naviguais avec sur mon pi3 , il n ' y a pas enormement d' alternative .

@ + .

Return to “Français”