bakala
Posts: 6
Joined: Sat Jun 08, 2019 12:12 pm

problème boot SSD

Sat Jun 08, 2019 3:01 pm

Bonjour à tous,

Tout d'abord, je précise que je suis novice dans le domaine. Je me lance pour domotiser ma maison avec Jeedom. J'y vais donc par étape.
Première étape installer Rasbian.
J'ai suivi les différentes étapes (Etcher) mais lorsque je connecte mon SSD au Pi et que je le mets sous tension seule la diode rouge s'allume, le boot ne se fait pas.

Pour vérifier j'ai fait la même chose avec une carte SD au lieu d'un SSD, et là ça fonctionne le Pi boot bien.

Je précise que j'ai une alimention Raspberry Universal Power 2.5A 5.1V.

Merci d'avance pour vos lumières.

epoch1970
Posts: 2981
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: problème boot SSD

Sat Jun 08, 2019 9:05 pm

Il date de quand ce Pi?
Ceux d'avant 2018 (?) ont besoin d'être programmés pour bouter via USB.
Si c'est un 3B+ la remarque n'est pas applicable, il sait booter par USB d'origine.

S'il n'est pas tout récent, il faut booter une fois avec la SD en ayant rajouté "program_usb_boot_mode=1" rajouté à config.txt. Cela modifie le microprogramme pour que le Pi essaie de booter via USB et le réseau, si la SD n'est pas présente.

Le changement n'est pas réversible. Donc il vaut mieux ensuite remettre en commentaire le "program_usb_boot_mode" pour éviter de reprogrammer (éventuellement) un Pi quelconque qui utiliserait la carte à l'avenir.
La manœuvre documentée ici.

Si le Pi est effectivement programmé pour savoir booter via USB et "vcgencmd otp_dump | grep 17" affiche "0x3020000a", mais qu'il ne boute pas, il y a plusieurs possibilités (causes les plus courantes en premier) :
- disque externe formatté incorrectement
- pas assez de courant/disque externe trop gourmand
- cmdline.txt qui ne correspond pas à la table de formatage du disque externe
- câble USB un peu miteux
- disque externe paresseux qui ne démarre pas assez vite pour le Pi.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

bakala
Posts: 6
Joined: Sat Jun 08, 2019 12:12 pm

Re: problème boot SSD

Sun Jun 09, 2019 7:38 am

Merci pour ta réponse epoch1970

Je viens de l'acheter le Pi; il s'agit d'un Pi3 Model B+. L'alimentation est une alimentation officielle Raspberry.

Le SSD vient également d'être acheté c'est un Kingston. Je ne l'ai pas formaté, j'ai flashé directement Rasbian dessus.
Peut-être devrais-je le formater ? Comment dois-je procéder ?

D'avance merci si vous avez des solutions.
Bon dimanche.

bakala
Posts: 6
Joined: Sat Jun 08, 2019 12:12 pm

Re: problème boot SSD

Sun Jun 09, 2019 11:53 am

J'ai trouvé la solution :
Il faut rajouter une ligne dans le fichier config.txt depuis la carte sd sous Windows :
# Enable USB Boot for Jeedom
program_usb_boot_mode=1

puis on démarre avec la carte SD et le SSD.
puis on redémarre avec juste le SSD.

Et ça fonctionne.

Merci à plus.

Return to “Français”