MickB
Posts: 14
Joined: Sat Mar 31, 2018 6:06 am

Autostart OMXplayer

Wed Apr 04, 2018 10:35 am

Bonjour,

Mon but :
Dès l'allume du Raspberry Pi 3, OMXplayer se lance avec un flux RTSP.

Je pense avoir trouvé le 3/4 de la solution à un détail près!

1. chercher le flux RTSP de la caméra souhaitée
2. Ouvrir Terminal
3. Taper commande : nano .bashrc (ligne de commande à effectuer dès ouverture du Terminal)
4. Taper en fin de script : sudo omxplayer rtsp://admin:[email protected]/MediaInput/h264 (rtsp://identifiant:[email protected]_IP/MediaInput/h264 ; l'info MediaInput/h264 varie en fonction de la caméra)
5. CTRL + X
6. Y (yes)
7. Enter
8. Taper commande : /home/pi/.config/lxsession/LXDE/autostart (ligne de commande à effectuer au démarrage du Raspberry)
9. Taper en fin de script : @lxterminal
10. CTRL + X
11. Y (yes)
12. Enter

En faisant ces commandes, j'obtiens le résultat souhaité mais 1x sur 4 j'ai le terminal qui s'enclenche sans l'enclenchement de OMXplayer. Seul l'info, have a nice day ;)

Savez-vous pourquoi??
Merci d'avance!

tvjon
Posts: 618
Joined: Mon Jan 07, 2013 9:11 am

Re: Autostart OMXplayer

Wed Apr 04, 2018 4:02 pm

Bonjour,

Ce qui suit est la procédure que j'utilise pour une caméra IP.

J'espère que ça aide! Bonne chance.

Dans votre fichier de script ip cam, tapez votre commande actuelle, mais sans sudo (sudo est indésirable), comme ceci:

omxplayer rtsp://admin:[email protected]/MediaInput/h264

Rendre l'exécutable ipcam
memory-split.png
memory-split.png (25.9 KiB) Viewed 267 times
file-properties.png
file-properties.png (47.91 KiB) Viewed 267 times
autostart-ipcam.png
autostart-ipcam.png (19.51 KiB) Viewed 267 times

MickB
Posts: 14
Joined: Sat Mar 31, 2018 6:06 am

Re: Autostart OMXplayer

Mon Apr 16, 2018 4:00 pm

Merci pour l'info!
Je vais regarder pour faire le test. ;)

MickB
Posts: 14
Joined: Sat Mar 31, 2018 6:06 am

Re: Autostart OMXplayer

Wed Apr 18, 2018 3:02 pm

Bonjour,

Dans un premier temps, j'ai enlevé le sudo indésirable.
L'enclenchement se fait correctement à plusieurs reprises et certaines fois pas... Comme avant.

Je dirai que ce souci n'est pas dramatique par contre j'en ai un qui est quelque peu dérangeant.
J'ai une latence variant entre 1 à 10 sec avec omxplayer sur mon raspberry.
Quand je suis sur l'adresse IP de la caméra, l'image est simultanée!

Est-ce qu'il y a des régalges à paufiner?


Dans votre post, vous parlez de ipcam. Est-ce le même principe que omxplayer et le flux RTSP?
Merci d'avance!

tvjon
Posts: 618
Joined: Mon Jan 07, 2013 9:11 am

Re: Autostart OMXplayer

Wed Apr 18, 2018 10:09 pm

Bonsoir,

Un autre paramètre important lors du démarrage automatique d'un périphérique en réseau:
attendre.png
attendre.png (42.89 KiB) Viewed 176 times
Pour une de mes caméras IP, la latence en utilisant omxplayer est un gros problème. Tu peux essayer:

omxplayer --avdict rtsp_transport:tcp rtsp://admin:[email protected]/MediaInput/h264

mais vous pouvez trouver la vidéo se brise, bien que la latence devrait être mieux.

Return to “Français”

Who is online

Users browsing this forum: No registered users and 10 guests