User avatar
Heza
Posts: 12
Joined: Mon Oct 15, 2012 12:37 pm

Wifi et OpenVPN

Tue Oct 23, 2012 3:09 pm

Bonjour à tous ,

Après avoir lutté pour installer mon adaptateur wifi sous ma raspbian wheezy, je viens quérir votre aide pour un problème vraiment étrange.
Hier j'ai monté le NAS de ma freebox et c'est à partir de là que tout a commencé.
Premièrement le Pi ne n'éteint plus aussi rapidement qu'avant, de même pour le reboot c'est comme ci il cherchait quelque chose, mais mis à part cela, le partage fonctionne.
Ce qui est plus embêtant c'est que mon dongle wifi se déconnecte dès que la connexion à OpenVPN est effective alors que sans je peux profiter normalement de la connexion.
Avant d'installer le dongle wifi, je passais par un partage de connexion avec mon pc fixe via un cable ethernet mais c'est bête de devoir laisser allumer mon pc qui consomme pour juste 2-3 tâches qui peuvent être exécutées par le Pi.
Serait ce la configuration d'OpenVPN qu'il faut revoir ou celle du dongle ?
Merci d'avance pour votre aide :)

vohu
Posts: 92
Joined: Tue Aug 14, 2012 9:22 am

Re: Wifi et OpenVPN

Tue Oct 23, 2012 3:47 pm

Tu es sur que la connexion wifi est coupée ? que c'est pas un problème de routage plutot ?

User avatar
Heza
Posts: 12
Joined: Mon Oct 15, 2012 12:37 pm

Re: Wifi et OpenVPN

Tue Oct 23, 2012 3:53 pm

Non elle est coupée, la diode du dongle s'éteint et dans le wifi config c'est bien précisé disconnected et de plus je ne peux plus ouvrir de pages internet, mais si c'était un problème de routage ça se manifesterait comme ça.

User avatar
Heza
Posts: 12
Joined: Mon Oct 15, 2012 12:37 pm

Re: Wifi et OpenVPN

Tue Oct 23, 2012 5:06 pm

J'ai oublié de préciser qu'une fois que la connexion VPN est établie l'utilisation CPU passe à 100% alors qu'avant quand je me connectais en ethernet ce n'était pas le cas

vohu
Posts: 92
Joined: Tue Aug 14, 2012 9:22 am

Re: Wifi et OpenVPN

Tue Oct 23, 2012 9:10 pm

Peut ête un problème d'alim alors... J'avais le meme soucis avec xbmc...
Quand je lancais, aucun pb, et d'un coup, quand j'ouvrais un menu ou très vite... plantage, reboot, ou plus de clavier... C'était un pb d'alim

User avatar
Heza
Posts: 12
Joined: Mon Oct 15, 2012 12:37 pm

Re: Wifi et OpenVPN

Tue Oct 23, 2012 9:48 pm

Bon voilà c'est réglé, mea culpa c'était effectivement un problème de routage.
En fait OpenVPN attribuait une passerelle différente de celle de mon réseau et donc je ne pouvais plus accéder à internet via le dongle.
Pour ceux qui rencontrerait le problème , j'ai juste installé network manager, configuré pour qu'il reconnnaisse mon dongle comme connexion principale et régler un paramètre IPv4 dans les options.
Merci pour tes réponses dans tous les cas ;)

mcquiggi
Posts: 4
Joined: Thu Oct 25, 2012 4:42 am

Re: Wifi et OpenVPN

Mon Dec 31, 2012 5:09 pm

My French is weak, but I believe that I am having the same issue with OpenVPN and Wifi. I am running OpenVPN as a client to connect to an existing VPN network. Once I start openvpn on the rPi, I get a disconnect on wlan0. wpa_supplicant complains and my network connection goes down. This does not happen when I connect to my local router via Ethernet cable.

I will poke around, generate some logfile data and follow up to this post.

Kevin

Return to “Français”

Who is online

Users browsing this forum: No registered users and 3 guests