KR_Newbie
Posts: 9
Joined: Mon Sep 25, 2017 9:13 am

RPI Serveur problème perte wifi

Mon Sep 25, 2017 9:39 am

Bonjour à tous,

Je débute sur Raspberry et je récupère un projet d'un serveur client.

Le système est simple, un RPI en tant que Serveur qui peut recevoir n client(s) et qui l'affiche sur une interface graphique,
et n RPI(s) client qui se connecte par la wifi au Serveur pour renvoyer des états.
En somme un système classique.

Côté client pas de soucis mais coté serveur je perds souvent l'émission du WIFI.
Une solution est le redémarrage mais cette action coupe l'interface graphique, prend du temps et fait plus bidouille.
J'ai tenté de faire un :

Code: Select all

sudo ifdown wlan0
sudo ifup --force wlan0
ifconfig wlan
et là j'obtiens les mêmes informations qu'au démarrage excepté que la ligne adr inet6: ****:****:***:***:****/64 Scope:Lien n'est plus là
Et que le UP BROADCAST RUNNING MULTICAST est devenu UP BROADCAST MULTICAST

J'ai cherché à droite à gauche sans trouvé de solution à mon problème, quelqu'un peut-il me diriger vers la solution?

Merci à tous.

totoharibo
Posts: 4178
Joined: Thu Jan 24, 2013 8:43 am

Re: RPI Serveur problème perte wifi

Mon Sep 25, 2017 7:19 pm

le canal utilisé est-il propre ?
(pas utilisé par quelqu'un d'autre)

KR_Newbie
Posts: 9
Joined: Mon Sep 25, 2017 9:13 am

Re: RPI Serveur problème perte wifi

Tue Sep 26, 2017 7:50 am

totoharibo wrote:
Mon Sep 25, 2017 7:19 pm
le canal utilisé est-il propre ?
(pas utilisé par quelqu'un d'autre)
A première vue je dirais non,
J'ai pas encore la connaissance complète du raspberry pour l'affirmer,
y a-t-il un moyen simple de le savoir? une commande ?

totoharibo
Posts: 4178
Joined: Thu Jan 24, 2013 8:43 am

Re: RPI Serveur problème perte wifi

Tue Sep 26, 2017 1:01 pm

sur la freebox fonction radar
pour les autres FAI ?

ernesto
Posts: 128
Joined: Thu Jul 19, 2012 10:09 am

Re: RPI Serveur problème perte wifi

Tue Sep 26, 2017 1:17 pm

Depuis le rpi
iwlist wlan0 scan

Avec un smartphone android
https://play.google.com/store/apps/deta ... yzer&hl=fr

KR_Newbie
Posts: 9
Joined: Mon Sep 25, 2017 9:13 am

Re: RPI Serveur problème perte wifi

Wed Sep 27, 2017 9:21 am

Après vérification le Serveur est le seul a utilisé le canal 6,
ernesto wrote:
Tue Sep 26, 2017 1:17 pm
Depuis le rpi
iwlist wlan0 scan

Avec un smartphone android
https://play.google.com/store/apps/deta ... yzer&hl=fr
Pour le iwlist wlan0 scan, j'obtiens :

Code: Select all

wlan0 No scan results
aussi bien lorsque mon serveur émet et lorsque je l'ai sudo ifup --force wlan0.

Par contre en fouinant un peu hier j'ai réussi à remonter mon adr inet6 en utilisant la commande :

Code: Select all

sudo /etc/init.f/dhcpcd restart
mais toujours pas de retour de l'émission WIFI ni de UP BROADCAST RUNNING MULTICAST

sinon je suis sur un Raspberry 3 model B pour info (Server et Client).

epoch1970
Posts: 3336
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPI Serveur problème perte wifi

Thu Sep 28, 2017 10:57 am

C'est l'interface qui dysfonctionne ou bien le point d'accès ?
L'interface devrait avoir une IP fixe. DHCP voudrait dire que l'interface passe en mode client, et donc pas de point d'accès possible.

Le process du point d'accès s'appelle "hostapd".
Il pourrait y avoir des traces système intéressantes via "tail -f /var/log/syslog" lorsque le truc se met à dysfonctionner.
Il est aussi possible de lancer hostapd en mode debug en tâche de premier plan avec "hostapd -d <chemin_vers_la_config>"

Concernant le "n clients", si l'interface wifi est celle du Pi 3 il y a une limite à la valeur "n". Je n'ai pas de chiffre exact mais je dirais que 10 clients connectés au même moment commence à faire pas mal. Je ne suis pas sûr des conséquences sur le serveur ou sur les clients d'un dépassement de la limite.

Concernant le canal utilisé, un conflit pourrait causer des problèmes de connexion pour les clients, mais ne devrait pas affecter le serveur.
(Et je crois qu'il faut être root "sudo iwlist ..." pour déclancher un scan)
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

KR_Newbie
Posts: 9
Joined: Mon Sep 25, 2017 9:13 am

Re: RPI Serveur problème perte wifi

Fri Sep 29, 2017 9:21 am

epoch1970 wrote: C'est l'interface qui dysfonctionne ou bien le point d'accès ?
L'interface devrait avoir une IP fixe. DHCP voudrait dire que l'interface passe en mode client, et donc pas de point d'accès possible.
C'est le point d'accès qui dysfonctionne lorsque le problème arrive.
epoch1970 wrote: Le process du point d'accès s'appelle "hostapd".
Il pourrait y avoir des traces système intéressantes via "tail -f /var/log/syslog" lorsque le truc se met à dysfonctionner.
Il est aussi possible de lancer hostapd en mode debug en tâche de premier plan avec "hostapd -d <chemin_vers_la_config>"
Je reregarderais syslog au prochain dysfonctionnement,
Pour le moment je suis en teste avec une clé Wifi et ça a l'air de mieux tenir.
Par contre relancer le process marche bien si on remonte par le wlan0
edit 29/09/17 14:28 wrote:

Code: Select all

sudo ifdown wlan0
sudo rm /var/run/hostapd/wlan0
sudo hostapad -B <chemin_vers_la_config>
sudo ifup wlan0
Ceci résout mon problème d'impossibilité de remonter mon point d'accès, merci.
epoch1970 wrote: Concernant le "n clients", si l'interface wifi est celle du Pi 3 il y a une limite à la valeur "n". Je n'ai pas de chiffre exact mais je dirais que 10 clients connectés au même moment commence à faire pas mal. Je ne suis pas sûr des conséquences sur le serveur ou sur les clients d'un dépassement de la limite.
Notre cahier des charges par Serveurs ne permet que 10 connexion max .
epoch1970 wrote: Concernant le canal utilisé, un conflit pourrait causer des problèmes de connexion pour les clients, mais ne devrait pas affecter le serveur.
(Et je crois qu'il faut être root "sudo iwlist ..." pour déclancher un scan)
Effectivement avec un sudo ça marche mieux.


Merci à tous, mon problème de point d'accès qui ne se remonte pas est clos.

Return to “Français”