Salamafet
Posts: 2
Joined: Fri Sep 28, 2012 1:50 pm

Désactivé la veille de l'écran

Fri Sep 28, 2012 1:55 pm

Bonjour,

Comment désactivé la veille de l'écran du Rasperry Pi sous Raspbian “wheezy” ?

Je fais pas mal de test avec des programmes qui tournent pendants plusieurs jours et je suis obligé à chaque fois d'intervenir manuellement sur la machine pour que l'écran ce réactive. D'ailleurs je trouve ca bizarre que l'écran ne passe pas en mode veille au lieu d'afficher du noir.

Merci

Salamafet
Posts: 2
Joined: Fri Sep 28, 2012 1:50 pm

Re: Désactivé la veille de l'écran

Sat Sep 29, 2012 8:09 am

J'ai trouvé la solution à mon problème.

Éditez /etc/kbd/config

Changer les lignes suivante

Code: Select all

# screen blanking timeout. monitor remains on, but the screen is cleared to
# range: 0-60 min (0==never) kernels I've looked at default to 10 minutes.
# (see linux/drivers/char/console.c)
BLANK_TIME=0 (Défaut 30)

# Powerdown time. The console will go to DPMS Off mode POWERDOWN_TIME
# minutes _after_ blanking. (POWERDOWN_TIME + BLANK_TIME after the last input)
POWERDOWN_TIME=0 (Défaut 30)
Rebootez ou redémarrer kbb
sudo /etc/init.d/kbd restart

Voila :)

dars
Posts: 2
Joined: Fri May 29, 2015 11:29 pm

Re: Désactivé la veille de l'écran

Fri May 29, 2015 11:41 pm

Bonjour,

Merci d'avoir expliquer la démarche car cela m'embete énormément lorsque je veux regarder un film sur mon raspberry mais malheureusement cela me dit que je n'ai pas les droits pour modifier le fichier. A savoir je suis sous debian ou raspbian !

Je me suis procuré le raspberry Pi 2 aujourd'hui et je viens de passer des heures sur les forums a tester différentes manip tel que le gksudo nautilus et autre chmod et honnetement je n'y comprends absolument rien... (j'ai même failli balancer mon Pi 2 contre un mur tellement j'en peux plus)

Pourriez-vous m'aider a me sortir de ce mauvais pas ? merci d'avance

Panjas51
Posts: 9
Joined: Sun Feb 09, 2014 2:10 pm

Re: Désactivé la veille de l'écran

Mon Jun 01, 2015 10:31 am

sudo nano /etc/kbd/config

Panjas51
Posts: 9
Joined: Sun Feb 09, 2014 2:10 pm

Re: Désactivé la veille de l'écran

Mon Jun 01, 2015 11:46 am

Cette modif ne fonctionne pas..?

BLANK_TIME=0 (Défaut 30)
POWERDOWN_TIME=0

dars
Posts: 2
Joined: Fri May 29, 2015 11:29 pm

Re: Désactivé la veille de l'écran

Wed Jun 03, 2015 7:33 pm

Yes merci infiniment ça fonctionne nickel ! vous êtes géniaux les mecs, ma mère va pouvoir regarder ces films tranquillement maintenant ! encore merci pour tout, vous avez droit a un bisou de ma maman lol

c00per
Posts: 2
Joined: Thu Sep 18, 2014 4:37 pm

Re: Désactivé la veille de l'écran

Sat Oct 31, 2015 8:33 am

Bonjour,

Je suis sous la nouvelle version Jessie de septembre et à nouveau je rencontre ce problème, à chaque release, c'est vraiment ennuyant, pourquoi ne mettent-ils pas un gui pour gêrer cette fonction.

J'ai passé les 2 options à 0 et ça ne marche toujours pas, après 5 minutes d'inactivité environ, l'écran se met en veille avec un écran noir.

Merci si vous avez d'autres solutions ;-)

Pour infio, j'ai essayé aussi ceci : framboisepi.fr/desactiver-la-veille-decran/

bn63
Posts: 1
Joined: Fri Apr 01, 2016 3:42 pm

Re: Désactivé la veille de l'écran

Fri Apr 01, 2016 3:45 pm

Même problème sous Jessie, impossible de deactiver la veille écran au bout de 10 min, personne n'a la solution ?

totoharibo
Posts: 4253
Joined: Thu Jan 24, 2013 8:43 am

Re: Désactivé la veille de l'écran

Sat Apr 02, 2016 8:34 am

bn63 wrote:Même problème sous Jessie, impossible de deactiver la veille écran au bout de 10 min, personne n'a la solution ?
sur jessie c'est systemd dont les init.d marchent pas si je ne me trompe.

si c'est ça c'est sudo systemctrl xx xx. Les xx j'sais pas.

User avatar
AiGreek
Posts: 229
Joined: Sun Dec 06, 2015 7:44 pm

Re: Désactivé la veille de l'écran

Sat Apr 02, 2016 8:44 am

c00per wrote:c'est vraiment ennuyant, pourquoi ne mettent-ils pas un gui pour gêrer cette fonction.
En fait, il y a un Gui. On l'appelle Xscreensaver

Code: Select all

apt-get install xscreensaver

Return to “Français”