hostapd non fonctionnel au démarrage [RÉSOLU]


3 posts
by pixop » Mon Jun 05, 2017 2:13 pm
Bonjour,

Sur un Raspberry pi 3 et une raspbian 8.0 Jessie, hostapd ne fonctionne pas au démarrage, que ce soit via systemctl start hostapd ou par service hostapd start; aucun réseau n'est visible depuis mon smartphone, tablette, etc.

Par contre, si je le lance manuellement avec la commande hostapd /etc/hostapd/hostapd.conf, ça fonctionne et je peux m'y connecter malgré un message d'erreur, que voici:
Code: Select all
root@raspberrypi:~# hostapd /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
Failed to create interface mon.wlan0: -95 (Operation not supported)
wlan0: Could not connect to kernel driver
Using interface wlan0 with hwaddr b8:27:eb:87:d2:93 and ssid "Pi3-AP"
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED


J'ai cherché un peu et n'ai rien trouvé de concluant... Se pourrait-il que c'en soit la cause ?

J'ai désactivé hostapd dans systemd du coup et si je le réactive ça donne:
Code: Select all
root@raspberrypi:~# systemctl enable hostapd.service
Synchronizing state for hostapd.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d hostapd defaults
insserv: warning: current start runlevel(s) (empty) of script `hostapd' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `hostapd' overrides LSB defaults (0 1 6).
Executing /usr/sbin/update-rc.d hostapd enable
root@raspberrypi:~# systemctl start hostapd.service
root@raspberrypi:~# systemctl status hostapd.service
● hostapd.service - LSB: Advanced IEEE 802.11 management daemon
   Loaded: loaded (/etc/init.d/hostapd)
   Active: active (exited) since lun. 2017-06-05 12:13:37 CEST; 3h 54min ago

juin 05 12:13:37 raspberrypi systemd[1]: Started LSB: Advanced IEEE 802.11 m....
juin 05 15:54:25 raspberrypi systemd[1]: Started LSB: Advanced IEEE 802.11 m....
Hint: Some lines were ellipsized, use -l to show in full.

Là, je devrai voir mon RPi mais rien !

Je veux configurer mon RPi comme point d'accès.
J'ai donc modifié mon /etc/network/interfaces comme suit:
Code: Select all
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

#allow-hotplug wlan0
#iface wlan0 inet manual
#    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

#allow-hotplug wlan1
#iface wlan1 inet manual
#    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

## FOR PI ACCESS POINT WIFI
allow-hotplug wlan0 
iface wlan0 inet static 
    address 172.24.1.1
    netmask 255.255.255.0
    network 172.24.1.0
    broadcast 172.24.1.255
#    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

J'ai installé et configuré dnsmasq comme suit:
Code: Select all
interface=wlan0      # Use interface wlan0 
listen-address=172.24.1.1 # Explicitly specify the address to listen on 
#listen-address=192.168.1.1
bind-interfaces      # Bind to the interface to make sure we aren't sending things elsewhere 
server=8.8.8.8       # Forward DNS requests to Google DNS 
domain-needed        # Don't forward short names 
bogus-priv           # Never forward addresses in the non-routed address spaces. 
dhcp-range=172.24.1.50,172.24.1.100,1h # Assign IP addresses between 172.24.1.50 and 172.24.1.150 with a 2 hour lease time

/etc/hostapd/hostapd.conf ressemble à ça:
Code: Select all
# This is the name of the WiFi interface we configured above
interface=wlan0

# Use the nl80211 driver with the brcmfmac driver
driver=nl80211

# This is the name of the network
ssid=Pi3-AP

# Use the 2.4GHz band
hw_mode=g

# Use channel 6
channel=6

# Enable 802.11n
ieee80211n=1

# Enable WMM
wmm_enabled=1

# Enable 40MHz channels with 20ns guard interval
ht_capab=[HT40][SHORT-GI-20][DSSS_CCK-40]

# Accept all MAC addresses
macaddr_acl=0

# Use WPA authentication
#auth_algs=1

# Require clients to know the network name
ignore_broadcast_ssid=0

# Use WPA2
#wpa=2

# Use a pre-shared key
#wpa_key_mgmt=WPA-PSK

# The network passphrase
#wpa_passphrase=raspberry

# Use AES, instead of TKIP
#rsn_pairwise=CCMP

Sécurité retiré pour les tests.

/etc/default/hostapd a été complété comme suit:
Code: Select all
# Defaults for hostapd initscript
#
# See /usr/share/doc/hostapd/README.Debian for information about alternative
# methods of managing hostapd.
#
# Uncomment and set DAEMON_CONF to the absolute path of a hostapd configuration
# file and hostapd will be started during system boot. An example configuration
# file can be found at /usr/share/doc/hostapd/examples/hostapd.conf.gz
#
#DAEMON_CONF="/etc/hostapd/hostapd.conf"

# Additional daemon options to be appended to hostapd command:-
#    -d   show more debug messages (-dd for even more)
#    -K   include key data in debug messages
#    -t   include timestamps in some debug messages
#
# Note that -B (daemon mode) and -P (pidfile) options are automatically
# configured by the init.d script and must not be added to DAEMON_OPTS.
#
#DAEMON_OPTS=""


Merci pour l'intérêt que vous porterez à mon problème.
Bien à vous et merci d'avance.
Last edited by pixop on Tue Jun 06, 2017 4:07 pm, edited 1 time in total.
Posts: 2
Joined: Mon Jun 05, 2017 1:33 pm
by epoch1970 » Tue Jun 06, 2017 9:38 am
L'erreur est "normale", elle n'a pas d'incidence.
Est-ce que dhcpcd est désactivé sur wlan0? Dans le fichier interfaces il est écrit
la 4ème ligne du fichier wrote:# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

Dans /etc/default/hostapd, il est écrit
les lisgnes 6 et 7 du fichier wrote:# Uncomment and set DAEMON_CONF to the absolute path of a hostapd configuration
# file and hostapd will be started during system boot.

Donc tant que "DAEMON_CONF" n'est pas décommenté, ça ne démarrera pas.

Par ailleurs virer "bind-interfaces" de la conf dnsmasq, ça ne sert à rien sauf le faire foirer au démarrage.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel
Posts: 959
Joined: Thu May 05, 2016 9:33 am
by pixop » Tue Jun 06, 2017 4:06 pm
Bonsoir epoch1970,

Je pensais n'avoir oublié aucun fichier à montrer mais dhcpcd.conf est passé à la trappe.
Cependant, je lui ai bien ajouté une ligne "denyinterfaces wlan0"...

Je n'avais pas vu que la ligne "DAEMON_CONF" était commentée et cela venait bien de ça !
Merci de me l'avoir fait remarquer.

Je prends note pour le bind-interfaces. ;)

Une fois de plus le problème était situé entre le clavier et la chaise. :roll:
Je vais pouvoir passer ce sujet en résolu, merci.
Posts: 2
Joined: Mon Jun 05, 2017 1:33 pm