Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Problème ethernet

Thu Aug 23, 2012 3:37 pm

Bonjour,

J'ai reçu ma Raspberry hier et après avoir un peu galéré sur les config clavier je me suis rendu compte que je n'avais pas internet. Je n'ai aucun signal me disant qu'un câble Ethernet vient d'être connecté lorsque je branche mon Raspberry et d'après ce que j'ai vu certaines LED devraient s'allumer quand l'Ethernet est mis, moi je n'ai que la LED de power et la petite à coté qui clignote régulièrement.

J'ai regardé avec ifconfig, eth0 est là mais aucune adresse ne lui a été donnée (aucun soucis au niveau de la box vu que le DHCP fonctionne correctement).

Ma Raspberry aurait un problème?

trouch
Posts: 310
Joined: Fri Aug 03, 2012 7:24 pm
Location: France
Contact: Website

Re: Problème ethernet

Thu Aug 23, 2012 4:58 pm

le premier batch avait un probleme sur le jack ethernet (pas de detection du cable), mais c'est réglé depuis lontemps...
as tu essayé avec un autre cable (celui de ton ordi par exemple) ? ça peut etre un problême de cable défectueux ou de cable croisé.

tu peux aussi forcer le dhcp :

Code: Select all

$ sudo dhclient eth0

WebIOPi - Raspberry Pi REST Framework to control your Pi from the web
http://store.raspberrypi.com/projects/webiopi
http://code.google.com/p/webiopi/
http://trouch.com

User avatar
Gabriel
Posts: 73
Joined: Wed Aug 10, 2011 5:43 pm
Location: France

Re: Problème ethernet

Thu Aug 23, 2012 5:48 pm

Croisé ou droit ce n'est pas un problème puisque les deux sont compatibles avec le raspberry pi. (vu sur ce forum)
My home-made case : http://goo.gl/nprcI ; My presentation http://goo.gl/5hSar et en français : http://goo.gl/28Vif ; Please think to the FAQ and to the Wiki

trouch
Posts: 310
Joined: Fri Aug 03, 2012 7:24 pm
Location: France
Contact: Website

Re: Problème ethernet

Thu Aug 23, 2012 5:56 pm

Gabriel wrote:Croisé ou droit ce n'est pas un problème puisque les deux sont compatibles avec le raspberry pi. (vu sur ce forum)
je n'étais pas sûr, merci de la précision

WebIOPi - Raspberry Pi REST Framework to control your Pi from the web
http://store.raspberrypi.com/projects/webiopi
http://code.google.com/p/webiopi/
http://trouch.com

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Thu Aug 23, 2012 6:08 pm

Merci pour les rep.

J'utilise le câble Ethernet d'un de mes pc justement donc je pense que le câble est bon.
J'ai vu sur ce forum, comme dit au dessus, que les câbles droit fonctionnent.

Je viens d'essayer la commande, ça reste une trentaine de seconde sans rien faire et après la commande semble exécutée mais rien ne change.

Les LEDs sont sensées s'allumer à quel moment? (savoir si j'ai un appareil défectueux )

User avatar
Gabriel
Posts: 73
Joined: Wed Aug 10, 2011 5:43 pm
Location: France

Re: Problème ethernet

Thu Aug 23, 2012 6:57 pm

Alors sur mon raspberry pi les leds (concernant l'ethernet) marchent comme ça :
- si cable ethernet branché avec rien au bout = aucune ne s'allume (logique mais bon...)
- câble (droit) avec freebox (routeur+dhcp ok) = FDX, LNK, 10M s'allument puis LNK clignote avant de rester stable (et allumée) [si on n'utilise pas/peu la connexion].
- câble (droit) avec netbook windows [juste pour voir] -> pareil (!) : FDX, LNK, 10M s'allument et LNK clignote de temps en temps.
My home-made case : http://goo.gl/nprcI ; My presentation http://goo.gl/5hSar et en français : http://goo.gl/28Vif ; Please think to the FAQ and to the Wiki

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Thu Aug 23, 2012 7:15 pm

D'accord. Pour l'instant je ne les ais jamais vu ni s'allumer ni clignoter :(

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Thu Aug 23, 2012 8:01 pm

Est ce que la date présente en dessous de la framboise est pour vous aussi : 2011 ?

User avatar
Gabriel
Posts: 73
Joined: Wed Aug 10, 2011 5:43 pm
Location: France

Re: Problème ethernet

Thu Aug 23, 2012 8:39 pm

Moi aussi j'ai 2011. Tu l'alimentes comment ta carte ? Chargeur usb ?
My home-made case : http://goo.gl/nprcI ; My presentation http://goo.gl/5hSar et en français : http://goo.gl/28Vif ; Please think to the FAQ and to the Wiki

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Thu Aug 23, 2012 9:37 pm

Oui, j'ai plusieurs chargeur (téléphone, tablette, ...). J'utilise celui de ma playbook en générale, c'est une 5V 2A. Normalement je crois qu'il suffit de 1A. J'ai vu que beaucoup avait eu des problèmes avec leur alimentation si mon soucis pouvait venir simplement de là ça m'arrangerait mais je pense que ce n'est pas le cas :| (comment le savoir d'ailleurs?)

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Fri Aug 24, 2012 7:07 pm

Quelqu'un a t-il eu à renvoyer son Raspberry à RS ? Et comment cela s'est-il passé?

Je pense que le port Ethernet est HS mais je ne connais pas de moyen de le vérifier (les LEDs ne s'allumant pas même lorsque connecté c'est déjà à priori significatif mais bon).

jean.michel.78
Posts: 32
Joined: Fri Aug 24, 2012 11:29 am
Location: montigny 78 france
Contact: Website

Re: Problème ethernet

Sun Aug 26, 2012 10:17 am

essaie de forcer l adresse
ifconfig eth0 192.168.0.12
et relis ifconfig eth0

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Sun Aug 26, 2012 11:26 am

J'ai essayé en passant en Ip Static mais ça n'a pas fonctionné. Je ne sortais pas du raspberry (aucun ping ne passait à par localhost) et les leds ne s'allumaient pas non plus. J'ai testé en wifi voir si ça fonctionnait en DHCP et j'avais bien internet. Le port est défectueux je pense.

Nefast
Posts: 8
Joined: Thu Aug 23, 2012 3:30 pm

Re: Problème ethernet

Thu Aug 30, 2012 6:33 pm

J'ai contacté RS par email. Au cas où quelqu'un d'autre aurait un problème de ce genre, ils m'ont répondu que la Raspberry devait être renvoyé pour un échange mais que cet échange serait fait dans les délais de réapprovisionnement soit d'ici janvier 2013... Si cela ne convient pas on peut se faire rembourser. Ils notent aussi que l'expédition se fait sous notre responsabilité (si le colis n'arrive pas au bout et qu'on a pas pris de suivi ben tant pis pour nous) mais sans précisé si les frais d'envoi sont à leur charge au final ou non.

Pour moi c'est très limite par rapport à l'attente comme si la commande venait d'être faite et que, au vu de la file d'attente, les délais sont long. Un produit défectueux sous garantie n'est pas une commande, l'échange devrait être prioritaire sur les commandes en cours...

Bref je me suis fait entuber, j'espère que d'autres n'auront pas de problème de ce genre...

Return to “Français”