ouaibe
Posts: 29
Joined: Wed Feb 13, 2013 7:06 pm

[RESOLU] Certains sites innaccessibles

Wed Mar 23, 2016 8:06 pm

Bonjour,

Je suis sous raspberrypi 3 sous raspbian.
Ma connexion wifi fonctionne très bien, par contre, certains site sont innaccessibles (ssl0.ovh.net par exemple) ainsi que certaines connexion telles que l'accès à mon serveur perso owncloud (distant) et mon webmail via ClawsMail chez OVH ?

Une idée ?
Bonne soirée.
Last edited by ouaibe on Mon Mar 28, 2016 7:18 pm, edited 1 time in total.

ouaibe
Posts: 29
Joined: Wed Feb 13, 2013 7:06 pm

Re: Certains sites innaccessibles

Sat Mar 26, 2016 8:03 pm

Bonsoir,

C'est à n'y rien comprendre ...la majorité restent innaccessible ! et pourtant ma connexion soit wifi, soit filaire est OK;
Une idée?

Bonne soirée.

totoharibo
Posts: 4448
Joined: Thu Jan 24, 2013 8:43 am

Re: Certains sites innaccessibles

Sun Mar 27, 2016 6:20 am

as tu essayer de faire un ping dessus avec leur nom de domaine et si ça colle pas avec leur adresse IP ?

avec une liaison ethernet ça fait pareil ?
avec un autre ordi ça fait pareil ?

je pencherais pour un problème de DNS

ouaibe
Posts: 29
Joined: Wed Feb 13, 2013 7:06 pm

Re: Certains sites innaccessibles

Sun Mar 27, 2016 3:55 pm

Bonjour,

Sur le meme réseau, tout est OK avec mes autres ordis et meme avec une autre RaspberryPi de la 1ere generation ... que ce soit en filaire ou wifi.
J'ai fait les tests en eth0 et Wlan0, c'est pareil !

Ce qui est étrange c'est que par exemple, quelques sites par ci par là sont OK comme par exemple http://www.raspberrypi.org, http://www.debian-fr.org, http://www.raspbian.org ou encore webmail.gandi.net !!!!!!

jeanluc
Posts: 312
Joined: Thu Apr 11, 2013 9:44 am

Re: Certains sites innaccessibles

Sun Mar 27, 2016 4:27 pm

Salut;
Par hasard t'as pas installé pgl (peerguardian) cousin de peerblock...? la plupart des ip d'ovh y sont blacklistées...

ouaibe
Posts: 29
Joined: Wed Feb 13, 2013 7:06 pm

Re: Certains sites innaccessibles

Sun Mar 27, 2016 6:48 pm

Non non pas de pgl ... et je n'ai pas que des IP OVH innaccessibles.

jeanluc
Posts: 312
Joined: Thu Apr 11, 2013 9:44 am

Re: Certains sites innaccessibles

Sun Mar 27, 2016 8:09 pm

ouaibe wrote:Non non pas de pgl ... et je n'ai pas que des IP OVH innaccessibles.
Re;
pgl ou autre soft utilisant des blocklist ...

Dans les softs utilisant des blocklists de https://www.iblocklist.com/ c'est souvent le cas, car les ip des hébergeurs (ovh, online,..) sont pour la plupart blacklistées surtout dans la blocklist p2p, car ces hébergeurs sont potentiellement reconnus capables de louer des serveurs à des stés comme TMG qui travaillent pour hadopi.
Mais l'inconvénient de ces blocklists c'est qu'elles ratissent trop large et souvent a tord et a travers, et du coup des ip de ces hébergeurs se retrouvent bloquées alors qu'elles n'ont rien a voir avec des organisations anti-p2p.
;)

ouaibe
Posts: 29
Joined: Wed Feb 13, 2013 7:06 pm

Re: Certains sites innaccessibles

Sun Mar 27, 2016 8:38 pm

Merci, mais dans ce cas, l'ensemble de mes machines sur mon réseau (pour peu qu'elles aient eu pgl) auraient été dans ce cas.

Je cherche toujours l'origine de mon pb ... si quelqu'un a une autre idée ;o)

jeanluc
Posts: 312
Joined: Thu Apr 11, 2013 9:44 am

Re: Certains sites innaccessibles

Sun Mar 27, 2016 9:04 pm

As tu essayé de faire un ping sur ces sites bloqués ?


1- Avec ton firewall actif si t'en as un en place

2- Après initialisation des règles iptables

Code: Select all

sudo iptables -F
sudo iptables -X
ping ssl0.ovh.net
Faire pareil avec l'ip

Edit:dans ce cas, l'ensemble de mes machines sur mon réseau
Pas forcément, sauf si ta pi sert de passerelle pour tout ton réseau.... :D
Pour le ping @totoharibo t'en a parlé...mais t'as pas donné réponse...alors qu'est ce que ça donne avec et sans règles iptables et avec domaine et avec l'ip directement ?

JumpZero
Posts: 1133
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Certains sites innaccessibles

Mon Mar 28, 2016 2:26 pm

ouaibe wrote:tout est OK avec mes autres ordis et meme avec une autre RaspberryPi de la 1ere generation ... que ce soit en filaire ou wifi.
Si tu as un deuxième Raspberry Pi, tu peux faire un essai simple (si c'est possible): croise les 2 cartes SD, si le problème suit la carte SD c'est sans doute un problème de logiciel (de config système dans la SD concernée) du type firewall ou autre comme te le dis Jean-Luc. Sinon hardware? routeur? autre..
--
Jmp0

jeanluc
Posts: 312
Joined: Thu Apr 11, 2013 9:44 am

Re: Certains sites innaccessibles

Mon Mar 28, 2016 3:02 pm

@JumpZero
-Accès à certains sites et pas d'autres : routeur ou box...je n'y crois pas de trop...vu que ça marche sur certains postes de son réseau
-Idem pour le DNS ...si résolveur (bind, unbound,..) installé, soit ça résout (tous les sites) ou rien...sauf si les ip qui fonctionnent sont déclarées dans son fichier hosts; si résolution FAI ou autre : idem c'est tout ou rien sauf si le prestataire du serveur DNS bloque volontairement certains sites.

Mais @ouaibe ne part dans ses réponses que du principe que ça fonctionne sur les autres postes de son réseau local... silence radio sur un test de ping demandé par @totoharibo au début du topic....j'attends avec impatience celui avec et sans firewalll..

Son réseau local, il en parle, mais sans dire si chaque poste est indépendant derrière sa box ou son routeur, ou si un des poste sert de passerelle...avec ça pas facile...sauf la boule de cristal peu être :lol:

Alors demander de l'aide, c'est bien, mais être précis et répondre aux tests demandés c'est mieux...

JumpZero
Posts: 1133
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: Certains sites innaccessibles

Mon Mar 28, 2016 4:48 pm

@jeanluc oui c'est vrai on ne connais pas l’architecture de son réseau local, on part du principe que tout est derriere une box/routeur.. mais qui sait! Par contre il n'a pas dit s'il avait un firewall ou pas.
Affaire a suivre.. après réponse aux tests
--
Jmp0

ouaibe
Posts: 29
Joined: Wed Feb 13, 2013 7:06 pm

Re: Certains sites innaccessibles

Mon Mar 28, 2016 7:17 pm

Pas de firewall, aucune réponse au PING, idem avec les IP des sites cités (entre autre) comme avec l'IP 8.8.8.8.
Jamais ce type de pb avec mes différentes instal DEBIAN ou même Raspberry pi 1ère génération dans mon réseau qui n'a pas été modifié.

Je pense qu'il s'agit d'un bug ! Oui mais lequel ? impossible d'y répondre.

Je viens de réinstaller Raspbian et là aucun pb ... bref, affaire résolue (mais non élucidée).
Merci à tous.

Return to “Français”