alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Default user

Fri Jul 27, 2012 7:28 pm

Bonjour a tous, bien content d'avoir reçu mon rasp,i je me fais la main dessus et je me met a linux par la même occasion... j' épluche pas mal de tutos et autre blogs sur l'utilisation de linux et ca rentre vite! cool!
Mais la je bloque sur un truc tout bête: je crée un autre user 'alex' ,je lui attribut les mêmes droits que 'pi' via 'sudo visudo' jusque ici pas de problèmes; mais je ne parviens pas a définir que wheezy se log sur alex a chaque démarrage pour l 'instant il reste bloquer sur 'pi' et pas moyen de contourner le problème avec un 'deluser' sur 'pi' y a toujours un prosses qui reste actif avec lui donc erreur et 'pi' et toujours la!
quelqu'un peut il me donner la marche a suivre pour que le raspi se log sur 'alex' a chaque demarage et aussi accessoirement le moyen de supprimer entièrement le user 'pi'.
je tourne sous wheezy, télécharger le 25/7/12.
Par avance merci ;-)

jeek
Posts: 32
Joined: Sun Jul 22, 2012 6:43 am

Re: Default user

Sat Jul 28, 2012 7:30 pm

Je ne suis pas un spécialiste mais j'ai supprimé l'utilisateur pi en tapant :
sudo adduser alex
sudo adduser alex sudo

Je me connecte sur l'utilisateur alex et tape :
sudo deluser --remove-home pi

Chez moi ça a marché...

ReidLos
Posts: 11
Joined: Sat Jul 28, 2012 3:26 pm

Re: Default user

Sun Jul 29, 2012 3:03 pm

Salut,

Pour qu'il se connecte automatiquement, tu dois éditer le fichier :

/etc/lightdm/lightdm.conf

Cherches la ligne contenant :

autologin-user=pi

Et remplaces là par :

autologin-user=alex

alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Re: Default user

Sun Jul 29, 2012 5:37 pm

Merci a vous pour vos réponses, je test ça et je post le résultat.
Ça fais plaisir de voir que la communauté francophone est active!!
Si je peux aider....

alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Re: Default user

Sun Jul 29, 2012 8:59 pm

Alors je dois être "pas bon" car j'ai fais pas mal de tests mais rien ne marche!
j'ouvre et edite le fichier

Code: Select all

sudo nano /etc/lightdm/lightdm.conf
je trouve la ligne autologin-user dans [SETDEFAULT] la ligne est commenter (#) et il n y a pas de 'pi'
Pas grave je dé commente et met 'alex'.....marche pas :-(
j'ai fais pas mal de test dans ce fichier eplucher les definition de chaque ligne... je bloque!!

ReidLos
Posts: 11
Joined: Sat Jul 28, 2012 3:26 pm

Re: Default user

Mon Jul 30, 2012 7:27 am

Remets à l'origine le fichier et regardes bien. Fais une recherche dans le fichier :)

alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Re: Default user

Mon Jul 30, 2012 8:06 am

par soucis de bien faire j ai deja tester avec le fichier d' origine juste apres avoir mis l'image sur la carte sd.
meme resultat... et une recherche du mot 'pi' ne donne rien!
as tu le meme fichier?
chez toi il y bien la ligne 'autologin-user=pi' ?
chez moi ell existe bien mais elle est commenter d'origine et vide de parametre!
#autologin-user=

ReidLos
Posts: 11
Joined: Sat Jul 28, 2012 3:26 pm

Re: Default user

Mon Jul 30, 2012 10:52 am

Voilà le bloc que j'ai chez moi :

Code: Select all

#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
autologin-user=pi
#autologin-user-timeout=0
#autologin-session=UNIMPLEMENTED
#exit-on-failure=false

alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Re: Default user

Mon Jul 30, 2012 11:09 am

ha oui ok! c'est le bloc en entier? car chez moi j'ai au moins le double de lignes!!
je suis au boulot mais je te post ce soir le bloc entier extrai du image neuve.
merci pour ton aide

alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Re: Default user

Mon Jul 30, 2012 7:20 pm

Voila mon bloc en entier =

Code: Select all

[SeatDefaults]
#xserver-command=X
#xserver-layout=
#xserver-config=
xserver-allow-tcp=false
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
greeter-session=lightdm-greeter
greeter-hide-users=true
#greeter-allow-guest=true
#greeter-show-manual-login=false
#user-session=default
#allow-guest=true
#guest-session=UNIMPLEMENTED
session-wrapper=/etc/X11/Xsession
#display-setup-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-session=UNIMPLEMENTED
#exit-on-failure=false
Qu'en pense tu ? je peux poster la totalité du fichier si besoin.

ReidLos
Posts: 11
Joined: Sat Jul 28, 2012 3:26 pm

Re: Default user

Tue Jul 31, 2012 10:22 am

Poste la totalité oui s'il te plait.

alcut
Posts: 7
Joined: Fri Jul 27, 2012 7:12 pm

Re: Default user

Thu Aug 02, 2012 8:49 pm

Bonjour a tous problème résolut!!
Merci a "Jeek" et "ReidLos" pour leur aide; j'ai préféré m’orienter sur la technique de "ReidLos" car supprimer un user afin de devenir le "default_user" me semble un peu barbar...;-)
Voici la solution :
Pour bouter sur un default user il faut éditer le fichier /etc/inittab

Code: Select all

sudo nano /etc/inittab
Dans ce fichier, on changera ou commentera la ligne :

Code: Select all

1:2345:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1
par :

Code: Select all

1:2345:respawn:/bin/login -f YOUR_USER_NAME tty1 </dev/tty1 >/dev/tty1 2>&1
Tout est expliquer http://www.debian-fr.org/autostartx-apr ... 25337.html
et bien plus (lancer l'interface graphique auto....)
Merci a eu et a vous.

Return to “Français”

Who is online

Users browsing this forum: No registered users and 4 guests