User avatar
Vinzenz-o
Posts: 14
Joined: Tue Jul 03, 2012 1:48 pm

Débuts laborieux sur la distrib Debian6 (Squeeze) (buguée ?)

Tue Jul 03, 2012 2:38 pm

Salut à tous,

Petit résumé de mes premier pas sur RPI et de mes problèmes (qui ne sont pas tous résolus^^). Peut-être que ce topic pourra dépanner d'autres utilisateurs qui rencontrerons des problèmes similaires ;)

Donc, j'ai reçu mon RPI hier, en même temps que ma carte SD.

La carte est une Sandisk Extreme 32GB, Class 10, 45Mo/s.
Apparemment cette carte pose problème (trop rapide ???). Plusieurs topics font état de problèmes similaires à ceux que j'ai rencontrés (ie http://www.raspberrypi.org/phpBB3/viewt ... =28&t=7983 et http://www.raspberrypi.org/phpBB3/viewt ... =28&t=7968, parmi d'autres similaires).

J'ai commencé par installer l'image Debian6-19-04-2012 en utilisant "win32diskimager" sous W7 (mon portable avec Linux étant HS suite à une erreur de ma part :mrgreen: Il était en cours de réinstall en même temps... :lol: ). Aucun soucis de transfert d'image.
Lancement du RPI et directement l'erreur:

Code: Select all

mmc0: Timeout waiting for hardware interrupt
qui tourne en boucle.

J'ai trouvé ce topic => Debian Won't Boot: mmc0 Timeout et la solution apportée qui consiste à télécharger les "start.elf" et "kernel.img" qui ont été upgradés; puis copie de ces fichiers sur la carte SD.

Je relance le RPI, mais nouvelles erreurs:

Code: Select all

mmc0: final write to SD card still running
mmc0: Timeout waiting for hardware interrupt.
mmcblk0: error -110 sending stop command, original cmd response 0x900, card status 0x900
(les mêmes ou très similaires^^).
Mais, au bout d'un moment (plusieurs minutes^^), il arrive tout de même à booter. Je peux me loguer, lancer des tâches, lancer l'interface graphique, etc...

Par contre, mon clavier et ma souris posent problème... Les touches restent comme enfoncées (genre touches rémanentes non stop tant que je n'ai pas appuyé sur une autre touche). Situation très galère. Par exemple, en tapant le login "pi", on se retrouve avec "piiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii"... Pour taper le mot de passe, j'ai dû m'y reprendre plusieurs dizaines de fois...

Une fois sur l'interface graphique, dés que je bouge la souris, la clavier devient inactif et la souris également...

Je trouve donc ce topic => Pi with 16GB SanDisk Extreme Class 10 45MB/s WORKING qui explique comment faire une MàJ propre et complète du firmware du RPI.

Après avoir suivi toutes les étapes, je relance le RPI et il se lance normalement (plus ou moins). Plus d'erreurs au lancement. Par contre, le problème du clavier perdure, ainsi que celui de la souris... Je suis obligé de retirer le récepteur USB puis de le rebrancher et tout remarche très bien...

Mais, le RPI met tout de même plusieurs minutes (entre 1min30 et 2 ou 3 min) à se lancer. C'est long. Trop long si j'en crois les retours d'autres utilisateurs...
Egalement, je trouve que cette distribution est particulièrement lente et lourde sous interface graphique. Il faut parfois jusqu'à 30 secondes pour lancer un logiciel (peut-être que c'est normal^^).


Entre ces étapes, j'ai également testé la distribution Raspbmc (http://www.raspbmc.com/).
Aucun soucis de lancement. Rapide, sans erreurs.
Clavier/souris parfaitement reconnus et fonctionnels (par de rémanence des touches, ni de blocages du clavier ou de la souris).


Je vais tester d'autres distributions car cette Debian6 (Squeeze) me semble quelque peu buguée. D'ailleurs il semblerait que de plus en plus de monde se dirige vers la distrib Wheezy (http://www.raspberrypi.org/archives/1435).


Si vous avez des éléments de réponses/solutions pour mes soucis de lenteur et/ou de clavier/souris, je suis preneur ;)

Vinzenz-o

DanyCool
Posts: 3
Joined: Fri Jul 06, 2012 4:33 pm

Re: Débuts laborieux sur la distrib Debian6 (Squeeze) (bugué

Fri Jul 06, 2012 4:43 pm

Bonjour à toi RPI-Man,

j'apprécie ton poste car j'ai rencontré le même problème ... comme beaucoup d'autre d'ailleurs.

Seul le problème du clavier persiste, lorsque je saisie l'URL (wget http://goo.gl/1BOfJ -O /usr/bin/rpi-update && chmod +x /usr/bin/rpi-update) il semble se connecter mais il me dit :
http request sent, awaiting response ... 404 not found

Si tu as réussis cette manipe pour faire fonctionner le clavier & souris en mode GUI (startx) pourrais la détailler ...

Merci d'avance

User avatar
Vinzenz-o
Posts: 14
Joined: Tue Jul 03, 2012 1:48 pm

Re: Débuts laborieux sur la distrib Debian6 (Squeeze) (bugué

Sat Jul 07, 2012 3:29 pm

Salut Dany,

Le bout de code que tu indiques:

Code: Select all

wget http://goo.gl/1BOfJ -O /usr/bin/rpi-update && chmod +x /usr/bin/rpi-update
(vérifie bien que dans "1BOfJ" et le "-O" tu indiques bien des "O" majuscules. Lettre "O" et pas le chiffre zéro)

permet de télécharger un fichier qui permettra ensuite de lancer l'update du firmware du RPI. Ce n'est donc pas ceci qui devrait résoudre le soucis du clavier.

J'ai également eu qques soucis pour effectuer cette mise à jour. Pense bien à updater les certificats auparavant en utilisant la commande:

Code: Select all

sudo apt-get install ca-certificates
puis fait une mise à jour des dépots en tapant:

Code: Select all

apt-get update
Peut-être nécessaire de taper "sudo" au début de la ligne... Je ne sais plus...

Par contre, j'ai remplacé l'URL raccourci "http://goo.gl/1BOfJ" par l'url normale "https://raw.github.com/Hexxeh/rpi-updat ... rpi-update"
C'est plus galère à taper, mais tu es sûr de ne pas avoir de soucis de redirection... (bien que çà ne doit pas changer grand chose^^)

Pour la suite des opérations, suis bien ce tuto => http://www.raspberrypi.org/phpBB3/viewt ... =28&t=7983
et tout devrait plus ou moins bien fonctionner.
Mais je reste persudé que la distribution Debian Squeeze est pas mal buguée.

Pour le problème des touches rémanentes du clavier, j'ai l'impression que le fait de passer en clavier FR AZERTY permet d'avoir moins de bugs... Mais il lui arrive parfois de rester "bloquer" sur une touche...

Pour les clavier/souris qui se désactivent, je n'ai pas vraiment de solution pour l'instant.
J'ai tout de même remarqué que si je bouge la souris avant d'être sous l'interface graphique, ils se bloquent tout les deux. Je suis dans ce cas obligé de débrancher le récepteur USB et de le rebrancher pour que tout refonctionne.
Même chose si je repasse de l'interface graphique à "l'interface terminal"; même sans bouger la souris...
Dans tous les cas, le fait de débrancher puis rebrancher le récepteur USB permet de réactiver les clavier/souris.

Depuis mon premier message, j'ai installé la distribution Debian Wheezy (http://www.raspberrypi.org/archives/1435) et clairement, elle fonctionne beaucoup mieux.
Peut-être que le fait d'avoir mis à jour le firmware du RPI avant permet à Wheezy d'être plus stable que Squeeze.

;)

DanyCool
Posts: 3
Joined: Fri Jul 06, 2012 4:33 pm

Re: Débuts laborieux sur la distrib Debian6 (Squeeze) (bugué

Tue Jul 10, 2012 5:52 am

Merci Vinzenz-o,

J'ai du faire la même chose pour URL ... le poste pour la carte SD je l'ai bien suivi aussi ...
Vraiment Bizarre car le clavier et la souris fonctionne bien sur autre distrib ??? avec ou sans hub alimenté.

Je pense que je vais me diriger vers une Wheezy aussi ... ;)

Pour info, fedora remix ne passe pas avec une carte SD SANDISK ULTRA 8Go ! :shock:

Return to “Français”