Edwardulrik
Posts: 3
Joined: Mon May 17, 2021 5:44 pm

Impossible de connecter ma wlan0

Mon May 17, 2021 5:55 pm

Bonjour,

Distri Raspbian desktop du site Raspbian.

Je viens de sortir mon vieux RPI 2 B+ pour faire un distributeur de croquette. Et tout fonctionne.
Je voudrais maintenant le mettre sur une clé wifi pour plus de facilité d'utilisation. Mais je rencontre un problème.
La clé wifi est bien détectée par le RPI :
commande : lsusb

Code: Select all

Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Mais n'arrive pas à prendre une adresse ip pour ce connecter à un réseau, j'ai modifier "wpa_supplicant.conf" (ici un test sur le partage de co du téléphone) :

Code: Select all

$ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FR

network={
        ssid="OnePlus 6"
        psk="*******"
}

Mais mon ifconfig reste toujours le même, après reboot également.

Code: Select all

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.7  netmask 255.255.255.0  broadcast 192.168.2.255
        inet6 fe80::3db4:4b22:c65:e722  prefixlen 64  scopeid 0x20<link>
        inet6 2a01:cb05:8b20:800:2f6:67e5:b97b:8d1c  prefixlen 64  scopeid 0x0<global>
        ether b8:27:eb:59:9b:7c  txqueuelen 1000  (Ethernet)
        RX packets 4252  bytes 352322 (344.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1964  bytes 280216 (273.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 40:a5:ef:0c:b8:8f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
La clé wifi fonctionne sur windows et c'est la clé fournis lors de l'achat du RPI .. donc compatible.

J'ai également changé le canal 2.4ghz de la box du 11 vers le 1, ça n'a rien changé.
interface.d n'a pas été modifié.

Pourriez-vous m'aidé ?

Merci

epoch1970
Posts: 6505
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Impossible de connecter ma wlan0

Tue May 18, 2021 11:55 am

Il faudrait regarder dans /var/log/syslog et voir pourquoi l'interface n'obtient pas d'adresse du tout.
Normalement dhcpcd s'occupe de ça, sauf si il y a quelque chose dans /etc/network/interfaces (ou interface.d), auquel cas il ne s'occupe plus de rien.

Faire un tour dans raspi-config et vérifier que le wifi est bien activé, également.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

JumpZero
Posts: 1237
Joined: Thu Mar 28, 2013 7:35 pm
Location: Arcachon, France

Re: Impossible de connecter ma wlan0

Tue May 18, 2021 4:08 pm

Edwardulrik wrote:
Mon May 17, 2021 5:55 pm
Distri Raspbian desktop du site Raspbian.
La distribution recommendée c'est Raspberry Pi OS:
https://www.raspberrypi.org/software/op ... -os-32-bit

Edwardulrik
Posts: 3
Joined: Mon May 17, 2021 5:44 pm

Re: Impossible de connecter ma wlan0

Tue May 18, 2021 6:00 pm

Bonjour,
JumpZero wrote:
Edwardulrik wrote:
Mon May 17, 2021 5:55 pm
Distri Raspbian desktop du site Raspbian.
La distribution recommendée c'est Raspberry Pi OS:
https://www.raspberrypi.org/software/op ... -os-32-bit
C'est bien la version que j'ai installé, autant pour moi. J'ai mal renseigné les informations.

Dans raspi-config, je constate le problème suivant dans la partie wifi :

Code: Select all

Could not communicate with wpa_supplicant
Avec cette information, j'ai effectué mes recherches et trouver ce poste :
https://raspberrypi.stackexchange.com/q ... wont-start

J'ai essayé les différentes proposition mais chez moi, il n'y a pas wpa_supplicant dans /var/run/
J'ai copier la source de /etc/ vers /var/run/ sans succes.

J'ai également modifier le code de "/lib/dhcpcd/dhcpcd-hooks" proposé ici :
https://serverfault.com/questions/86985 ... 522#905522

Sans plus de succès ... mon os va bientôt être bon pour un reset. Je vais d'ailleurs essayer de réinstaller l'OS. Je reviens vers vous si ça résout le problème. [EDIT] Aucuns changement ...

Merci pour le temps passé à me répondre.

Edwardulrik
Posts: 3
Joined: Mon May 17, 2021 5:44 pm

Re: Impossible de connecter ma wlan0

Thu May 20, 2021 1:49 pm

Bonjour,

Après avoir réinstallé la version avec les logiciels recommandé cette suite de commande à résolut le problème :

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
reboot
sudo raspi-config
J'ai utilisé la commande raspi-config pour configurer la partie wifi, tout fonctionne très bien.

Si cela peut aider d'autres utilisateurs.

Return to “Français”