herbfargus
Posts: 10
Joined: Sat Jul 18, 2015 11:51 pm

Re: Omxplayer waiting for dbus address to appear

Sun Aug 09, 2015 12:35 am

Just in case anyone else doesn't want to rename their splashscreen- you can add a sleep perameter as follows (you can make it 3 instead of 5 if you're on a Rpi 2):

Code: Select all

#! /bin/sh
### BEGIN INIT INFO
# Provides:           asplashscreen
# Required-Start:     dbus
# Required-Stop:
# Should-Start:      
# Default-Start:      S
# Default-Stop:
# Short-Description:  Show custom splashscreen
# Description:        Show custom splashscreen
### END INIT INFO

do_start () {
    sleep 5
    omxplayer /home/pi/video.mp4 &  
    exit 0
}

case "$1" in
  start|"")
    do_start
    ;;
  restart|reload|force-reload)
    echo "Error: argument '$1' not supported" >&2
    exit 3
    ;;
  stop)
    # No-op
    ;;
  status)
    exit 0
    ;;
  *)
    echo "Usage: asplashscreen [start|stop]" >&2
    exit 3
    ;;
esac

:

icebob
Posts: 5
Joined: Sat Jul 04, 2015 8:38 pm

Re: Omxplayer waiting for dbus address to appear

Fri Oct 09, 2015 7:21 pm

herbfargus wrote:Just in case anyone else doesn't want to rename their splashscreen- you can add a sleep perameter as follows (you can make it 3 instead of 5 if you're on a Rpi 2):
:[/code]
It works on Jessie too. Thanks!

TakingBackTj
Posts: 1
Joined: Thu Jan 07, 2016 3:58 pm

Re: Omxplayer waiting for dbus address to appear

Thu Jan 07, 2016 4:06 pm

Hey, I'm new to the forums and only had my pi for a few weeks.

I have followed the guide to play a mp4/mov on startup down to a t, yet when I reboot, I don't get any error messages (like its going to work) but when the video is supposed to play... nothing happens (blank screen) then loads the main desktop.

I can run the video from omxplayer in the terminal, so it is seeing the video and able to play it... it just wont play on start up...

Any ideas would be amazing

This is my /etc/init.d/asplashscreen

Code: Select all

#! /bin/sh
### BEGIN INIT INFO
# Provides:           asplashscreen
# Required-Start:
# Required-Stop:
# Should-Start:      
# Default-Start:      S
# Default-Stop:
# Short-Description:  Show custom splashscreen
# Description:        Show custom splashscreen
### END INIT INFO

do_start () {
    sleep 5
    omxplayer /home/pi/video.mp4 &  
    exit 0
}

case "$1" in
  start|"")
    do_start
    ;;
  restart|reload|force-reload)
    echo "Error: argument '$1' not supported" >&2
    exit 3
    ;;
  stop)
    # No-op
    ;;
  status)
    exit 0
    ;;
  *)
    echo "Usage: asplashscreen [start|stop]" >&2
    exit 3
    ;;
esac

:

barraba
Posts: 33
Joined: Wed Sep 28, 2016 12:17 pm

Re: Omxplayer waiting for dbus address to appear

Wed Sep 28, 2016 12:41 pm

Please need help !! I can't get anymore of this :(

i have a Raspberry pi 3 model b
rasbian with full update and update-distro
i cant get video working, tryed "nasplash" solution, and adding dbus, and downgrading omxplayer and tryed step by step everying that i found in google. No luck. It just load to desktop witout my splash.

Still if i run script manualy in terminal it shows video without a problem

omxplayer downgraded:

Code: Select all

[email protected]:~ $ omxplayer --ver
omxplayer - Commandline multimedia player for the Raspberry Pi
        Build date: Wed, 13 Jul 2016 12:06:55 +0000
        Version   : 66f9076 [master]
        Repository: https://github.com/popcornmix/omxplayer.git
tryed with -b and force display settings - nothing

Code: Select all

[email protected]:~ $ sudo cat /etc/init.d/nasplash 
#! /bin/sh
### BEGIN INIT INFO
# Provides:          nasplash
# Required-Start:    dbus
# Required-Stop:
# Should-Start:
# Default-Start:     S
# Default-Stop:
# Short-Description: Show custom splashscreen
# Description:       Show custom splashscreen
### END INIT INFO

do_start () {

    omxplayer -b --display 0 /home/pi/video.mp4 &
    exit 0
}

case "$1" in
  start|"")
    do_start
    ;;
  restart|reload|force-reload)
    echo "Error: argument '$1' not supported" >&2
    exit 3
    ;;
  stop)
    # No-op
    ;;
  status)
    exit 0
    ;;
  *)
    echo "Usage: nasplash [start|stop]" >&2
    exit 3
    ;;
esac

:
when i aded "dbus" key to the "Required-Start:"
it even dissapeared from
/var/log/syslog

and still its in init.d list

Code: Select all

[email protected]:~ $ grep -nrI Default-Start /etc/init.d |grep nas
/etc/init.d/nasplash:7:# Default-Start:     S

[email protected]:~ $ grep -nrI Default-Start /etc/init.d
/etc/init.d/plymouth:9:# Default-Start:	2 3 4 5
/etc/init.d/nasplash:7:# Default-Start:     S
/etc/init.d/dbus:6:# Default-Start:     2 3 4 5
/etc/init.d/bootlogs:7:# Default-Start:     1 2 3 4 5
/etc/init.d/fake-hwclock:9:# Default-Start:     S
/etc/init.d/alsa-utils:9:# Default-Start:     S
/etc/init.d/rpcbind:9:# Default-Start:     S
/etc/init.d/avahi-daemon:8:# Default-Start:     2 3 4 5
/etc/init.d/udev-finish:6:# Default-Start:     S
/etc/init.d/hdparm:8:# Default-Start:     S
/etc/init.d/umountfs:6:# Default-Start:
/etc/init.d/plymouth-log:9:# Default-Start:	S
/etc/init.d/dhcpcd:9:# Default-Start:     2 3 4 5
/etc/init.d/mountkernfs.sh:7:# Default-Start:     S
/etc/init.d/ssh:7:# Default-Start:	2 3 4 5
/etc/init.d/mountall.sh:6:# Default-Start:     S
/etc/init.d/raspi-config:6:# Default-Start: S
/etc/init.d/hostname.sh:7:# Default-Start:     S
/etc/init.d/single:6:# Default-Start:     1
/etc/init.d/umountnfs.sh:7:# Default-Start:
/etc/init.d/ntp:7:# Default-Start:   2 3 4 5
/etc/init.d/urandom:6:# Default-Start:     S
/etc/init.d/checkroot.sh:8:# Default-Start:     S
/etc/init.d/mountnfs-bootclean.sh:6:# Default-Start:     S
/etc/init.d/keyboard-setup:8:# Default-Start:     S
/etc/init.d/kmod:8:# Default-Start:     S
/etc/init.d/umountroot:7:# Default-Start:
/etc/init.d/networking:6:# Default-Start:     S
/etc/init.d/halt:6:# Default-Start:
/etc/init.d/procps:12:# Default-Start:     S
/etc/init.d/kbd:6:# Default-Start:     S
/etc/init.d/bootmisc.sh:7:# Default-Start:     S
/etc/init.d/mountdevsubfs.sh:7:# Default-Start:     S
/etc/init.d/mountnfs.sh:7:# Default-Start:     S
/etc/init.d/lightdm:7:# Default-Start:     2 3 4 5
/etc/init.d/mountall-bootclean.sh:6:# Default-Start:     S
/etc/init.d/killprocs:6:# Default-Start:     1
/etc/init.d/x11-common:7:# Default-Start:     S
/etc/init.d/hwclock.sh:27:# Default-Start:     S
/etc/init.d/triggerhappy:6:# Default-Start:     2 3 4 5
/etc/init.d/skeleton:10:# Default-Start:     2 3 4 5
/etc/init.d/rc.local:6:# Default-Start:     2 3 4 5
/etc/init.d/README:49:# Default-Start:     2 3 4 5
/etc/init.d/dphys-swapfile:20:# Default-Start:     2 3 4 5
/etc/init.d/checkfs.sh:7:# Default-Start:     S
/etc/init.d/udev:6:# Default-Start:     S
/etc/init.d/console-setup:7:# Default-Start:     S
/etc/init.d/nfs-common:7:# Default-Start:     S
/etc/init.d/checkroot-bootclean.sh:6:# Default-Start:     S
/etc/init.d/reboot:6:# Default-Start:
/etc/init.d/sudo:8:# Default-Start:     2 3 4 5
/etc/init.d/rmnologin:6:# Default-Start:     2 3 4 5
/etc/init.d/cron:10:# Default-Start:     2 3 4 5
/etc/init.d/bluetooth:6:# Default-Start:     2 3 4 5
/etc/init.d/rsyslog:7:# Default-Start:     2 3 4 5
/etc/init.d/motd:7:# Default-Start:     1 2 3 4 5
/etc/init.d/sendsigs:6:# Default-Start:
/etc/init.d/rsync:8:# Default-Start:     2 3 4 5
i tryed to rename it to
xsplash, no help

my cmdline.txt

Code: Select all

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes logo.nologo consoleblank=0 rootwait quiet
my config.txt

Code: Select all

sudo cat /boot/config.txt 
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

disable_splash=1
please help me !!

barraba
Posts: 33
Joined: Wed Sep 28, 2016 12:17 pm

Re: Omxplayer waiting for dbus address to appear

Thu Sep 29, 2016 1:45 pm

problem solved, you have to add

Code: Select all

# Provides:          nasplash
# Required-Start:    $local_fs
so fs could load to omxplayer read your file

SamY86
Posts: 1
Joined: Sat May 20, 2017 11:23 pm

Re: Omxplayer waiting for dbus address to appear

Sat May 20, 2017 11:31 pm

I had this error:

Code: Select all

/usr/bin/omxplayer: line 54: /home/pi/miniconda/bin/dbus-daemon: cannot execute binary file: Exec format error
waiting for dbus address to appear
waiting for dbus address to appear
...
So I deleted miniconda folder and worked for me.
PS Don't try splashscreen, all the files are erased from cloud.It's an obsolete method now.

Return to “General discussion”