USB problem solved! New problem (no sound :( )

7 posts
by squeaky3 » Thu Jun 28, 2012 9:38 pm
I went with Wheezy. Muse Score installed great, USB hub works with no freezes. But no sound.

I can't get wav or mp3 to play either.

When I do the hello_audio test, it works through the headphone, but not HDMI (I think my TV sets itself to DVI) But then I can't get any sound from a wav file, and when I load up the media player, I can add a wav file to the playlist, but the sound is set on mute, and it won't play. Also using the aplay command doesn't work.

I'm stuck, what am I missing. Please someone help :( :( :( :(
Posts: 16
Joined: Tue Jun 12, 2012 9:54 pm
by squeaky3 » Thu Jun 28, 2012 10:22 pm
I am finding there have been some sound problems in Wheezy.

Anyone know if they are solved yet?

Here's my current situation:
Started with Squeeze. Sound worked. Open Office worked. USB hub fussy and glitchy. MuseScore did not work!

Switched to Wheezy. Sound does NOT work (except hello_audio.bin, this indicates a software, not hardward problem) Open office installed (haven't loaded it yet). USB hub working without any glitches. MuseScore installed, but no sound!!


I want to use my Pi to present my music classes, I need audio!
Posts: 16
Joined: Tue Jun 12, 2012 9:54 pm
by squeaky3 » Thu Jun 28, 2012 11:29 pm
OK, probably from reading my posts you will see I am a total n00b at this....

What I have found out so far is it may be something to do with PulseAudio, which was added when I installed MuseScore.

If I type (in terminal):

mplayer -ao alsa:device=default $FILENAME

It plays my wav file via HDMI - I don't know how to force jack output this way.

It can also make the system hang/crash terminal though....

I don't know enough about what I am doing to try and fix it!
Posts: 16
Joined: Tue Jun 12, 2012 9:54 pm
by W. H. Heydt » Fri Jun 29, 2012 12:45 am
This provided a solution to a sound problem I've been having...

I'm using Debian Squeeze and--prior to giving the command to play a track, the set up is:

We then need to install and enable the sound driver module.
In the example below, we have chosen to have the audio
output routed to the headphone socket.
$ sudo modprobe snd_bcm2835

$ sudo amixer cset numid=3 1

So that the sound driver module is loaded at boot time,
we need to add the following text to the /etc/modules file
(using an editor such as nano, pico, or vi).


At least according to some commentary, you need to issue the amixer command for each session until there is a system update of some sort.
Posts: 6716
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)
by texy » Fri Jun 29, 2012 4:12 pm
You dont need to do that for wheezy as its all taken care off.
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
Forum Moderator
Forum Moderator
Posts: 4955
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England
by MadHorseman » Sat Jun 30, 2012 9:58 am
Doesn't seem to work with my Pi - I've got sound etc on Squeeze that way. On Wheezy the LXPlayer chucks away my playlists - methinks a re-download & re-image is called for??

p.s. On Wheezy I install synaptic - where did it go??? :cry:
User avatar
Posts: 83
Joined: Wed Mar 21, 2012 9:48 am
Location: Almadena, W Algarve, Portugal
by poing » Mon Jul 02, 2012 2:43 pm
I find I can't play MP3s in Wheezy; Sometimes I see a flash in the playlist after I load a song, but then it's gone. Playlist always stays white. I was just testing the headphone, I'll try the Heydt route ;-)
Posts: 1129
Joined: Thu Mar 08, 2012 3:32 pm