Page 1 of 1

ip address

Posted: Sun Dec 07, 2014 8:37 pm
by markjd
This might be a question without a real answer:

I have a USB WiFi adaptor and by connecting my pi to my TV know the IP address of my pi and can connect to it from my laptop with putty using the typical address which I found by connecting the pi to my TV and then using the GUI.

However, the WiFi connection is not that stable and so I have tried connecting my pi to my router with an ethernet cable. Once my pi is connected to the ethernet cable, the address does not work on putty.

Does anyone know why?

Cheers - Mark

Re: ip address

Posted: Sun Dec 07, 2014 9:04 pm
by Joe Schmoe
Sounds like "ifplugd" at work. IOW it's a feature - actually, a very bad mis-feature.

The solution is:

apt-get purge ifplugd

then reboot.

Re: ip address

Posted: Sun Dec 07, 2014 9:51 pm
by Bosse_B
every network adapter has its own unique hardware address, the MAC address. It is globally unique, too.
Whenever a router is connected to by a network adapter and asked to supply an IP address via DHCP it will note the MAC address in its database together with the IP address it supplies to the adapter.
This is in order for it to normally supply the same IP address the next time the same adapter connects.

Now, in your case you have two different network adapters, the WiFi and the Ethernet adapters and they have different MAC addresses. So the router will always supply different IP addresses to them. This is built into the networking system.

In fact the handing out of the same IP address every time an adapter connects is NOT certain, it depends on the router make for how long it will keep the old address memorized, so you might not even get the same address for the WiFi adapter every time.

This can be solved on the router by making what is called a "reservation" in the DHCP server section. A reservation ties together an IP address and a MAC address permanently and is therefore what you should do in your situation to ensure future address changes will not happen.
But WiFi and Ethernet will always get different addresses.

Re: ip address

Posted: Sun Dec 07, 2014 9:53 pm
by billybangleballs
I would edit /etc/network/interfaces and tell it what ip address to use.

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet static

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

That's what mine looks like and it's always at when connected by wired lan.

Re: ip address

Posted: Sun Dec 07, 2014 9:58 pm
by Bosse_B
But then the IP address selected MUST be outside of the DHCP address range used by the router!
Otherwise there may be an address conflict on the network at a later time and the connectivity is broken....

Re: ip address

Posted: Sun Dec 07, 2014 10:06 pm
by billybangleballs
I agree to a point Bosse_B.
I've never had dhcp give out an ip that was already active on the network but it may well be that I've just been lucky all my life.
But to be on the safe side, as you say, choose an address in the same subnet that is outside the pool used by dhcpd and that you are sure is not being used by anything else.

Re: ip address

Posted: Sun Dec 07, 2014 11:03 pm
by Bosse_B
On my routers I set aside about 80 addresses for DHCP hand-out.
My servers have static addresses in the low address range.
And then I have the odd extra unit, which connects through WiFi or Ethernet, where the address is set static too on the unit.
Of course one has to keep a separate book of these because they will not show up in the router's list of connections.
DHCP range:
Servers (static):, 11,12, 13, ...
WiFi gadgets (static):
Ethernet gadgets (static):
Extra space still available...

This works just fine but one has to keep tabs on what is going on.
I use a high 3rd address octet like 116 because I don't want to get address conflicts if I should connect back home via VPN from a WiFi network that uses the "default settings" present in many routers (192.168.0.x or 192.168.1.x).

Re: ip address

Posted: Mon Dec 08, 2014 11:45 am
by markjd
Thanks for all the advice. I'll give it a go tonight.