User avatar
Raspburrito
Posts: 3
Joined: Fri Sep 12, 2014 12:17 pm
Location: Chile

Unable to disable splash screen

Fri Sep 12, 2014 12:26 pm

Hi fellow Raspberrians,

I've been having some bad time trying to disable the splash screen on boot (actually, the 4 colour enlarged pixels).
I follow the instructions that are everywhere, changing the /boot/config.txt file as root, adding disable_splash=1, and nothing happens at all, it keeps showing up the pixels on boot.

I'm using Raspbian installed via the latest version of NOOBS, and for the record I still get other options to work by editing the file, like the screen rotation for example.

Am I doing something wrong? Or can the splash not be disabled any longer?
I used to love the way I could change (not too easy not too hard) features like this one, but It is kind of sad how I got stucked with it.

Thanks in advance for any help,
sudo mucho

User avatar
RaTTuS
Posts: 10532
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Unable to disable splash screen

Fri Sep 12, 2014 1:07 pm

have you edited the config.txt file in the correct location - if you are using noobs then it is the one in the recovery partition IIRC
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: Unable to disable splash screen

Fri Sep 12, 2014 4:05 pm

RaTTuS is right - there's a few very early-stage parameters in config.txt that are read by bootcode.bin, and the rest (the majority) that are read by start.elf. On NOOBS bootcode.bin is loaded (at power-on) from /dev/mmcblk0p1, and start.elf is loaded from the boot partition of your OS (typically /dev/mmcblk0p5).
So to control early-stage things like the splash-screen you need to edit the config.txt that is read by bootcode.bin, i.e. add a config.txt to /dev/mmcblk0p1 (the RECOVERY partition).

Alternatively, you could use autoboot.txt with NOOBS which also bypasses the coloured splash screen https://github.com/raspberrypi/noobs#ho ... -partition

PiGraham
Posts: 3717
Joined: Fri Jun 07, 2013 12:37 pm
Location: Waterlooville

Re: Unable to disable splash screen

Fri Sep 12, 2014 4:23 pm

Raspburrito wrote:Hi fellow Raspberrians,

I've been having some bad time trying to disable the splash screen on boot (actually, the 4 colour enlarged pixels).

Do you mean the 'rainbow screen'?
Image

I'm not sure if you can disable that with text file settings in /boot.

I don't think it displays on a Buildroot boot. I think it's produced by the GPU before it runs any Arm code.

User avatar
Raspburrito
Posts: 3
Joined: Fri Sep 12, 2014 12:17 pm
Location: Chile

Re: Unable to disable splash screen

Fri Sep 12, 2014 6:28 pm

AndrewS wrote:RaTTuS is right - there's a few very early-stage parameters in config.txt that are read by bootcode.bin, and the rest (the majority) that are read by start.elf. On NOOBS bootcode.bin is loaded (at power-on) from /dev/mmcblk0p1, and start.elf is loaded from the boot partition of your OS (typically /dev/mmcblk0p5).
So to control early-stage things like the splash-screen you need to edit the config.txt that is read by bootcode.bin, i.e. add a config.txt to /dev/mmcblk0p1 (the RECOVERY partition).

Alternatively, you could use autoboot.txt with NOOBS which also bypasses the coloured splash screen https://github.com/raspberrypi/noobs#ho ... -partition
Well no luck, I should have said I'm a total noob.
The only config.txt file I have access to is inside the /boot/. I found the /dev/mmcblk0p1 and it is a 'block device' I cannot seem to edit, at least not with my current knowledge, so I have no clue how to "add a config.txt to /dev/mmcblk0p1 (the RECOVERY partition)"...

I sadly had to work around the issue: installed Raspbian without NOOBS, now it works like a charm, simply add disable_splash=1 on /boot/config.txt, and done, the rainbow screen is gone (or black).

Thanks everyone,
sudo mucho

User avatar
cresfang
Posts: 37
Joined: Fri Apr 29, 2016 3:03 am
Location: Garden of Time
Contact: Website

Re: Unable to disable splash screen

Thu Jul 21, 2016 2:28 pm

If you wanna copy config.txt to NOOBS recovery partition, do this in terminal:

Code: Select all

cd /boot
sudo mkdir /media/recovery
sudo mount /dev/mmcblk0p1 /media/recovery/
sudo cp config.txt /media/recovery/
sudo reboot
VOILA! The splash is disabled this way.
The NOOBS's wiki using autoboot.txt didn't work for me.
Raspberry Pi 3

Return to “General discussion”