DracosTheBlack
Posts: 3
Joined: Thu Apr 10, 2014 9:36 pm

Mumble on Raspbmc Guide

Thu Apr 10, 2014 10:02 pm

Hello there I've been a lurker on these boards for a few months, and decided to make a post.

Let me know if its in the wrong area and we can move it. This can probably be applied to raspbian as well as raspbmc from my understanding they're very similar.

I had didn't have much trouble setting up Mumble but I did have trouble seeing it external to my network. The problem it turns out was that Verizon Fios doesn't support IPv6, and by default Raspbmc defaults to that. So this guide explains how to disable that and how to install mumble.

Raspbmc disable IPv6
---------------------------------
1.Comment out anything related to ipv6 in /etc/hosts
2.SSH. Ensure IPv6 is changed to IPv4 in the flags in /etc/xinetd.d/ssh.
3.NTP. Ensure -4 option is set in /etc/default/ntp (e.g. NTPD_OPTS='-4 -g').
4.RPCBIND (rpc.statd, rpc.mountd). Comment out the appropriate entries in /etc/netconfig:
udp tpi_clts v inet udp - -
tcp tpi_cots_ord v inet tcp - -
#udp6 tpi_clts v inet6 udp - -
#tcp6 tpi_cots_ord v inet6 tcp - -
rawip tpi_raw - inet - - -
local tpi_cots_ord - loopback - - -
unix tpi_cots_ord - loopback - - -
5.AVAHI. Set use-ipv6=no in /etc/avahi/avahi-daemon.conf.
6.REBOOT
7.Disable ipv6 in kernel:
echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf
8.Disable ipv6 in kernel modules (file /etc/modprobe.d/aliases.conf):
alias net-pf-10 off
alias ipv6 off
9.REBOOT
10.Verify IPv6 is diabled (output should have no IPv6 addresses):
netstat -tunlp



Install Mumble on Raspbmc
----------------------------------
1.Update the repositories with the latest packages.
sudo apt-get update
2.Next, install the application.
sudo apt-get install mumble-server
3.Fix Failed Install
edit the /etc/init.d/mumble-server file and remove the word dbus from the ends of the lines that say #required-start and #required stop then run insserv -v
4.Rerun install
sudo apt-get install mumble-server
5.Set host binding in /etc/mumble-server.ini
In the section "# Specific IP or hostname to bind to." add an entry for host=0.0.0.0
6.Set mumble to start on boot
update-rc.d mumble-server defaults
6.Run the configuration for the server.
sudo dpkg-reconfigure mumble-server
7.REBOOT

That's all it takes.

Hopefully that helps out, I see a lot of questions but no full guide.

Thanks,
Sean

DracosTheBlack
Posts: 3
Joined: Thu Apr 10, 2014 9:36 pm

Re: Mumble on Raspbmc Guide

Tue Apr 15, 2014 1:22 pm

Also in the XBMC settings you will have to go and disable its firewall.

nbe
Posts: 1
Joined: Sat Apr 19, 2014 7:34 pm

Re: Mumble on Raspbmc Guide

Sat Apr 19, 2014 7:55 pm

thanks for this guide, really useful!
worked perfectly for me.

i was forced to reinstall whole xbmc with my mumble server on.
The first time i had a lot of troubles getting it run, by configuring mumble to start automatically on boot with my awful linux skills.
And yeah, dont forget to disable firewall in raspbmc settings.... costs me 2 days to figure out why its not available outside my LAN.


i saw at installation that mumble is using OpenSSL 1.0.1e.... is it possible to update it?

DracosTheBlack
Posts: 3
Joined: Thu Apr 10, 2014 9:36 pm

Re: Mumble on Raspbmc Guide

Tue Apr 29, 2014 2:20 pm

I read this on the mumble blog hope it helps.

http://blog.mumble.info/mumble-and-heartbleed/

Return to “General discussion”