jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23682
Joined: Sat Jul 30, 2011 7:41 pm

Re: Stellarium Progress

Sat Sep 10, 2011 9:16 am

I've been trying to find time to rebuild Stellarium with Open GL ES support so I get some OpenGL acceleration on the Raspi - using the Debian repo version the frame rate is unusable.

So, after lots of downloading of libraries etc I have managed to recompile it (on the Raspi itself). It uses a combination of gcc, g++, boost libs, QT etc, and the build went without issue after mods to the CMake setup to add a Raspi version.

It did however, take a very (very) long time. Over 5hrs to rebuild completely. I need to cross check the compile time for X86 on my desktop, but something seems awry. CPU was full tilt the whole time.

And the end result - same speed as the Debian repos. Grr. So it's still not using the Open GL ES libraries (I don't think), but I am not sure why not.

However, although the end result isn't what I had hoped, the fact that I was able to download all the dev libraries, make minor mods to the make, and it all built on the Raspi itself with no problem is very reassuring.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

User avatar
liz
Raspberry Pi Foundation Employee & Forum Moderator
Raspberry Pi Foundation Employee & Forum Moderator
Posts: 5201
Joined: Thu Jul 28, 2011 7:22 pm
Contact: Website

Re: Stellarium Progress

Sat Sep 10, 2011 4:22 pm

Rats, and…a bit less rats. Mice, perhaps. Thanks very much for keeping us updated - and please apologise to Mrs H for us for taking up your weekend!
Director of Communications, Raspberry Pi

darethehair
Posts: 8
Joined: Mon Dec 05, 2011 9:41 pm
Contact: Website

Re: Stellarium Progress

Mon Dec 05, 2011 11:27 pm

Intriguing! Any updated progress report on this effort? Optimism that it is 'just a matter of time' before this works as desired?

obarthelemy
Posts: 1399
Joined: Tue Aug 09, 2011 10:53 pm

Re: Stellarium Progress

Mon Dec 05, 2011 11:32 pm

It's cool to see work already in progress :-)

radu
Posts: 110
Joined: Mon Nov 21, 2011 8:19 pm

Re: Stellarium Progress

Tue Dec 06, 2011 1:28 am

The Debian version you were trying to use was built for OpenGL ES, right? What frame rate did you get? Less than 1 FPS?
Did you try to run top or something and see how much of the cpu was being used while running?

Return to “General discussion”