User avatar
Posts: 357
Joined: Sat May 26, 2012 6:40 am
Location: UK
Contact: Website

Re: I have no idea how to use this thing!

Wed Jun 27, 2012 12:16 pm

Hi Burngate,

If your still having problems setting up a static IP address, take yourself to this blog, it will go some way to describe how to set this up. ... dress.html

Keep on it, the learning should be the fun bit!

Burngate wrote:OK
So first today we're going to try to sort the screen.
1) config.txt, put in disable_overscan=1 ... no different
2) I wonder if the monitor is doing something odd? Menu > Feature > HDMI PC Full Mode > change to on?
... Yey! It's still muzzy, but I can see the Raspberry top left!
3) Lots of other prattings, no further forward, give up on that for the moment

What about the network - static IP
Let's look at the man
Yeah, lots of good stuff, but not entirely clear! I think I should be able to just change "iface eth0 inet dhcp" to something like "iface eth0 static" but something like is not as good as perfection.
So first, how about the examples?
Found /usr/share/doc/ifupdown/examples/network-interfaces.gz
Is that an archive? (flaps around in the dark) open with ... Xarchiver? sounds good. Yeah. Inside it is ... wait for it ... network-interfaces! Easiest thing would be extract it.
"Can't perform extraction! You don't have the right permission to extract the files to the directory ... " WHY NOT? For G's sake where else should it go? In fact why was it zipped in the first place! And why should anyone NEED permission - it's only a set of examples for G's sake!
I'm rapidly getting p'd off with this security malarkey. It's MY computer. I can do what I want!
TO-DO give myself full permissions to everything.
OK extract to /home/pi. That worked! TO-DO put the extracted file back where it belongs!
Now back to /etc/network/interfaces (why isn't the file manager putting the folders - sorry directories - in alpha order?)
Yeah, so infact it seems it should be:
iface eth0 inet static
(Why do we need the network statement? isn't that obvious from address and mask? or am I missing something?)
Let's try it!
Open the file with leafpad, edit it, save it ... "'interfaces' already exists - overwrite?" Naturally!

That's what I'm trying to do! ... "Can't open to write" ... to be expected. Why does this HAVE to be so DIFFICULT!
Finding stuff out, learning, is fun. Doing things is fun. Having it piss in my face isn't.
Coffee time

One place I worked, the night-man left a note in the log:
"I'm sorry to say I got so annoyed I took the large hammer to the computer. My resignation is on your desk"
"am I getting slower, or is stuff more complicated; either way I now have to write it down -"

Posts: 31
Joined: Sun Jun 10, 2012 8:10 am

Re: I have no idea how to use this thing!

Mon Jul 02, 2012 7:16 am

Burngate wrote:Thanks andyl :)
The coffee cooled me down
I'm just seeing it from the noob's point of view - since I am a noob.
I'm well aware that I should do it a superuser - I'm also lazy. But your average 15-year-old is likely to not want all the hassles.
But I just thought a blow-by-blow of my journey through life might amuse some of the experts here.
I'm finding the blow by blow entertaining. I haven't really considered myself proficient with linux, but the setbacks do become less frustrating the more I go through them.

Return to “General discussion”