Argus
Posts: 1
Joined: Sat May 26, 2012 6:34 pm

Getting Started

Sat May 26, 2012 8:59 pm

My first experience of the Raspberry Pi
I had prepared for the Pi by having ready a USB keyboard, mouse, HDMI lead, powered USB hub and a 5v 1A mini-USB power supply, and by following the admirable instructions in the “Getting Started” document to download the latest Debian and copy it onto a 4GB SD card.
The Pi arrived. I should explain at this point about myself – I more or less know what I am doing with Windows (programming in Delphi and Visual Studio, etc.) but have no experience of Linux at all.
I connected the mouse and keyboard directly to the Pi, inserted the SD card, connected the Pi to my Samsung TV using the HDMI lead, inserted the mini-USB lead and switched on.
(This is a success story, but it might be useful for others to know what sort of problems one may encounter on the way.)
1) The red light on the PI came on and the yellow one blinked, but the TV screen only displayed a message saying that I should check the cable.
2) I have another HDMI cable, so I tried that - same result.
3) I tested the two cables by using them to connect another computer to the TV. The first was indeed faulty, but the second one was fine.
4) I also had a yellow-to-yellow composite lead, so I used that. Now I could see text on the screen, ending with message announcing Debian 6.0, but apparently no invitation to log in.
5) The message was right at the bottom of the screen, and I guessed that the login prompt was perhaps below and out of sight, so I typed the username “pi” and pressed Enter. Yes – a request for a password appeared, but when I entered the password “suse” (as instructed in “Getting Started”), I was told that this was incorrect.
6) I experimented with typing longer things for the username (to test the keyboard) and found that the connection was unreliable – some characters in what I typed were skipped.
7) After brief thoughts about perhaps having to get another keyboard, I tried connecting it through the powered hub. Now the keyboard worked reliably – it is clearly not adequate to connect directly to the Pi (at least, with my keyboard it isn’t.)
8) Although I was now sure that the keyboard was working well, I still got the message “incorrect password.” I tried internet searches for “Raspberry Pi login problems” etc, without getting anywhere, until I registered and looked for help in the FAQs etc. One person who had had the same difficulty had been typing a password “raspery” and was advised that the correct spelling was “raspberry”, so I tried that. It worked!!! The password wasn’t “suse”at all.
9) After that, startx got me well under way, although because the panel of icons was half-concealed at the bottom of the screen I had to experiment quite a bit to find how to enlarge it so that it was usable.
10) I still have one other problem (which I haven’t solved) – I don’t know what to use as the administrator’s password – it’s not “raspberry”, and it’s not “suse” either. And I still can't get an HDMI connection to work to my TV.

JohnCrow
Posts: 25
Joined: Fri May 25, 2012 5:28 pm
Location: Lincolnshire

Re: Getting Started

Sun May 27, 2012 6:41 pm

Im also unable to find the admin password.(Debian)

The normal login password was changed from suse to raspberry, and this is detailed in the getting started documents.
As for the display, Im using a VGA TFT screen (1280x1024) with this adaptor.

http://www.amazon.co.uk/gp/product/B007QT0NNW

I find it works perfectly, picks up the correct resolution automatically.
A lot cheaper than having to replace a perfectly good monitor.
1 in 10 people understand binary, the other one doesn't

User avatar
Midnight Caller
Posts: 28
Joined: Sat Feb 11, 2012 9:54 pm
Location: UK
Contact: Website

Re: Getting Started

Sun May 27, 2012 11:58 pm

@JohnCrow, Thank you for the link, I just bought: 'KanaaN HDMI to VGA Adapter Converter | KanaaN HDM, from Amazon UK £20.99 with Free P&P
Please remember that I am Dyslexic wen replying

AAK
Posts: 6
Joined: Wed May 30, 2012 12:23 pm

Re: Getting Started

Wed May 30, 2012 12:34 pm

Maybe this will help:
If you do not have an english keyboard (like me) than you should try to type "raspberrz" (wihtout ") since the Z and Y keys are switched on some keyboards. It did work for me.

bredman
Posts: 1415
Joined: Tue Jan 17, 2012 2:38 pm

Re: Getting Started

Wed May 30, 2012 1:10 pm

If you want administrator access (like Run as Administrator in Windows) you should put sudo at the beginning of the command. For example to set today's date/time use the command
sudo date 05301410

Note also that there is a bug in the password handling, see the fix at
http://elinux.org/R-Pi_Troubleshooting# ... y_password

Return to “General discussion”