prairietech
Posts: 28
Joined: Wed Mar 20, 2013 9:22 pm

Can't Copy & Paste to Raspberry

Tue Oct 22, 2013 12:02 am

I am unable to copy and paste code from a web page on my Windows 7 computer to my Raspberry.
Accessing the Pi via VNC to a terminal window on the Pi.
I've tried the mouse copy / paste and also the keyboard copy / paste. Neither works.
Tried to paste text from the Raspberry to Notepad on the W7 computer and that doesn't work either.
What am I missing?

klricks
Posts: 6550
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Can't Copy & Paste to Raspberry

Tue Oct 22, 2013 1:58 am

I have not been able C&P as well. Both systems act independently as they probably should.
I have resorted to other options like:
- Bringing up the web browser on the RPi (using XRDP)
- Email to myself using a web based email client
- Save as text file in notepad and move the files through a network share.
- etc

Be careful with C&P from web pages. Sometimes they have hidden characters embedded which will generate errors in a script or config file. I once did a C&P from a web page and had to edit the file and manually delete all the white spaces and blank lines before the config file would work properly.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

User avatar
blachanc
Posts: 456
Joined: Sat Jan 26, 2013 5:03 am
Location: Quebec,canada(french)

Re: Can't Copy & Paste to Raspberry

Tue Oct 22, 2013 2:57 am

maybe this could work for you:

the way I do it:

copy whatever text into a text document opened in notepad++,
select the text to paste in notepad++
right click in a putty window.
http://www.putty.org

ben
Autism/Asperger syndrome: what is your score on this quiz?
http://www.raspberrypi.org/forums/viewtopic.php?f=62&t=70191

Return to “General discussion”