coolblue2000
Posts: 30
Joined: Tue Jan 08, 2013 9:48 am

Start Surf browser in kiosk mode

Wed Sep 04, 2013 2:02 pm

I am trying to start the Surf browser in kiosk mode.

The following help file describes how to do it
http://surf.suckless.org/files/kiosk_mode

however using -k as a parameter does not appear to work when started from /etc/xdg/lxsession/LXDE/autostart

@surf -k www.mysite.com

If I take the -k parameter out it works fine with it in the browser simply never boots up.

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: Start Surf browser in kiosk mode

Wed Sep 04, 2013 6:00 pm

Did you try testing your command line in a terminal window to see if it gave any error messages? :roll:
When I try running "surf -k http://www.mysite.com" from a terminal window on Raspbian, it says:

Code: Select all

surf - simple browser
usage: surf [-e xid] [-i] [-p] [-s] [-v] [-x] [uri]
i.e. it doesn't recognise the -k option, so it tells you what options it does support.
"dpkg -l surf" says it's installed version 0.4.1, whereas http://surf.suckless.org/ says the latest version is 0.6

So I guess you'll either have to compile surf from source, or you could look at some of the other many http://www.raspberrypi.org/phpBB3/searc ... kiosk+mode threads.

Return to “General discussion”