coolblue2000
Posts: 30
Joined: Tue Jan 08, 2013 9:48 am

Best way to start chromium at startup in kiosk mode

Mon Aug 26, 2013 1:00 pm

I have a raspberry pi running raspbian with the view to running a shop display. However I currently start chromium with the following line in the .profile file xinit /usr/bin/chromium --kiosk --incognito www.myweb.com.

The problem is that it seems when started this way, there is no way to prevent the screen from blanking after about 10-15 mins. So is there a better place to start chromium in order for there to be a way to prevent the screen from going blank?

We are looking to buy about 400 PIs for this project and it all hinges on whether we can prevent the screen from going blank.

stephencassidy
Posts: 37
Joined: Mon Aug 19, 2013 11:12 am

Re: Best way to start chromium at startup in kiosk mode

Mon Aug 26, 2013 4:24 pm

Hi, I seem to remember having the same issues when setting up our pi's for system monitoring. I had a quick look through my pi notes and I think this is how I solved the issue.

Edit the file

/etc/lightdm/lightdm.conf (about line 58)

in the SeatDefaults section it gives the command for starting the X server which I modified to get it to turn off the screen saver as well as dpms

[SeatDefaults]
xserver-command=X -s 0 -dpms

Hope this helps

ste

coolblue2000
Posts: 30
Joined: Tue Jan 08, 2013 9:48 am

Re: Best way to start chromium at startup in kiosk mode

Mon Aug 26, 2013 9:09 pm

@stephencassidy

I have already tried that, however it did not prevent the screen from blanking. I can stop the screen blanking when running the raspbian gui but when chromium is running in kiosk mode outside of the gui nothing appears to work. I have repeatedly tried different configurations etc but nothing seems to work.

Oakham
Posts: 366
Joined: Tue Aug 20, 2013 9:11 pm

Re: Best way to start chromium at startup in kiosk mode

Mon Aug 26, 2013 9:39 pm

coolblue2000 wrote:@stephencassidy

I have already tried that, however it did not prevent the screen from blanking. I can stop the screen blanking when running the raspbian gui but when chromium is running in kiosk mode outside of the gui nothing appears to work. I have repeatedly tried different configurations etc but nothing seems to work.
This page mentions screen blanking https://github.com/MobilityLab/TransitS ... spberry-Pi
Searching is easy, most questions have been asked before !

Return to “General discussion”