coolblue2000
Posts: 30
Joined: Tue Jan 08, 2013 9:48 am

How to Disable screen blanking for chromium in kiosk mode

Fri Aug 16, 2013 3:47 pm

I am running Raspbian, and I am using this as a display device for a TV in a retail centre. I run Chromium on startup with this line in .profile:
xinit /usr/bin/chromium --kiosk --incognito www.mysite.com

...however none of the solutions to disable screen blanking seem to work (although they do work if I am in the Raspbian GUI). It is quite important (as you can imagine) that the display screen does not go blank.

Does anyone have any solutions to this?

I have tried the following:

setting the xinitrc file as in this example http://raspberrypi.stackexchange.com/qu ... n-raspbian

setting exec /usr/bin/X -s 0 dpms -nolisten tcp "$@" in xserverrc

setting blank timeouts in /etc/kbd/config

setting /etc/lightdm/lightdm.conf with the following line: xserver-command=X -s 0 dpms

non of the above have worked

I have noticed a possible solution which entails installing xscreensaver then disabling it but I do not know how to make it run on startup.

User avatar
ddxfish
Posts: 75
Joined: Wed Aug 07, 2013 5:17 pm
Location: Florida
Contact: Website AOL

Re: How to Disable screen blanking for chromium in kiosk mod

Fri Aug 16, 2013 7:50 pm

You are changing the screen blanking based on a startup script for X. Your screensaver command will only run when you start X.

Change it for command line:
nano /etc/kbd/config

Change screen blank time to 0 (disable) and also screensaver to False.

This stops blanking while in command line only on Raspbian for me.

Source:
http://www.etcwiki.org/wiki/Disable_scr ... spberry_Pi
My Pi Guides: http://www.etcwiki.org/wiki/Category:Raspberry_Pi
My AIM screen name: ddxfish
Always happy to chat about the Pi!

coolblue2000
Posts: 30
Joined: Tue Jan 08, 2013 9:48 am

Re: How to Disable screen blanking for chromium in kiosk mod

Sun Aug 25, 2013 9:15 am

changing /etc/kbd/config does not stop the screen blanking in chromium for me. I have also read many posts that also claim that this does not work for them either. The xscreensaver solution seems to be the only thing that works..... but I just need to be able to start xscreensaver before chromium starts. no idea how to do this though.....


Is this a bug in chromium or raspbian?

Return to “General discussion”