Page 1 of 1

Analog Audio Clicking

Posted: Sun Jul 21, 2013 9:00 pm
by PipeMasta5000
Hello everyone!

I'm having an issue with the analog audio output on my RPi when using pyomxplayer. When I play, stop, or change chapters during playback I get a series of clicking noises from the speakers. There's a single click when I play the video, three or four for other options (stop, prev. chap, etc) I get the feeling there's a minor build-up on the audio cable, but I've attempted bridging the common wire on the audio cable with a resistor to absorb this excess power, and I tried completely grounding the common lead... both without success.

I'm using this RPi with a variety of other electronics (through GPIO), so there are a large number of other variables involved... but I'm hoping that this problem is isolated to the RPi itself. Has anyone else experienced similar clicking noises when starting and stopping analog audio playback?

Thank you all for your help.

**PM5000

Re: Analog Audio Clicking

Posted: Mon Jul 22, 2013 2:46 am
by prairietech
I can't repeat the exact cause but the clicking is from the output circuit in the RPi being turned off and on between playback functions.

I just completed a Pandora's Box project and was extremely disappointed with the annoying clicking between songs using the RPi's audio output. Using an HDMI to VGA adapter, I connected my speakers to the stereo output of the adapter and the clicking was gone.

Re: Analog Audio Clicking

Posted: Mon Jul 22, 2013 5:12 am
by FM81
PipeMasta5000 wrote:but I'm hoping that this problem is isolated to the RPi itself.
Only related to it's analog output, never on HDMI and never on my USB-soundcard (using analog out too).
PipeMasta5000 wrote:Has anyone else experienced similar clicking noises when starting and stopping analog audio playback?
Yes, but strong "clicks" only in the past; wasn't this fixed some versions ago? Do you use an old version?
With actual it should work as good as such PWM can - not perfect, but useful in some (most?) cases.

MfG, FM_81

Re: Analog Audio Clicking

Posted: Mon Jul 22, 2013 5:56 am
by KenT
This was fixed a few months ago. IIRC it was a firmware fix by Dom. I also think the firmware fix has now migrated (in Raspbian) from rpi-update to sudo apt-get upgrade.

there is still a click when the audio is started up but you should not get it between tracks.