iero
Posts: 5
Joined: Thu Jul 04, 2013 12:54 pm

Oregonscientific LW301 weather station

Mon Jul 08, 2013 9:27 am

Hello all,

I try to get data from a Oregon LW301 weather station. This station (see attached) can get sensor information with a RF 433MHz receiver, connected with USB to a little box that translate and send to an oregon server this data using TCP/HTTP protocol (ethernet link). The product is good and works well as designed by Oregon. But it will be great to improve the system using a RPI to get data and share to other weather services, blogs, etc.. And for a domotiga system too.
LW301-how.jpg
LW301-how.jpg (34.72 KiB) Viewed 12814 times
I tried to plug the 433MHz receiver to RPI without succes. I thought it was a "not enough power" problem, but I had the same problem using a AC powered hub or a Y usb cable with red USB plug in a power plug. So, I cannot how to resolve this problem. The problem is detailed here :

http://www.raspberrypi.org/phpBB3/viewt ... 28&t=49050

Another option could be to plug the ethernet port to RPI and read ethernet data. It will be more complex (using routing tables and dedicated apache server) but it is possible.
Another option would be to get a 433MHz receiver and try to decode data directly from sensors. But I don't want to buy something 3 times the price of the RPI !

Any idea how to connect this Oregon weather station to raspberry ?

Have a nice and shiny day

klricks
Posts: 7288
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Oregonscientific LW301 weather station

Mon Jul 08, 2013 12:49 pm

Does the RF receiver require any special USB driver installation in order to function on the PC? If so are there any linux drivers available? You might want to address your issues with Oregon tech support or an Oregon forum.
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

iero
Posts: 5
Joined: Thu Jul 04, 2013 12:54 pm

Re: Oregonscientific LW301 weather station

Mon Jul 08, 2013 1:45 pm

Hello

Oregon doesn't support this type of testing ! They want you to use the product as they design it..

I found a google code project :
http://code.google.com/p/wmr/

They tested LW301 with linux box with success without any usb driver.

And the '-32' error doesn't seems to be related to drivers problem ?

Best regards

willz1200
Posts: 5
Joined: Sun Dec 02, 2012 3:33 pm

Re: Oregonscientific LW301 weather station

Mon Jul 08, 2013 6:54 pm

I am using rf to control relay and stuff and I have these http://www.ebay.co.uk/itm/271165830803 wired into the gpio of the pi and they work a treat!

iero
Posts: 5
Joined: Thu Jul 04, 2013 12:54 pm

Re: Oregonscientific LW301 weather station

Mon Jul 08, 2013 8:37 pm

Hello

Can you give me more information about your GPIO device ?

I got a "Unfortunately, access to this particular item has been blocked due to legal restrictions in some countries. (...) Please accept our apologies for any inconvenience this may cause, and we hope you may find other items of interest on eBay"

I opened the LW301 box and i found a PIC18F97J60 controler. See picture :
photo.JPG
photo.JPG (57.69 KiB) Viewed 12732 times

willz1200
Posts: 5
Joined: Sun Dec 02, 2012 3:33 pm

Re: Oregonscientific LW301 weather station

Wed Jul 10, 2013 10:24 pm

The transmitter is on pin 11 (GPIO 17) and the receiver is on pin 13 (GPIO 21) and they both run at 5v.

Here is the eBay title in full: RF Wireless Transmitter and Receiver Link Kit Module 433Mhz for Remote Control

I'll upload some pictures when I get the chance.

klricks
Posts: 7288
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Oregonscientific LW301 weather station

Wed Jul 10, 2013 11:48 pm

willz1200 wrote:The transmitter is on pin 11 (GPIO 17) and the receiver is on pin 13 (GPIO 21) and they both run at 5v.

Here is the eBay title in full: RF Wireless Transmitter and Receiver Link Kit Module 433Mhz for Remote Control

I'll upload some pictures when I get the chance.
You can't connect 5V logic directly to the RPi GPIO pins. It must be 3.3V logic or you need to use a level converter.
http://www.amazon.com/SparkFun-Logic-Le ... +converter
Unless specified otherwise my response is based on the latest and fully updated RPiOS Buster w/ Desktop OS.

bmjbmj
Posts: 2
Joined: Tue Apr 08, 2014 10:46 am

Re: Oregonscientific LW301 weather station

Tue Apr 08, 2014 11:04 am

Did you ever get a solution to this problem?
I have tested both on the R.Pi and on an laptop running Kubuntu 12.04.4 and no USB enumeration.

I have tried with:
500mA off power
http://www.geekdevs.com/2010/04/solved- ... -ehci_hcd/
modprobe -r ehci_hcd

It is possible to PIC18F97J60 micro-controller has a software error (not conform to the USB standard), but it appears according to the tests carried out by http://code.google.com/p/wmr/ that some Linux systems can handle the 'error' ???

iero
Posts: 5
Joined: Thu Jul 04, 2013 12:54 pm

Re: Oregonscientific LW301 weather station

Tue Apr 08, 2014 8:14 pm

In fact, I plugged the ethernet cable from the LW301 station to the RPI.

And I've configured an apache server to receive all data sent by the station. It works great.

bmjbmj
Posts: 2
Joined: Tue Apr 08, 2014 10:46 am

Re: Oregonscientific LW301 weather station

Wed Apr 09, 2014 7:27 am

Interesting! How do you do it?

I'm guessing that you configure R.Pi to give the station a fixed IP address (based on its MAC). There after, you will do something with the etc/hosts file so that 'http://www.osanywhereweather.com' points to lochalhost instead of the actual IP address.

I have not used wireshark to analyze traffic from the station but I guess it sends HTML request like xxxxx.com /? Name1 = value1 & name2 = value2. Are you using PHP to collect and answer these? Does the station expect other answers than HTTP/1.1 200 OK?

Since I'm lazy :oops: and do not like to reinvent the wheel, I wonder if you would care to share your config files with the rest of us here on the forum?

steveathon
Posts: 1
Joined: Wed Oct 01, 2014 1:46 am

Re: Oregonscientific LW301 weather station

Wed Oct 01, 2014 1:51 am

willz1200 wrote:The transmitter is on pin 11 (GPIO 17) and the receiver is on pin 13 (GPIO 21) and they both run at 5v.

Here is the eBay title in full: RF Wireless Transmitter and Receiver Link Kit Module 433Mhz for Remote Control

I'll upload some pictures when I get the chance.
Can you post up the wiring? Also, are you receiving into python or something else? Any chance you can share a demo of your code?

killerekpl
Posts: 1
Joined: Tue Dec 30, 2014 2:50 pm

Re: Oregonscientific LW301 weather station

Tue Dec 30, 2014 2:52 pm

iero wrote:In fact, I plugged the ethernet cable from the LW301 station to the RPI.

And I've configured an apache server to receive all data sent by the station. It works great.
Can you tell how you configure the apache server to receive the data from LW301? It would be very helpful.

didierheck
Posts: 1
Joined: Sat Jun 20, 2015 12:46 pm

Re: Oregonscientific LW301 weather station

Sat Jun 20, 2015 12:51 pm

Hi,

Could someone share the details on how to finally take advantage of the LW301 on a Raspberry Pi ?
Thanks in advance.

DDA

incidentals
Posts: 8
Joined: Tue Sep 25, 2012 8:32 pm

Re: Oregonscientific LW301 weather station

Fri Apr 22, 2016 8:39 pm

if you are still interested you can get to the live page through html using a script to put username and password and then press button.

if you only have a single weather station it will be displayed and you can scrape the page for data.

you can use vba or python or even php to get the textboxes filled and get the stuff available.

we have not yet managed to view a second weather station through the second page!

but we are a little further

dcnicholls
Posts: 3
Joined: Thu Nov 03, 2016 12:08 pm

Re: Oregonscientific LW301 weather station

Thu Apr 05, 2018 12:09 pm

If you are still interested you can get to the live page through html using a script to put username and password and then press button.

Can you post the code you use to log in to the osanywhereweather.com site, in order to access the data page? I have not managed to do this yet.

Thanks

Return to “General discussion”