User avatar
KronosPi
Posts: 5
Joined: Sun Feb 03, 2013 5:22 pm

Need help running Huawei E1731 using ppp

Sat Jun 08, 2013 8:17 pm

Hey,
I have a 3G USB dongle, Huawei E1731 and my service provider is airtel, (India) and I wanted a simple way to use it directly with my RasPi. I followed

http://saurorja.org/2013/03/30/airtel-3 ... ete-guide/

as a reference to set up the modem on my Pi, I even made sure all my files, /etc/chatscripts/airtel ; /etc/ppp/pap-secrets ; /etc/ppp/peers/airtel were identical to the ones on the website.

However, the main problem that I'm facing is that, as soon as I connect my modem to the USB port on my RasPi, in the /dev folder, ttyUSB0 isn't being created, the files that do get created, are /dev/cdrom1 and /dev/sr0, so I tried using that as my
"Manually selected modem port" in the pppconfig file, but every time I try switching it on using sudo pon airtel, I get

/usr/sbin/pppd: In file /etc/ppp/peers/airtel: unrecognized option '/dev/ttyUSB0' (when I've set /dev/ttyUSB0 as my modem port)
or
/usr/sbin/pppd: In file /etc/ppp/peers/airtel: unrecognized option '/dev/sr0'

I did try to google quite a bit, but could'nt find anything comprehensive or workable.. :? Any suggestions?

P.S. I tried it with a powered USB hub as well, same results :\

User avatar
KronosPi
Posts: 5
Joined: Sun Feb 03, 2013 5:22 pm

Re: Need help running Huawei E1731 using ppp

Sat Jun 08, 2013 10:13 pm

Umm, Sorry for bothering but just found out the solution, apparently the Pi detects the dongle as a CD-Drive to install the GUI software/drivers, switched mode to modem and it works :D Thought I'd post so that it might help some poor soul in the future with the same issue :mrgreen:

sudo apt-get install usb-modeswitch

and then
sudo nano /etc/modules

added line:
usbserial vendor=0x12d1 product=0x1446

then reboot, and /dev/ttyUSB0 appears, set that as modem port in pppconfig, restart and done! Use sudo pon airtel, sudo poff airtel to use :)

source:
http://www.geekride.com/huawei-e173-on-ubuntu/

Please close the thread, if there is such a thing, *forum n00b* :?

fr0zen
Posts: 6
Joined: Sat Dec 21, 2013 9:19 pm

Re: Need help running Huawei E1731 using ppp

Tue Mar 25, 2014 2:00 am

Thanks KronosPi for posting the working config! I had exactly the same problem.

User avatar
KronosPi
Posts: 5
Joined: Sun Feb 03, 2013 5:22 pm

Re: Need help running Huawei E1731 using ppp

Tue Mar 25, 2014 3:51 pm

No problem ! Glad to be of service :D

Return to “General discussion”