Page 1 of 1

nfs mount timeout solved

Posted: Mon May 27, 2013 5:34 am
by unclejed613
while trying to mount a nfs share on my pi, so i can serve video files on my pi's web server, i kept getting timeout errors.... something i'm slowly figuring out (after 10 years as a linux user) is that options like -v (verbose) are built into just about everything linux. so i tried this with the mount command to see if i could get a clue what the major malfunction was.

Code: Select all

[email protected]:/home/pi# mount -v linbox:/share /var/www/htdocs/vidtest/share
mount: no type was given - I'll assume nfs because of the colon
mount.nfs: timeout set for Sun May 26 22:51:14 2013
mount.nfs: trying text-based options 'vers=4,addr=,clientaddr='
mount.nfs: mount(2): Connection timed out
mount.nfs: Connection timed out
[email protected]:/home/pi# 
the best clue to what was causing the timeout was the bogus ip address "".

putting the following line in /etc/hosts:

Code: Select all         linbox
fixed the problem.

since there have been a lot of people having trouble loading shares from NAS drives, etc... i thought this info might help a lot of people.

Re: nfs mount timeout solved

Posted: Mon May 27, 2013 5:49 am
by Heater
I have been using :

Code: Select all

mount -t nfs4    /mnt/nfs
Of course it's better to use a host name.

I just used this while compiling a GCC crosscompiler on the Pi with the source and build directories on the share. So that gave it a 13 hour long shake down. Works a treat.

Re: nfs mount timeout solved

Posted: Tue May 28, 2013 1:19 am
by unclejed613
well, so far after almost 24 in operation it seems to be working fine. when i test the video play through the pi's vpn/web connection, it usually plays ok, but bogs down once in a while. i think the reason for this is the video is traveling twice through the ethernet port on the main machine, and twice through the port on the pi, and twice through the router, as well as out to the vpn network and back( and sometimes vpn connections are a bit slow). the pi shows upload speeds of between 100-400kb/s on the vpn connection, so, going both directions, that must be hitting the dsl modem pretty hard... the videos are encoded for 128k, which usually works pretty well. the difference between testing it here and somebody else watching is the data only travels one way through my machine and the router, and still twice on the pi...matter of fact somebody's visiting the pi right now and it's chugging along pretty smoothly