milesma
Posts: 7
Joined: Fri May 24, 2013 3:57 pm

[Solved] fail on kindleberry pi's setting

Fri May 24, 2013 4:13 pm

Hi guys,
I'm following this link:
http://projectdp.wordpress.com/2012/09/ ... pberry-pi/

I've done smoothly step 1~4.
Basically, on step "5.0 Pi: Boot into your kindle user’s account on tty1 -auto"
I can not sort it out by either "1:2345:respawn:/sbin/agetty -a kindle -8 -s tty1 linux" or " 1:2345:respawn:/bin/login -f kindle tty1</dev/tty1>/dev/tty1 2>&1"

And in step "5.2 Pi: Configure ssh passwordless logins – auto", I don't have a folder as described " cd /home/kindle/.ssh/" (the last .ssh is not there).

So any suggestions?
Or anyone know what step 5's script mean?

Thank you
Last edited by milesma on Sat May 25, 2013 3:48 am, edited 1 time in total.

User avatar
pluggy
Posts: 3636
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
Contact: Website

Re: fail on kindleberry pi's setting

Fri May 24, 2013 6:20 pm

the .ssh folder is created when you first use the ssh command to connect to a remote machine. You could try making the folder by hand beforehand

If you're logged into the pi as the kindle user its just

Code: Select all

cd ~
mkdir .ssh
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......

milesma
Posts: 7
Joined: Fri May 24, 2013 3:57 pm

Re: fail on kindleberry pi's setting

Sat May 25, 2013 3:48 am

Thanks Guys. The problem is solved.
Basically, the following script works for me.

1:2345:respawn:/sbin/agetty -a kindle -8 -s tty1 linux

The thing I've missed is a setting to disable log into xwindow directly.
After use raspi-config to change this option, all good! I can use kindle as a sole display now.

Return to “General discussion”

Who is online

Users browsing this forum: Aydan, BooX, chrisoh, furball, Heater and 58 guests