mm1804
Posts: 4
Joined: Sun Jul 15, 2012 2:54 pm

Re: A 5$ 1.5

Sat Oct 06, 2012 4:31 pm

I tried several times to get this working (pearl DPF @ Raspberry PI) but all of the howtos are not working/ have errors in the steps and so on. Can somebody post a real working one or can upload a working image somewhere?

Thanks a lot!
MM1804

ax206geek
Posts: 52
Joined: Sat Jun 16, 2012 2:55 pm

Re: A 5$ 1.5

Mon Oct 08, 2012 11:54 am

There's duplication of thread: http://www.raspberrypi.org/phpBB3/viewt ... =64&t=6688

http://forum.doozan.com/read.php?9,8553 has some of the firmware. But a major upgrade is coming soon.


bentech4u
Posts: 5
Joined: Sun May 25, 2014 5:17 am
Contact: Website

Re: A 5$ 1.5

Sun May 25, 2014 5:39 am

guidol wrote:
cougarten wrote:Quote from magnitux on August 22, 2011, 16:58
this lcd 2.4 screen is compatible with lcd4linux on debian(seagate dockstart)
http://www.pearl.de/a-HPM1184-5618.shtml
good german tutorial on this (also how to buy): http://geekparadise.de/2011/04.....-dockstar/
Today I took this tutorial above and did go through it with a Raspberry Pi under Raspbian Wheezy.
After installing some replacement-packages, I could compile lcd4linux with dpf support on the Raspberry.
I patched the Display firmware with the windows-tool from http://www.vdr-portal.de/board18-vdr-ha ... ost1032264
The display-Firmware-Package (Portrait and Landscape) is at http://dl.dropbox.com/u/64770380/Pearl% ... rmware.zip

Perhaps, the actual lcd4linux-version via 'apt-get install lcd4linux' is already supporting the DPF-Display?
But the Homepage of LCD4Linux states about that:
http://ssl.bulix.org/projects/lcd4linux/wiki/DPF
Requirements
To build this driver you need libdpf. But it isn't online at this moment.


Here is a blog about what I did in german:
http://lehwalder.wordpress.com/2012/07/ ... an-wheezy/

And here are 2 pictures for you from the display and my Raspberry :)
Image
Image

The command-lines I did use:

Code: Select all

apt-get install libtool automake1.10 autoconf zlib1g-dev libssl-dev python-dev libc6 libusb-dev libibus-1.0-dev subversion libgd2-noxpm-dev libgd2-noxpm –fix-missing
(apt-get install sdcc-libraries)
apt-get install cc1111
wget http://tech.section5.ch/files/dpfhack-0.1alpha.tgz
tar -xvzf dpfhack-0.1alpha.tgz
cd dpf/src
make
cd ..
wget http://tech.section5.ch/files/dpf-lcd4linux.tgz
tar -xvzf dpf-lcd4linux.tgz
cd dpf
vi build-dpf-lcd4linux.sh
./build-dpf-lcd4linux.sh ../src/dpflib/
cd lcd4linux
make install

HI

i have a hacked st2205u based picture frame. It was working with my desktop ubuntu machine.

i have followed the tutorials http://lehwalder.wordpress.com/2012/07/ ... an-wheezy/

and for me it's not working with my RPI.

when i start lcd4linux, i am getting

Code: Select all

drv_init(st2205u) failed: no such driver
but from phack, i can able to send text directly to picture frame. Or if i run st2205uterm simply, i am getting console screen on my picture frame.

please anyone help me to get it work with lcd4linux

Return to “General discussion”