Posts: 1
Joined: Thu Mar 28, 2013 9:37 am

Building Transmission, struggling 3 days with some progress

Thu Mar 28, 2013 9:40 am


I was trying to use transmission on my raspberry. At first I just apt-get transmission-daemon, configured web access and everything worked just fine.
But now I am in a need of using an older version of transmission. However the RPi repos contains only the 2.57 version. And the version I need to use is either 2.22 or 2.33. I was searching for some deb package but without any luck. All the packages I have managed to find were designed for amd or intel arch. There were no arm arch package available anywhere. Maybe I didn't search well enough but I just couldn't find any. So I went to the transmission home page, downloaded the binaries of 2.33 version and started to build it.
At first italics./configre was resulting with ssl errors. So after some fights with dependencies I figured it out. All I needed was to

Code: Select all

apt-get install ca-certificates libcurl4-openssl-dev libssl-dev pkg-config build-essential checkinstall.
After that ./configure went smoothly at this step but stopped with error at the libevent check. The error stated that libevent in version >= 2.0.10 is required. However RPi repo contains only 2.0.8 version. So all I did was:

Code: Select all

wget https://github.com/downloads/libevent/libevent/libevent-2.0.18-stable.tar.gz

    tar xzf libevent-2.0.18-stable.tar.gz

    CFLAGS="-Os -march=native" ./configure && make.
And here to problem that I just can't solve happens. I receive an error sation that gcc compiler is not installed. I tried checking is gcc works correctly with:

Code: Select all


    string=$(gcc helloworld.c -o helloworld)

    if [ string -n ]; then

    echo "Failure"


    echo "Success!"

But have not receive any prompt. Bash just skipped to the next line and nothing really happened. So please, can any one help me with this?
Sorry for my English, I do realize that my grammar sucks hardly :) If something is unclear just let me know in the comments and I will try to explain it.

Posts: 428
Joined: Mon Jun 04, 2012 9:06 pm
Location: Berkshire

Re: Building Transmission, struggling 3 days with some progr

Thu Mar 28, 2013 11:42 am

post output of "echo $PATH"
does just attempting to run gcc work?

Return to “General discussion”