stubz151
Posts: 6
Joined: Fri Dec 07, 2012 4:24 pm

Help with error

Sat Mar 16, 2013 3:06 pm

I got a PI but when i try boot off my sd card that i got with my PI from rs components , this is the error raspberry pi kernel panic unable to mount root fs, I really don't want to return it as it took 3 months to get here . Please help

xterm
Posts: 6
Joined: Tue Mar 12, 2013 2:30 am

Re: Help with error

Sat Mar 16, 2013 3:39 pm

May be its just that the raspbian-image was not written correctly onto the sd-card. I experienced this on my own last week, when I was writing an image to an sd-card while doing lots of other usb-related stuff on the usb-hub where my card-reader was attached to. I just rewrote the image to the sd-card and everything was fine.

Before returning your RaspberrPi download the lasted raspbian image and try to rewrite it to your sd-card. http://www.raspberrypi.org/downloads

If that doesn't work try to write the raspbian-image to another sd-card.

It is also possible, that you have a power-problem, when I started my RaspberryPi for the first time I got tons of errors of all kind, they all went away after I replaced my power-supply (and / or micro-usb-cable, it's unbelievable how bad many of this cables can be).

stubz151
Posts: 6
Joined: Fri Dec 07, 2012 4:24 pm

Re: Help with error

Sat Mar 16, 2013 3:52 pm

I have just tried the xbian image I am going to try a few others then swap the power supply

xterm
Posts: 6
Joined: Tue Mar 12, 2013 2:30 am

Re: Help with error

Sat Mar 16, 2013 4:17 pm

Don't underestimate the power-supply, the first time I had to use the shortest micro-usb-cable that I could find (length: about 12 cm), nothing else did work with my cheap usb-charger (5V, 1000mA).
And with most of my cheap usb-cord-extensions the voltage on the RaspberryPi dropped to 4.5V.
After that I connected my power-supply directly to the associated GPIO-Pins that worked good (Warning: This may easily destroy your RaspberryPi if you do it the wrong way!).
Meanwhile I have, still cheap, but better micro-usb-cables and usb-chargers and everything is ok.

But just to be sure also try to use another sd-card.

stubz151
Posts: 6
Joined: Fri Dec 07, 2012 4:24 pm

Re: Help with error

Sun Mar 17, 2013 8:39 am

I made a wheezy bootable sd card and it works fine it bust just be the raspbmc iso i downloaded , do you know of any other good media os's for RPI

Spid
Posts: 525
Joined: Sat Jan 19, 2013 12:47 pm

Re: Help with error

Sun Mar 17, 2013 8:41 am

Raspbian
Xbian
Openelec

XBMC installed from within a Linux Distro............
I will always assume you are running Raspbian for desktop and Raspbmc for XMBC !

Return to “General discussion”