sim_tcr
Posts: 338
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
Contact: Website

2013-02-09-wheezy-raspbian crashed and had to reflash SD.

Wed Feb 20, 2013 6:46 pm

I had flashed 2013-02-09-wheezy-raspbian 3 days back and all was running fine. Suddenly today pi went out of network. Pulled the power and connected back. It was still not coming to network. Connected a display and turned it back on display was stuck with below prompt and keyboard wont respond. Full error message screenshot at http://raspisimon.no-ip.org/pics/IMG004 ... 0-2336.jpg
I reflashed 2013-02-09-wheezy-raspbian again.

Code: Select all

Entering kdb (current=0xda82ac80, pid 1) due to Keyboard Entry
<kdb>
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)

User avatar
alexeames
Forum Moderator
Forum Moderator
Posts: 2869
Joined: Sat Mar 03, 2012 11:57 am
Location: UK
Contact: Website

Re: 2013-02-09-wheezy-raspbian crashed and had to reflash SD

Wed Feb 20, 2013 9:33 pm

What kind of SD card are you using?

I noticed back in September that a weird mixture of overclock settings, new releases and cheap SD cards was a recipe for frustration and frequent file system corruption.

It may not be any of those things, but your situation rings a bell.
Alex Eames RasPi.TV, RasP.iO

sim_tcr
Posts: 338
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
Contact: Website

Re: 2013-02-09-wheezy-raspbian crashed and had to reflash SD

Thu Feb 21, 2013 3:52 am

alexeames wrote:What kind of SD card are you using?
I use Transcend 16 GB Class 10 Card. The previous image on the same card did not have any issues.
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)

User avatar
pluggy
Posts: 3635
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
Contact: Website

Re: 2013-02-09-wheezy-raspbian crashed and had to reflash SD

Thu Feb 21, 2013 11:30 am

Hint, lose the fixation with class 10 cards. I have 4 Pis, I'm always doing unholy things like unplugging then without shutting them down. I've yet to experience a corrupted SD card. Plain vanilla Sandisk class 4. They beat a lot of class 10's for read speed which is where it matters. No problem whatever with 2013-2-09, it works like all the others.

Or maybe I'm just a cheapskate ol' dinosaur who likes a quiet life.....
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......

sim_tcr
Posts: 338
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
Contact: Website

Re: 2013-02-09-wheezy-raspbian crashed and had to reflash SD

Thu Feb 21, 2013 11:34 am

pluggy wrote:Hint, lose the fixation with class 10 cards. I have 4 Pis, I'm always doing unholy things like unplugging then without shutting them down. I've yet to experience a corrupted SD card. Plain vanilla Sandisk class 4. They beat a lot of class 10's for read speed which is where it matters. No problem whatever with 2013-2-09, it works like all the others.

Or maybe I'm just a cheapskate ol' dinosaur who likes a quiet life.....
I have a two pi's one with Transcend Class 4 8 GB (image is the one before 2013-2-09) and another one with Transcend Class 10 16 GB ( 2013-2-09 image).
Can you suggest some simple command to run on both to see the performance difference between two cards?
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)

User avatar
pluggy
Posts: 3635
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
Contact: Website

Re: 2013-02-09-wheezy-raspbian crashed and had to reflash SD

Thu Feb 21, 2013 11:42 am

http://elinux.org/RPi_SD_cards

Quite a way down the page is a bit on Performance.

Higher class cards write fast, that's what the class is all about. Read speed isn't defined in the class, and reading is far more important than writing for Linux. You'll need to run the write bit first since the read bit uses the file it creates.
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......

poing
Posts: 1132
Joined: Thu Mar 08, 2012 3:32 pm

Re: 2013-02-09-wheezy-raspbian crashed and had to reflash SD

Thu Feb 21, 2013 3:32 pm

pluggy wrote:Hint, lose the fixation with class 10 cards. I have 4 Pis, I'm always doing unholy things like unplugging then without shutting them down. I've yet to experience a corrupted SD card. Plain vanilla Sandisk class 4. They beat a lot of class 10's for read speed which is where it matters. No problem whatever with 2013-2-09, it works like all the others.

Or maybe I'm just a cheapskate ol' dinosaur who likes a quiet life.....
The other day I saw a picture of the card that you use. I have the exact same ones (7 of them for four Pies), do a lot of power plug pulling and also never ever had a corrupted SD card.

Sadly they seem to be out of production; the only ones I can still find with the same appearance are Class 2 cards - not sure if it matters.

Return to “General discussion”